JPLAY ASIO driver not compatible with Roon Labs version 1.2?

Today I read the good news that Roon updated the software to version 1.2 so when I came home today I did the update to version 1.2
With the previous version I felt very happy and confident with the combination of Roon (as mediaserver) and JPLAY ASIO driver + Fidelizer Audio Pro 7.1. as sonic optimalizer software.
I never experienced any serious problems so far, but after the update to version 1.2 today I noticed several times that the JPLAY ASIO driver seems to be not compatible with Roon 1.2 :rage:

In the Roon audio settings I can see the JPLAY ASIO driver and I am also able to select it, but after the selecting process there will be no sound at all. When I switch to the JPLAY ASIO driver settings again the ‘‘Loading’’ icon appears and keep activated for an indefinite time. During this process the JPLAY ASIO driver disappears and appears alternately.

Strange enough I can select the Devialet ASIO USB in the Roon audio settings and that option doesn’t give any problems and seems to be stable and compatible.
My set up contains a Devialet 200 (with use of the internal dac) + a computer audio transport renderer with Windows 10 OS.

I really love Roon as a mediaserver, but I prefer to combine it with JPLAY and Fidelizer Audio Pro because that combination gives me the best of all.

Hopefully Roon is not using policy rules against JPLAY software like JRiver…

If you send some DSD to the Devialet ASIO USB driver it will start doing the same thing.

Have not try that so far, but 192 khz 16/24 bit music files are no problem.

I’m really curious if there will be a solution for this annoying problem.

If it worked with 1.1, then it’s far more likely to be the complete rewrite of Roons audio architecture that’s causing some issues. I don’t see any hint of Roon having ever used policy rules or tried to block anything - quite the opposite in fact.

Sorry can’t offer any help but I’m sure it will get resolved quickly.

We’re going to look into this @Jan_Forman. Thanks in advance for your patience here.

Same issues for me.

1 Like

This problem occurs for me when I try to play HiRes files. I’m using JPlay and Fiedelizer free with RoonServer and Windows 10 on a lenevo pc with I7 core 8MB RAM and SSD. Music is stored on a local USB drive. DAC is a NAD M51.

Works fine while I stick to tidal and cd files (WAV) but when I swap to HiRes file just skips from one track to the next without any sound. Sometimes if I go back to cd files they will play oth time I get the same skipping behavior and have to restart the Pc to get things working again.

I also lost all devices on the Core not just jPlay one time and I have managed sometimes to play hires files.

Hope this helps you track this down.

We are having trouble reproducing this problem. I just fired up JPLAY, set it up with a DAC, and all of the formats that should work are working.

It would be good to get the following info from each of you:

  • Screenshot of your JPLAY settings
  • Screenshots of both tabs of Roon’s output settings for JPLAY
  • Screenshots of Roon’s signal path during the failures so we can see what’s playing + any processing happening on our end

Maybe we’ll see something in there that paints a clearer picture about what’s going on.

Thanks for the help. In pulling this together I noticed my JPlay settings were not what I normally use, no idea why. JPlay can be unstable if the settings are not right for your PC/DAC so this might be my problem :blush: I will reset them and see if this is still happening. This will have to wait till tomorrow now, I will let you know how I get on.

Brian, thank you for your reply and time investment :ok_hand:

This morning I started in a fresh and good mood and went further with some setting changes in Roon and JPLAY.
As first I started with a new attempt to see if there were some differences in comparison with yesterday, but unfortunately the situation was unchanged. So, I started to change the audio settings in Roon, but again the same experiences as before.

(undermentioned pictures presents my experiences)

After I experienced an equal situation I started to check my JPLAY settings to see if I could switch something that will give eventually more satisfactory results. so at first I changed the dac link value setting from 170 Hz to 1 Hz and after this I restarted Roon and… Bingo !!
Totally happy after this result I started with further investigation and discovered that Roon not accepts dac settings below 40 Hz, which is a bit confusing to me because with the previous version I was able to adjust the dac settings to absolutely low values without problems. The only thing I had to do was adjusting the values of the pc buffer upwards to 2,5 or 5 seconds (which gave me a less good sound to my ears)

Undermentioned picture presents the JPLAY setting which gave me the solution to get it work properly.
In the meantime I adjusted the dac link value to 40 Hz and it still works good.

I have a same trouble.
And any DAC link setting can’t work.
I’m struggling with this problem.

Well now I’ve got my jplay settings back to what they should be all works fine. Only thing I wonder about now is what is Roon/RAAT doing as I have a 5 sec buffer in jplay and so used to have a delay when taking actions such as pause which have now gone away. :slightly_smiling_face:

I haven’t looked at this again since yesterday (It’s on my list!), but a few comments…

Putting any kind of large buffer beyond RAAT is kind of begging for trouble–we’ve evolved our approach to clock management quite a lot in 1.2, and we are trusting that drivers that claim to ASIO present their timing behavior to us very honestly–both with respect to playing in real-time, and with respect to latency reporting. We were less dependent on this stuff being implemented properly in ASIO drivers in 1.1.

If you have a big (>500ms) buffer in JPLAY, it might help to increase the “Resync Delay” setting in Roon to a corresponding level. That way, Roon will fill JPLAY’s buffer with silence and stop making assumptions about clocking/timing during any faster-than-real-time buffering that JPLAY might be doing.

Another thing to consider–RAAT+Roon is a lot more JPLAY-like than Roon 1.1 used to be:

  • Like JPLAY, RAAT runs in an isolated process from the main Roon app, so behavior of the main Roon server/UI is much less likely to influence the audio.
  • Like JPLAY, RAAT has a large memory play buffer inside (similar to JPLAY’s PC buffer). Thinking through this from a technical perspective, this likely negates the influence of their PC buffer.

The ideal settings with 1.2 might be quite different from 1.1, and are probably more conservative (i.e. RAAT is doing some of these things now, so JPLAY can be set up to do less).

I don’t completely understand what the “DAC Link” setting means–according to their specs it has something to do with recovering the DAC clock, but that seems like a strange thing to attach to a setting measured in Hz–keep in mind that RAAT also drives its audio delivery based on the DAC clock, just like Roon 1.1 and Roon 1.0 did.

Thanks Brian. Yes I was think that maybe RAAT was closer to Jplay now. I have just been trying output direct to my NAD asio driver and though the difference is less than it used to be i think Jplay still sounds better. No idea what they do. Will try some different settings as you suggest and do some more critical listening.

I took another look…the DAC link setting controls the ASIO buffer size (from our perspective). If I set it to 1hz, then JPLAY requests roughly 1 buffer per second. And so on. The numbers aren’t exact, but the correspondence right as I change the value.

I do see it failing to play if I set DAC Link to >85hz. Our code doesn’t really care (or make assumptions) about what the buffer size is.

Anyways, when I try to set DAC Link > 85hz, and instrument our code to see what’s going on, it seems like JPLAY requests a handful of buffers from us, then stops requesting, and everything hangs. While it’s possible that 1.2’s changes are related to the problem, the actual mechanism of failure doesn’t look to be on our side–we’ve got audio ready and JPLAY simply isn’t taking it from us. I’ve checked to make sure that nothing in our code is hanging–and it isn’t. In fact, we’re executing nothing, just waiting for the next audio “interrupt” from JPLAY with a request for more samples.

BTW, I am guessing the pause delay is gone because in 1.2 we no longer cut the stream when you pause–now pause causes us to play silence for a little bit before cutting the stream. In 1.1 we would stop streaming and start fresh every time you took actions on the transport. 1.2 is much smoother (really important for S/PDIF, AES, etc connections, which have to do an expensive unlock/relock every time we break the stream).

Interesting, makes sense. I always learn something from your posts, much appreciated.

From the past looking on the JPlay forum it seems there are many DACs that simply don’t work with higher DAC Link values (mine included) so this behavior could well be your DAC.

Hi @Jan_Forman,

Have you resolved your issue with the JPlay ASIO playback? I’m facing the same problem and wondering if you found any solution?


To my opinion the installed Renesas driver for the PPA V2 PCIe-USB card was mainly causing the experienced problems here.
After I switched to a friend,s borrowed SOtM PCIe-USB card with installing the Texas Instruments driver it became a remarkable situation to me to see that Roon at that moment found the JPLAY ASIO driver quickly without noticable problems.
Not even the sound of the SOtM was by far better than the PPA, but even the T.I. driver of the SOtM seems to be the better one in avoiding possible software conflicts.
Although, during the many hours of listening after the switch I noticed again a few random times stability problems with the availability of audio drivers in the audio setting.

Yesterday I saw that there was a software update from Roon and installed it. After the software update I have not experienced the stability problems with finding the audio drivers so far, but maybe it’s to early to say that it’s working flawless…

Will post my further experiences here :wink:

After running windows updates on my audio PC I can run ROON with JPlay ASAO driver in a dual PC setup and it sounds REALLY good. If I play tracks of the same sample rate everything plays OK until ROON starts a song with a different sample rate and then it just stops. I need to disable/re-enable audio device in order to play a different sample rate.

Basically I have a problem putting tracks with different sample rates into the same play queue in ROON if I use JPlay as audio device.

Can anybody suggest a solution?

Play with the resync delay setting try .5 seconds or more. It might help.