Keeping Roon Running when logged out

Hi Folks,

I am running ROON on a Win10 Pro PC that has no monitor or keyboard. I want to keep the room server running when I am logged out. Is that possible or does the user have to remain logged in for the server to run?


If you’re running Roon Server on a headless server, then just make sure you have checked the “Launch at startup” option, so that Roon Server will start up when Windows starts. Then you don’t need to be logged in as a user.

You can set this option by using Remote Desktop or Teamviewer from another PC to access the headless server. Remote Desktop will require that the server is running a Pro version of Windows. I think Teamviewer will work with any version.

1 Like

I have that box checked and two things happen:

Although I can see the server from my phone and it appears to be playing, I don’t hear anything. As soon as I log in remotely or with a local keyboard it works. As soon as I log out of the session it stops working again…

This is an absolutely clean PC…

Any thoughts?


Another thing of importance… The USB audio speakers show up and I am able to select them in both cases…

What audio devices have you defined in Roon? Screenshots would be helpful.

It sounds as though you have your audio devices connected directly to the Roon Core running on your headless server, and indeed I can see that the WASAPI device is only present when someone is logged into the server. It may be possible to use the System Output and bypass the WASAPI mixer. I’ll do a bit of experimenting here on my NUC.

No luck here, I’m afraid. Windows 10 has a mind of its own.

One thing you could try is to set up an auto-login, so that when Windows starts, it will also auto-login into the user account used for your Roon Server. You’ll need to access netplwiz to set that up. See this article for step by step instructions:

This may then keep your user account logged in without the need to log in remotely.

You are correct, the server s also the playback box. I am guessing that this is not the intended configuration? What I would like to have is the Windows 10 PC be able to play music remotely via a phone, iPad etc. The PC is located in a place where I really don’t want to have a monitor or keyboard hanging around.

Could you suggest a better setup?


[quote=“Ed_Cohen, post:8, topic:14920, full:true”]
What I would like to have is the Windows 10 PC be able to play music remotely via a phone, iPad etc. [/quote]
Roon Server is supposed to support both Control and Output functions, according to the Roon architecture. Most of us are using Output Zones distributed over the network, so we don’t need to be constantly logged in to the server. However, it would appear that directly connected output devices fall prey to this “must be logged in” snafu.

I’m flagging @support here to see if they can suggest a better workaround for your situation than the auto-logon trick I suggested earlier.

Interesting… So when you have Output Zones are you using a PC or is this a device?

I actually have an extra server and could make this PC a Output zone if that gets me around the issue of having to remain logged in…


I don’t actually have any zones that use the output hardware/software of my Core server. All my endpoints are distributed over the network. like so:

Some of the Roon endpoints are on PCs, which also act as Control devices for Roon. And there’s the rub, when I’m using a PC as a Roon Endpoint (in addition to it being a Control), I’m logged in to it.

What you could try is to download the Roon Bridge software to your extra server, and see if that will work as an endpoint without your having to be logged in?

Edit: or even try installing Roon Bridge onto your Core server, to see if that will work?

Hey @Ed_Cohen – Roon installs to the user’s App Data directory which, among other reasons, gives us a lot more flexibility for how we update.

This is done specifically with setups like yours in mind, so you’re able to click a button on any device in the house and your Core can update, as opposed to requiring that you log in remotely and give permission to the update directly on the Core machine.

This also means is that Roon requires the user is logged in to run. If you don’t intend to connect a monitor or keyboard to this machine, you’ll just need to configure Windows to log in automatically, and you’ll need to configure Roon to run at startup.

Nice diagram…what app did you use for that?

I bet the support guys wished everyone did a diagram like that and maintained it…hence the question!

1 Like

@Paul_Chatfield - it was done using Grapholite. Think of it as a poor man’s Visio - it works in pretty much the same way, but is orders of magnitude cheaper. It’s also supposed to be able to import Visio files, but that doesn’t work for me. It may be because my Visio dates from the 2003 version. New diagrams I create, I use Grapholite (the Windows 10 App version); and I just keep Visio around to maintain the old ones.

@mike - thanks for your reply. So my auto-logon trick is the way to go. Good to know for future reference. Perhaps I should write up something about this situation for the KB?

That would be great. Definitely drop me a line if you have any questions @Geoff_Coupe.

@Ed_Cohen - so I’ve tested the Auto-logon approach on my headless server (an Intel NUC), and it works, but there are a couple of things to bear in mind:

1 - the setup instructions in that link I posted earlier are slightly different if you’re setting up your Auto-logon via a Remote Desktop session. Once done, and your server rebooted, it does indeed perform an auto logon, and you can set up your directly-connected endpoint in Roon and use it.

2 - However, if you ever start a Remote Desktop session to your server for whatever reason, this will break your Roon endpoint. You will need to restart your server to restore the endpoint again. Roon remembers the setup information for the endpoint, so it should automatically appear once the server is restarted.

Re (1):

  • in step 3 of that link, via a Remote Desktop session, the “Users must enter a user name and password to use this computer” checkbox is already unchecked, and if you click Enter, as the instructions say, the window is closed. You need to first check, and then uncheck, that box. Then you will see that the Apply button (which was greyed out) is now selectable:

Click that, and then you’ll get the dialog box to enter the user account and password to be used with the running Roon Server:

Complete this, close the windows (by clicking the ‘OK’ buttons), reboot the server, and you’re all set to define your directly-connected audio devices in Roon.

While not a windows issue, a headless macmini with no display connected will not show USB connected devices, without running a display faker app or a dummy HDMI/VGA/DVI type adapter - I think I posted this elsewhere too

Ah here it is Running headless and GPU issues

Hey @Geoff_Coupe – we took a look and I think the issue here is Remote Desktop. When you log in remotely, it basically passes control of the local devices to the remote computer, and from Roon’s perspective, the audio devices just disappear.

Remote Desktop is also known to cause issues with OpenGL (which may or may not be an issue for a headless setup) but point being, it tends to provide remote access in a pretty heavyweight way.

For what it’s worth, I use Team Viewer quite a bit, and haven’t seen anything like this.

@Ed_Cohen – let us know how you’re getting on here, ok? Thanks guys!

@mike - yes, indeed this is what happens. The bummer is that when the Remote Desktop session is closed, Roon can’t grab the devices back. That’s why I said that a reboot is necessary.

1 Like