KEF LS50 Wireless Zone icon

The zone icon for the LS50 Wireless speaker haș changed to a headphones icon. How can I change it back?

For the wireless connection Roon displays the proper icon. Only the USB connection displays the wrong icon.
I tried to remove the device from Roon and add it back, restart roon, restart computer, restart speakers - nothing works. The change icon menu only has generic icons, no device-specific icons there.

Any advice on how to force roon to use the device specific icon?

I think you have to click through into DEVICE SETUP and change the icon there…


EDIT: …and then change the Zone Icon to the default Device Icon

tried that - but Roon shows the headphones as default device icon for the LS50Wireless…

Have you changed the device icon first ?

not sure what you mean.
when I first set up the device it had the proper icon. then I played with the DSP headphone presets, but none of these are enabled. I think this is what changed the icon and now I can’t change it back

As per the screen grab in my first post, you need to go into the DEVICE SETUP and find the KEF LS50W icon.

Apply that to the device settings and then go back into the ZONE SETUP and the default icon in that list should now be the LS50W icon.

Here is the process for my end point;


Hope this helps.

1 Like

I am afraid not… I tried all that; sorry, but I can’t show a screenshot here since I’ve left home.

But in my case that default icon for the LS50W is the headphones icon…

So you cant find the KEF LS50 icon in device setup at all?

exactly. Even after I used “find my device”, then choose KEF from the list, etc
Even after I disabled the KEF device and so on. Not sure how to reset this, it seems that roon is stuck on the association between the device and headphone icon. Maybe I’ll try a clean re-install of roon when I get home, if no other suggestion comes forth

maybe you need to unplug the speakers and then reboot your core and the device they are connected to (if they arent the same ) and try re adding them from scratch.

The headphone icon should go away as soon as you remove the “Audeze Presets” filter module from the DSP settings for this zone. If you changed the zone icon in the mean time, you might have to change it back to the “Default Icon”.

1 Like

that was it,marked as solution
thanks everyone!

1 Like

thanks a lot, really appreciate you takin the time tryin to help me!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.