KEF LSX II is not showing as Roon Ready

Hi Folks

Roon is ruuning the latest version(v2 build 1193) & KEF LSX II is running v1.3

For some reason KEF LSX II is not showing up under “Audio” section as “Roon Ready”. I can play via Airplay.

Anyone facing similar issues?

I did try restarting the core and LSX II, doesnt help :frowning:


I’m sorry that you’re having trouble. I’ll warn you in advance that I don’t have confidence that this is going to be a helpful post :frowning:

I have a pair of LSX IIs as well as two pairs of LS 50 IIs. All three pairs have worked flawlessly once on appropriate firmware versions.

You’re on 1.3, which is the latest. So no firmware issue.

I have seen reports of people having issues while on wireless. You don’t mention how your speakers are connected. Are they wireless?

There have also been reports of people having issues with specific vendor’s ethernet switches - I know for certain people have had issues with TP-Link switches. Possibly other vendors as well. Since the LSX IIs are so small, I recommend you try a wired connection on the same switch or router that your core is connected to. You can do this with just the primary speaker to test it out. That may not be a long-term solution but at least it’s a test you can do to help figure this out.

Sorry I can’t point my finger directly at the issue and help get you working but maybe there’s something here that’ll help.

[Edit : Here’s a thread that includes people discussing TP-Link as a potential culprit behind an issue similar to yours though it pre-dates KEF’s Roon Ready implementation so may actually not be relevant: KEF Roon Tested disappears and leaves only Airplay option]

Hi @gTunes I have connected the speakers through WiFi. My router had no ports left so I have to buy a Network switch. I see a cheapest one of TP-Link (TP-Link LS105G 5-Port 10/100/1000Mbps Desktop Network Switch | Officeworks)

But this is TPLInk made so will there be any issue?

Reboot your network gear, Kefs and core. This can often trigger it to show up.

I have connected the speakers to the LAN using an ethernet cable and that seems to have fixed the issue. Roon now shows LSX II as “Roon Ready”.

Quick clarification though, on the KEF app the “Wifi” option “Remote” is still enabled. Why is that?

1 Like

Glad to hear you got it working!

Is the WiFi option you’re referring to the “Wi-Fi” option in the picture below? If so, the name of that button is always Wi-Fi. It doesn’t change based on whether you are cabled or on wireless. It always acts as the network input.

1 Like

Just consider as ‘network.’ If you have the Ethernet plugged in, that takes precedence and the speaker is no longer WiFi to the network.

1 Like

Thanks @gTunes and @Ben_Hagens
Much apprecite the help :slight_smile: