KEF Roon Tested disappears and leaves only Airplay option

I keep losing my Kef streaming option and have to use airplay - which affects SQ

I have been emptying the image cache and rebooting Roon in order to solve the problem - but after an hour of listening (more or less) the music stops and the ‘Roon Tested’ option to use KEF streaming instead of airplay is lost. until I empty cache and reboot again…

this is the difference between Roon making the KEF LSX sound fabulous and making them sound okay.

the core is on my iMac 24 - and this machine is connected to my router via 1gb network switch with ethernet cable - my Kef LSX are also connected to router by ethernet cable
my Kef LSX are also directly connected

I just tried removing power cable from Kef LSX master for 30 seconds - it would be so cool if this worked!

update - tried unplugging - didn’t correct the problem

Roon Core Machine

iMac 24 8 gig

Networking Gear & Setup Details

ethernet connected via I gig tp-link network switch
Kef LSX also ethernet connected via this switch

Connected Audio Devices

KEF LSX ethernet

Number of Tracks in Library

small library 90 albums collected in last few days from TIDAL

Description of Issue

SQ is fantastic when I get to use KEF streaming option in settings/audio
but this option only shows up after I empty the image cache and re-boot (and not always then)
and then it disappears suddenly after about an hour or sometimes less of playback

this is a serious enough problem to undermine interest in Roon - which otherwise is a bit of a revelation!

I just tried unplugging master KEF speaker for 30 seconds and then plugging it back in - after about an hour I’m told after music stops playing to ‘select an audio zone’

I have the LSX speakers connected directly to router via a 1 gig network switch, with ethernet cable (the iMac is connected to router via same switch with ethernet too)

but it suddenly struck me that the the LSX use wifi even if they are connected with ethernet cable

is that right?

then I checked my wifi - which should have been fine but turned out not to be.

the bandwidth readings I was getting in my listening room were very poor - sometimes below 1 mbs.

I have corrected this problem and now have around 300 meg per second on the 5g network.

I am hoping this solves my problem - and Roon keeps hold of my LSX - so I don’t have to use airplay to connect to the speakers

I thought it had something to do with Roon’s image cache - and I was thinking long playlists and going from one screen to another was causing the cache to fill too quickly…??

more likely rubbish wifi - does that seem more plausible?

wifi fix did not fix the problem

blown away by the community here guys and gals

did I offend somehow? - by admitting to having a small…


it is small in size but big in spirit

and I still keep losing my nice hi-fidelity connection via Kef streaming

but when I empty the cache and restart Roon the Kef streaming option usually re-appears very quickly

Jon sorry no one has been in touch, but it can take @support a couple of days to get through their queue.
Hopefully someone will be along to help you soon.

Sadly I have no experience with KEF speakers, but they look great and I wish I had.

1 Like

I have Kef LSX speakers and they can be temperamental with Wifi connections. KEF specifically mention that Wifi mesh systems are not recommended. However, I have an Eero mesh Wifi network and the LSX speakers are 3 metres from the main router. Very occasionally the LSX speakers will not respond to Roon (or the appalling KEF apps). The Roon app can see the speakers but the Kef app cannot find them on the network. To fix this, you need to unplug both LSX speakers for at least 60 seconds and then power them up again. When I did it for 30 seconds and 1 speaker, I did fix the issue. This fixes the issue for me and the world can breath again!

Not sure what network system you, but ideally you should assign the LSX to the 5Ghz frequency according to KEF. I cannot do this with my mesh network.

1 Like

Frank I seem to remember some users in the past also trying Ethernet over Power adapters to get them working well.
I don’t know enough about the KEF setup to recommend that.
Also not all Powerline adapters work well with Roon so it’s worth doing a search through the forum’s, as there are a number of recommendations here of one’s that worked well (though Roon do not recommend them)

Thanks Michael. I have a collection of power adaptors collected over the years, buried in the attic :grinning:.

The loss of connection occurs maybe once a month possibly after the Eero network updates itself. I can live with the occasional 60 second reboot of the LSX speakers. After all they are supposed to be wireless so I’m determined to keep them away from the old power adaptors!

They are great little speakers, amazing for the size of them!

1 Like

Fair enough and I’m not a fan myself, but sometimes needs must. It was as much for Jon as yourself though :grin:

I did want a pair in my study, but already too many music options there. I do read about quite a lot of WiFi issues with them though, which slightly put me off

I still have one power adaptor in use with a Sky Q mini box. It sorted out the connection dropouts from the main box. Works a treat.

Hope the Wales rugby play well tomorrow but not too well. I’ll be at the match. Come on Ireland!

1 Like

I don’t hold out too much hope for us, but hopefully we keep it close.

Sky Q boxes always seem to be a disaster when it comes to WiFi

1 Like

Thanks guys - appreciate the ideas

I’ll try the 60 seconds unplugged for both speakers - that might help

would be great to sort out the problem - the system sounds really fabulous when its all working properly


1 Like

Hi @Jonathan_Trigg ,

Is the behavior the same if you set up Address Reservation in your router (to ensure that the IP of the KEFs doesn’t change)?

What are you rebooting to get them back? The iMac Core?

Is this a Managed or Unmanaged switch?

the ip of the KEF’s does not appear to change - and is the same as on indicated on the KEF connect app

  • I am emptying the image cache from the settings/setup menu and this causes Roon to re-start. 4 times out of 5 the KEF streaming option re-appears after re-start.

I don’t know what a ‘managed switch’ is - but this seems to be very simple - this is it:



1 Like

Thanks for that additional info @Jonathan_Trigg .

Are there any patterns to when the KEFs disappear? Does it by any chance only happen when you play 96kHz and above content?

well - that certainly does not seem to be the pattern…

I will look for other possible patterns

I don’t know why it should be emptying the image cache which does the trick

can I make that cache bigger?

I wonder if the new update will stop them from disappearing…

I just got this problem as well, few days after setting this up. It just dissappeared. I can find the LSX via airplay, but that’s not what I want of course.

Such a shame, because I liked the integration, when it was working, seeing as i could change volume etc. too, directly from Roon.

Aren’t there more technical ways (ie. via ssh or something) to run some diagnostics?

I have quite some Linux experience,…

Just after posting this, I tried rebooting a network switch, and now it shows up.

So my situation is that my Roon Core is connected to a different network switch, and my kef lsx connected directly to my router. It’s on the same LAN, but somehow rebooting the network switch between Roon Core and router + kef, did the trick.

hope this helps someone

Cheers Marten

As i’ve mentioned i have a reliable way to get the KEF Streaming (‘ROON tested’) option to re-appear - and that is to re-boot the local cache on the settings/setup page

i have just rebooted the two switches between me and my router - lets hope that makes a difference

my kef streaming option disappears roughly every half an hour

i notice that the longer roon is open the more RAM it takes up - if it stops after 20 mins it is taking up around 300 meg - if after an hour and a half - around a gig.