KEF Wireless2 - What happened to on/off switch in Roon?

I’ve been using my Wireless2 with Roon for quite some time and have always been able to turn off the speakers from the Roon app by just clicking the speaker in the lower right hand corner of the Roon screen and then clicking the on/off button. Today that on/off button is not there. It just shows the sleep icon, DSP, the two bi-directional arrows and the gears icon. My main system is a Lumin T2 and the on/off button is there. What happened? Was this a change in the software or is it just happening to me?

1 Like

Have you tried rebooting the speakers? I’d suggest turning them off (i.e. off rather than standby). If that doesn’t help, try rebooting everything else (core, router, network switches, etc).

Same issue here. I’ve tried rebooting without success.

There was a KEF firmware update the night before last so it is possible that’s somehow triggered the problem. This has always been a very convenient feature

I too just noticed this as well on my wireless II speakers. Definitely a feature that I liked.

Has anyone figured out a fix for this yet?

Would appreciate it if someone from KEF and/or Roon would comment on this.


No fix as far as I’ve been able to discover having gone through all the usual reboot procedures. I hope everyone is reporting this via the KEF app as I have done - hopefully this encourages a fix. I still suspect that this is a KEF issue brought about by the latest FW update a few days ago.

I share the suspicion, but don’t have anything to go by.

Perhaps @Ben_Hagens has any insight from KEF on this matter?

I’m not with any of my units as I’m out of office, away from home and out of country (including a wonderful 55 hour period of being awake starting Monday morning thanks to flight delays and cancellations. I don’t recommend it). I don’t see anything in the release notes of the last update that would suggest any change, but I’ll ping an email anyway. All I can suggest in the meantime is reboot your Roon server, and send logs via KEF Connect (just in case).

1 Like

I received a response from KEF support. They referred me to Roon support. So I guess that is what we should do.

Hmmm, might have been nice if Kef support had undertaken to work with Roon to determine the cause of the issue even if it is not down to Kef software (are they sure of this?). It is their product (LS50W2) that’s not working properly and there are obviously a number of folk affected.

I agree. Now we will see if Roon support refers us back to KEF. #support are you listening?

It looks like either Roon or Kef got it fixed. I noticed today that the power button was back

So I see. Thanks for the update.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.