Khadas Tone Board help please

Core Machine (Operating system/System info/Roon build number)

Linux mint, 1.7 build 511

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear wired to pc

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB to khadas Tone board

Description Of Issue

I can see the khadas dac as an output device but once enabled roon says device not found as in pics.

Any help appreciated

Hi @Daniel_Bunton,

Are you able to enable other zones properly and this behavior occurs only on the Khadas zone?
Is there any change in behavior if you reboot your Core + Khadas DAC?

Hi @noris thanks for the response

My only other zone Linn Akurate DSM works fine. This behaviour only happens with the Khadas zone.
No behaviour change with multiple reboots of both Khadas and Linux PC. Also have the same behaviour with all 4 USB ports

Hi @Daniel_Bunton,

Thanks for confirming the above. Do you by any chance have another PC around the house running Windows or MacOS which you can try installing RoonBridge on and connect the DAC to that PC? I wonder if this is a limitation due to the Linux OS, I did see the Khadas docs saying most Linux versions should be compatible, but this would be a good test to eliminate the OS from the equation.

@noris Thanks again for the reply.
I should have tried this before posting but was hoping it would have been a known issue.
Works fine from a Windows 10 PC.
I may have to contact Khadas to see which Linux OS are known to work. Linux Mint is just a lightweight version that I was hoping would be enough but I am having a few other issues too so maybe a different OS is the go.
You guys wouldn’t know what Linux OS is known to work?

Thank you

@Daniel_Bunton -

We don’t have this device in-house so it’s hard to say with which OS it works, reaching out to Khadas is the best bet to find out this info.

Thank you I just did that

The other thing I should mention is that the DAC works perfectly from the Linux PC from a web browser ie youtube, tidal etc.

it only seems to be Roon that doesn’t work

Hi @Daniel_Bunton,

Thanks for confirming that the DAC works in the web browser, I was not aware of this aspect. Sincethis is the case it should work in Roon. Can you please upload a set of your Roon logs to Dropbox / Google Drive / your preferred file transfer service by using these instructions? I would like to take a look for any error traces there.

Thank you. Just sent the link in a PM.

As a bit of feedback this seems like a very abnormal process and a little bit of a pain. Other software I have used usually has a send logs or send reports button.

Still very appreciative of your time and help

I have a Khadas Tone Board working as an endpoint off of a RPI3 running Ropieee

Hi @Daniel_Bunton,

Thanks for sending those logs. I spoke to the technical team regarding them and they have noted that Roon is failing to open the ALSA driver for this device. I know you mentioned it worked in a browser, but it is very possible that the browser was using a different driver implementation and not ALSA. I would test the behavior with another distro, such as Ubuntu.

Thank you
When I get the time I will try that and get back to you. Will see what Khadas say too

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.