KPN Glassfibre - "Can't find UPnP Service with WAN IP" in Diagnostics [Solved - Bind Core IP Address to DHCP Pool]

Can’t get ARC working since I got myself a new computer recently (Roon Core on Mac Studio) and a new modem/router because of changing to glass-fiber internet.
I’m not an expert on this sort of thing so can someone help me out? In my modem/router I checked if Port Forwarding (see picture) is on and it is…

Anyone? Thanks!

Diagnostics data:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}

You need to give the make and model of the router

here you can check if your port 55000 is open and reachable
and if the shown IP adress is the same as in your router. If not your ISP has shared adresses and you could contact your ISP for a static IP or public IP

Port 55000 is closed but IP address shown in tool is the same as my router’s…

Maybe I need to do the data manual?

so i would try to do manual port forwarding and disable UPnP
or ask ISP if there are limitations from them for port forwarding

  • End of Ideas - :slightly_smiling_face:

Thanks Tom!

1 Like

Same here for now :expressionless:

When recently enabling ARC testing on a newly installed core, it struggled when using the default 55000 port, with auto configuration failing. When I picked a different port, it worked immediately with UPNP enabled on my router, and no manual rule currently set for port forwarding. Worth a try?

1 Like

I did, without succes however. Maybe it has to do with the difference between IP addresses of Roon Core and Modem. But maybe that makes no sense. Like I said before , I’m a total dumb (in this area) :nerd_face:

Hi @Jan_Willem,

Thanks for your patience and for posting. I’ve moved this topic thread over to the #arc-testing:port-forwarding-progress so we can troubleshoot publicly, to the benefit of later Beta testers with a similar setup.

A few things to clarify, if you don’t mind:

  • Who is your internet service provider? I assume this modem/router combo is ISP-provided?
  • Are there any security settings enabled automatically on the new router? Have you disabled DMZ?
  • No other routers in this setup, correct?
  • Have you assigned a static manual IP to your Core? Here are more instructions for Mac.

We’ll proceed from there. Thanks!


Thanks for reaching out.

ISP is KPN glassfiber (Dutch)
No Security settings and DMZ
No other routers involved
No static IP’s involved

Took router out of the box, changed SSID & password, that was all.

Smart to continue this thread publicly. Because I am not a techie and in that way I might be a model for lots of future ARC users :blush:
But this section is not accessible to those 'future ARC users :grinning:

1 Like

@connor It’s working finally! Had to fiddle around with DHCP binding settings…

1 Like

Hey @Jan_Willem,

Thank you for the report! I was actually midway through a response draft message with more troubleshooting when I saw your note, so thank you for your patience and I apologize that I wasn’t able to be of more assistance.

Out of curiosity, did you have to bind the Mac Studio IP address to the DHCP pool?

We’ll definitely keep this noted for future setups. I’ll migrate this to the #arc-testing:port-forwarding-solved section shortly as a Wiki.

That’s correct.
I think it varies per router/modem. My previous one worked well direct after installing Roon ARC.

Hey @Jan_Willem,

Just to confirm for other users, what was the model of router in play here? Was it the KPN-provided modem/router combo? Looks like it from the web UI you shared.