Latest Roon build | Random small popping sounds moving DSP volume, and when selecting play & pause functions

Roon Core Machine

NUC running Roon Rock

Networking Gear & Setup Details


Connected Audio Devices

NUC Rock > Ropieee RPI4 > Motu Ulttralite MK5 > 3x Stereo Purifi amps > Multiway active speaker setup.

Number of Tracks in Library


Description of Issue

Since the latest build the following is occurring (More obvious):

  • When I move the Roon DSP fader I hear low volume “P-P-P-P” (low level digital popping) sounds.
  • When I Pause or hit Play I am getting a noticeable “P” (pop sound).

Before the most recent Roon update play and pause were silent, EDIT: or at least the noise was not as noticeable… But I did get a low level PPPPP DSP sound on volume ramping up and down fast, annoying.

Things I have tried to overcome/diagnose the issue:

  • RPI4: Rebooted Ropieee
  • RPI4: Tried ubuntu server/bridge
  • ROCK: Rebooted NUC Rock
  • ROON SERVER: Tried an alternative build of Roon on my i7 HP elite PC, to serve the RPI4 inplace of the Rock…

No difference with any setup change.

Any ideas how this can be improved?


Are you absolutely sure about that?
What’s in-between RPi and Motu?

I’ve unfortunately not got any improvements to offer, just an observation, which I’d be thankful to get a comment on from @support.

I’ve extensively used two DACs, and intermittently two others on loan, throughout the past ~2 1/2 years and regardless of SW/FW version, interconnections and setup there’s always been more or less strong tics and pops when starting/stopping, ffwd/skipping, or using DSP volume during playback.

My assumption is, that there’s no algorithm implemented in RAAT looking for signal zero-crossing occurrence to then perform the respective command.
Instead, any such command is instantly executed.

Waiting a couple of microseconds at the max for a zero-crossing to occur would eliminate these more or less severe instant sample to sample signal jumps.

1 Like

Thanks for your helpful and insightful reply…

@Marin_Weigel, the connection is USB.
Roon performs all crossover duties/DSP for my setup.

NUC Rock > RPI4 (Ropieee, or Ubuntu/Bridge) > USB > Motu Ultralite MK5 lite > Amps > 3way active speaker setup.

This is absolutely not a DAC or setup issue, the issue seems to be Roon, and the way it handles play/stop, DSP volume. Noting, I have also heard the DSP volume popping on ramping on my RME DAC also.

However these noises seem to be a little worse on the latest build for me, the play/stop pops definitely are.

I will say the pops don’t always occur, sometimes Roon’s DSP volume will ramp perfectly noise free, play stop have functioned without noise also… hmmm.

Seems to be Roon SW/coding issue.

I believe the DSP volume ramping noises have always been present, but since the latest update I have particularly noticed the play and pause “pops”.

Although I have seen other random forum members complaining about this issue also well prior to this update.

Whatever needs to be “tweaked” I would be all for…
The play/pause thing is really not ideal, it makes the software feel clumsy/unfinished.

1 Like

Yes of course, in cases where the command execution by Roon falls between close enough sample values or onto a zero-crossing point just by chance.

There are also recordings, somehow mastered with a DC offset, which causes pops even during silence.

1 Like

Interesting, have you addressed this issue before with Roon Support?

As you have, this user has also complained about sample rate pops.

No, since my issue with this is not annoying me enough to bother.

I’d much rather like some nice fading out/in when skipping tracks, and that’s what I voted for, but Roon has communicated less than being interest in it, because this would result in a major RAAT recode; and I think it would get the bit-perfect squad all puffed-up due to this involving DSP.

And I think, Roon tries to avoid any RAAT recoding anyways, because that would probably cause a plethora of issues with all their Roon ready partners’ firmwares…

1 Like

Well hopefully they can do something to address the issue.

Hey @grizaudio, I just saw your post in another thread related to popping noises in Roon where you said you had resolved your issue with a resync change in the advanced settings for your device.

Are you good to go now?

No unfortunately the popping (PP, PFT) on volume and play pause is not addressed with this change.

That change simply addressed a playback timing difference on Dac clock sync, which is great.

The volume and DSP Play/pause noise is still there randomly.

Marin has described it best above in this thread.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.


I’m curious whether Roon has made any comments concerning audible pops between track skips and volume routing pops/pffts. Searching the forum, it seems other users also experience this phenomenon with Roon.

In my system, I have tried addressing the issue with track delays etc, different servers, network connections, endpoints but the popping randomly occurs on track skips and volume ramping.

As I run an active speaker setup, and convolution filters for crossover, my ability to test without convolution is limited. However it seems many users are experiencing the popping sounds, with no DSP engaged.

The best explanation I could see on the issue was this:

The above link is my original post on my issue.

Related threads, with users reporting popping on track skips and volume ramping.

I was hoping someone from Roon technical might chime in on this.

I still get ‘random’ pops between tracks. Anyone else experience this?

I have tried Ropiee as endpoint, Rock, and Ubuntu/Bridge.

Curious to know if other users get pops between track skips, and small clicking on fast volume changes.

I have tried:

  • Many different end points, Ropiee, Ubuntu/Bridge, Direct to Rock
    (Next I will try Windows (Loathe) - to see if this helps)
  • Inserting a 4 sec delay for sampling rate changes, this is not the issue, as the pop can occur between tracks on the same album/sampling rates
  • Head room 1.5db just for good measure
  • Removed DSP volume, reverting to DAC volume

System has changed a little, but core hardware the same.

Roon Core Machine

NUC running Roon Rock, i5, 8gb

Networking Gear & Setup Details


Connected Audio Devices

NUC Rock > Motu Ulttralite MK5 > 2x Stereo Purifi amps > Active speaker setup.

Number of Tracks in Library

28,000 ish

Convolution Filters (Below Digital 0db threshold)

This is not a clipping issue, providing convolution to confirm for support
-1.5db of headroom reduction is also applied inside Roon atm.
So signals are sitting about minimum 2.5db below digital max.



Hi Marin, are you by any chance still experiencing pops between track skips and clicks on volume ramping?

You bet!
Depending on song played, they’re more or less prominent…

1 Like

Same here, pop strength/loudness varies, and its random.
I’ll have stints of listening where I experience no issue, and other listening sessions with regular pops atm.

I even removed DSP volume control today, reverting the DAC volume, and added headroom control of -1.5db (Even tough I know my convolution filters are below digital 0db limits) but that hasn’t helped.

@noris, It would be great to get some feedback.

With the amount of threads covering this topic, the issue appears to be impacting a number of users on this forum.

I wonder how many users like Marin are experiencing the issue without posting.

From what I’ve read in different threads, RAAT is coded such that currently there’s no way of implementing fading in or out or just zero crossing detection when fast forwarding or skipping or doing volume adjustments.

RAAT recoding could fix that, but would in turn be a nightmare for all Roon Ready device manufacturers needing firmware adjustments and customer updates.

I’m afraid, we’ll never see that happening - something that LMS/Daphile/Volumio/… all handle easily…

1 Like

Thanks Marin,

I very much appreciate you sharing your experience.

So I checked your avatar, it appears you are running Windows.
Since you are experiencing issues on Win11, and I’m using Linux based OS (Rock, Ropieee) this issue appears to be present across different OS platforms.

I might quickly try My Win11 machine but I suspect based on your experience this will not address the RAAT issue.

Keen for Roon support to jump in.