Lenovo P330 Tiny was fine, now gives Open GL missing message

Core Machine (Operating system/System info/Roon build number)

Lenovo P330 Tiny
Core I7-8700T, 32GB, 2TB Samsung SSD 970, 512MB WDC PC SN720
Windows 10 Pro 1909 18363.752
Roon 100700528 1.7 (build 528) stable used to access my catalogue on a Win 10 NUC. Other WIn 10 machines I have work fine.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Intel Wireless-AC 9560 to Google WiFi to BT Hub 4

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

HDMI or headphone port

Description Of Issue

This machine was working until a few days ago, when the graphic driver was auto updated to Intel OBGFX Driver (Windows 10 Version 1709 or Later) - 10 [64] - I have subsequently removed and completely reinstalled this driver via the Lenovo update utility with no change.
Starting Roon gives a fatal error where it could not find WGL functions to initialise OpenGL.

If I connect the display to a Nvidia Quadro P620 DVI port then Roon runs as expected. If I reconnect to the Intel HDMI port Roon continues to work. If I exit Roon and reload it then gets the error message.

The PC is only a few months old and I find it is compatible with everything I run on it.

Any suggestions?

Hi @Derek_Southgate,

Open GL 3.0 is a requirement for Roon and is needed for the UI to function. It sounds like something related to the driver update caused an issue with Open GL on your machine.

How did you reinstall the driver? Did you use Windows for this? Often times we’ve found that getting the drivers directly from the manufacturer’s website will yield the best results.

Try going to the Intel site and looking for a driver update there. Windows update often screws up drivers especially for inbuilt graphics.

The machine/Windows wouldn’t let me install the Intel driver, so I did it via the Lenovo Vantage app which is the ‘proper’ way of doing it. I even deleted the Intel graphics driver (not recommended) which is when I discovered it still worked ok on the Nvidia ports which don’t due 4K or sound. I then reinstalled the Lenovo version of the Intel driver. I somehow doubt that this would have removed the OpenGL functionality, so maybe it is Roon being too picky about what it is testing???

You have gotten some good advice. Try following it. Lenovo maintenance software/servers might be behind or out of spec. Why wouldn’t Windows let you install the Intel drivers?

It does not recognise the driver as being valid for my machine, and tells me to use the Lenovo special version available through the Lenovo Vantage app. It used to work on the Lenovo but they updated their driver on 30th March. I have not yet been able to get a copy of the old driver to test this. I don’t actually see why Lenovo would downgrade that aspect of the driver.

There’s your problem. Anyway, was the message a warning or a prohibition? Could you ignore it and install it anyway? Anyway, I have a recent lenovo tiny pc. I am not having this issue. Windows says my Intel Display Audio driver version is, if that helps.

I have a Lenovo ThinkPad X380 Yoga, and I use Vantage, and it is usually very good. I also use Intel Driver and Support Assistant to get Driver updates direct from Intel, and it works great. I suggest that you try it: https://www.intel.co.uk/content/www/uk/en/support/intel-driver-support-assistant.html

Your account should have Administrator rights.

My display audio driver is also at, but I think the problem is with the graphics driver, which is reported as This is the same version number that the Intel Driver and Support Assistant seems to be trying to install. I will try a driver roll back shortly to see if I get an older version. This has gone to version 7262 and Roon starts. Just got to check if it still works after a reboot…

The Intel DSA won’t install the Intel video driver as it thinks Lenovo have got their own version. So it’s a prohibition for which I do not have a workround. I am using both the Intel DSA and the Lenovo Vantage to keep the drivers up to date.

Rolling back the Intel display adaptor driver has worked, and Roon is working again. I just have to avoid updating it ‘automatically’, and wonder how I report the problem with the new driver to Lenovo/Intel.

1 Like

I have the same graphics driver Anyway, sounds like you got it working. Strange, though.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.