Letting Roon discover a Topping DAC

Good morning, guys.
Just a question, probably silly: at the moment my setup consists in a Merrick 1R computer (a sort of Intel NUC) acting as core and a Topping DX3Pro+ which is connected to the core via USB.
The latter has not coaxial/digital inputs.
As I’m convinced that the slightly crackling sound I sometimes get while listening comes from this poor connection (the USB one), is there a way to “publish” the DX3 Pro on my local LAN/WLAN letting the Roon discover it?
Thank you very much…

You’d need an intermediate device, that’s networked and carries the desired output.

That said, I don’t think your problem is …

… but your underpowered Merrik 1R, as it runs on an unspecified Celeron only.
Yes, it might work most of the time, but struggle to keep up the stream at other times.
BTW, how is it connected to your internet router, wired or wireless? (EDIT: just saw, it’s got no wireless option)
Is there a pattern regarding local or streamed, red book or high-res material?
You might also want to present us with screenshots of the Topping’s device setup and signal path displays.

Well, some months ago I was using a Bluesound Node 2i as intermediate device, but disabling the internal DAC as this particular function was carried out by the Topping.
I was quite happy with the results…
My DAC is connected to the core via USB, there’s no particular settings (honestly don’t know how to visualize a signal path either).
I use DSP settings on the core for my headphones, Grado SR325x and Meze 99 Classics.
Most of the times the results are quite good, sometimes I hear this slightly crackling sound and I fix the problem by restarting the core and the DAC, but it’s annoying, to be fair.
All my musical library is, quality-wise, excellent, as were’ talking about flac files purchased from Tidal or Qobuz, only a few albums ripped.
Probably, adding the Bluesound Node, which I sold at the time, would fix the issue but, as it’s a 500 pound device, I was looking for a sort of a workaround.

Roon’s helpcenter to the rescue - see here and excerpt…

To access audio settings, first enter Roon’s main settings screen, then choose the Audio tab. Inside the Audio tab, you’ll be presented with a list of audio output devices, grouped by type, and in some cases, by which computer or device they are connected to:

Device settings can be accessed by clicking the Gears icon or the “Enable” button. A device must be enabled in order to play music in Roon. Enabled devices will appear as Zones within Roon. This is the Device Setup screen. It is split into two categories, general and advanced. If your device has been automatically identified by Roon, all of the correct settings should be applied automatically without any extra configuration by the user needed. You can always return the settings to their default state by clicking Restore Defaults . Nothing is saved until you click Save Settings so feel free to exit the dialog if you get things into a confusing state and want to undo your changes.

Sometimes it’s got more info than fits the screen, see …

And about signal path an excerpt from here

In the footer, at the bottom of the screen, there is a little colored light – it might be yellow, green, light blue or bright purple. Click that thing. It should pop up a little depiction of the path that the audio is taking. If you are playing to a hardware device that Roon recognizes, you will also see some information about that product.

And there’s lots of other valuable info at https://help.roonlabs.com/portal/en/home, give it a shot to learn more…

Thanks again, Marin, for your patience.
I’ll be posting now some screenshots, don’t know if they can be helpful…

Good that we’ve got those screenshots now!

Sample rate conversion causes so-called inter-sample-overs, that essentially result in clipping (crackling sound) when the original samples closely approached 0dB already.

Click like 1,2,3,4 to configure the signal path quality indicator (5) to turn red on clipping, then enter ever more negative values into (6) until no clipping (crackling sound) occurs any longer.
Keep monitoring the clipping indication over time and adjust further negative if needed.

That should fix your problem.

Also keep an eye on processing speed in the signal path pop-up.
If that drops to below about 1.3 you’ll get drop-outs.


Thank you very much, Marin, I’ve really appreciated your help and fixed the settings the way you showed me.
Any tips about parametric EQ settings?
The ones I use for my headphones come straightly from Oratory1990…

I’d use correction via convolution, since it’s more accurate than PEQ, and the oratory ones are said to be the most accurate.

1 Like