Library connects with ARC but won't play (BHH 3000 with second router)

Roon Core Machine

NUC 7i7BNH with i7 Intel processor, Samsung 960 EVO 250GB M.2 SSD for the operating system, Roon ROCK, Roon Server, database. Crucial 16GB DDR4 RAM

Networking Gear & Setup Details

Bell (Canada) Home Hub 3000, which transmits via wifi to Eero v.6.11.1-46, which is connected via ethernet to NUC

Connected Audio Devices

NUC connected to Bricasti M1 SE via USB, also via wifi via Eero 6 to English Electric 8switch

Number of Tracks in Library

87,532 tracks

Description of Issue

My library appears in ARC without any problems. But when I try to play, it says “poor connection”. In my Roon settings, it says “Roon ARC was unable to securely access your Roon core”. Diagnostics data says nothing - [ ].
Following David Boyd’s advice, I set the Port to 55000.
On my Bell Hub 3000 modem:

  • DMZ is off
    -DDNS is disabled
    -DHCP is on
    -UPnP, DLNA and SIP ALG are on
  • there is nothing under Port Forwarding - it asks me to create a new rule. This might be the problem. What do I do?

I’m not sure the screen shot went through, but the categories the PF window is giving me are;

Name Status Protocol Internal port External port Local IP address / Device name Action

Hope you can help,

Sorry, I should be clearer about the connection to the NUC. It is connected to the English Electric switch, which connects to Eero 6. The EE switch also connects to the Bricasti DAC. I have the option in the DAC of using either the USB connection or the wireless M1 connection (I usually use the latter).

One more update. I found a video on how to port forward on the Bell Home Hub. I followed their advice and inputted the following settings. But ARC is still not connecting with the core.

One more update. I’ve out Eero in Bridge mode. And I’ve made a IPv4 and port reservation on Eero using the ROCK IP address. Still no connection. And empty diagnostic data for Roon support.

Can someone help me??? I know I’m somewhat computer illiterate, but I made the first post a week ago.

Hi @django54,

Please accept my apologies for the delay and thank you for your patience as the team diligently works to get to every ARC-related support inquiry since launch.

The issue is likely that you’ll need to place the Bell Home Hub 3000 in a special equivalent to Bridge mode to enable the port forwarding rule to work. Please see my post in the thread below, which links to detailed steps for changing the settings in the Home Hub 3000. There are other more illuminating posts in this thread as well.

Please let me know if these steps are helpful, and we will proceed from there.

Thanks for your reply. I tried putting Eero in Bridge mode, but with no success in ARC. Also, I couldn’t get my Sonos system to connect when Eero was in Bridge. I guess if anyone is successfully using Bell HomeHub 3000 with Eero and connecting with ARC, I could try their settings.

Hi @django54,

You won’t need to configure the Eero in Bridge mode. Normally, placing the modem, not the router, in Bridge mode would resolve your issue; however, the Bell Home Hub 300 does not offer a simple Bridge mode configuration.

  • As a workaround, you can configure your Eero router as an “Access point,” placing it behind the security layers on the Bell 3000 router. That would allow your Core to communicate to the Bell 3000 directly via the Eero, without the Bell Home Hub 3000’s NAT layer in between. This NAT layer is currently blocking the port forwarding. It’s a “rigged” Bridge mode, a fancy workaround.

  • While this method is perfectly secure, you need to be careful when you are tinkering with the Home Hub’s DMZ settings. If you configure the Eero as an “Access Point” for the Home Hub 3000, then everything connected to the Eero reaches the internet directly. That also means that anything connected to the Home Hub 3000’s Wi-Fi would be exposed in front of the firewall. So, please only connect devices to the Eero router (not the Home Hub) if you choose this route. The Eero router should be the only device connected to the Home Hub 3000 via Ethernet or Wi-Fi after you’ve configured your setup this way.

There are dozens of users who have posted about their experience configuring their Home Hub 3000 in this “fake Bridge mode” or “access point” setup. Here’s a guide you can use, for example: BYPASSING or BRIDGING the Home Hub 3000 (HH3K) - Bell Canada | DSLReports Forums

Please let me know if this information is clear - I know it’s all very convoluted - and we’ll be here to assist.

Thanks for the info. I’ve looked at your reply and the other pages and I’m not sure what concretely I need to do to configure Eero as an Access Point. Right now, the Eero router is attached to the HomeHub 3000 by ethernet. I have also attached a Squeezebox Internet Radio to the Bell router by ethernet. The Bell Router also runs our Fibe TV and land line, so I’m hesitant to try too much. Let me now if there’s one simple adjustment I can do to make Eero into an Access Point. Thanks!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.