Library External disappeared

Roon Core Machine

Intel Nuc 7i7bnkbl357.86a.0083.2020.0714.1344
Rock Linux 2.0 16GB ram

Networking Gear & Setup Details

  1. Cable–>Modem–>Nighthawk Router hardwired to NUC
    **2) Nuc to 5 TB WD Passport external hard drive via usb cord plugged into ANY USB port (NTFS)

Connected Audio Devices

  1. NUC to Receiver via hdmi
  2. NUC to Bluesound node 2i via wifi
  3. NUC remotes via wifi

Number of Tracks in Library

estimated 7000 song tracks

Description of Issue

My Library disappeared. Problem started within last 2 weeks
What I have done so far

  1. I rebooted NUC
  2. Reseated all wires
  3. Checked external hard drive to see if it is working on another computer (It works fine)
  4. Used different usb m/m wires
  5. Tried alternative blank USB flash drives (ntsb & fat32). None were visable via

My nuc will see a keyboard or mouse but will not see any storage drives :sob:

can someone help me?

Can you post a screenshot of your settings:storage page which should show where Roon is looking for your drive.

Did you read and follow the advice given in:

Somehow my ip address for roon was changed. ( I have no idea why).

It was
now it is

If you are using DHCP on the router (all do by default), it assigns addresses automatically and they may change.

Some routers allow you to enable a setting so that DHCP still assigns the addresses (which is generally preferable because it ensures that the same address is never used for more than one device) but it’s always the same one.

Decent routers have a name server (DNS) for the local network, so that you can use names instead of plain addresses. Then you can use the device name in Roon and everywhere else, and the address does not matter. These names should be listed in the router’s admin web page, and you can also change them

I don’t know the Nighthawk but seem to remember that it’s a good one. Check the manual

I got my library back… I did a error check/repair on the hard drive. Then used the ‘Eject storage device’ icon and plugged it back in. I hope I don’t have anymore problems. @BlackJack , Thank you for the advice.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.