Linn DS support request

Core Machine (Operating system/System info/Roon build number)
Roon Nucleus / Build # 764.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Eero wi-fi, but Linn devices are hardwired to Eero via ethernet and Netgear switches.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
I have three Akurate DS streamers and one Selekt DS.

Description Of Issue
I have a Roon system that supports several Linn streamers. I have a frequent problem of the players stopping after a couple of tracks. It’s rare that I can get more than 40 minutes of uninterrupted play time.

Have tried all the usual fixes – reboots, modem resets, etc. No dice.

I also manage Sonos via Roon and no problem there, so am increasingly convinced its a Roon / Linn operability issue. Would love help for a solution. Am a lifetime Roon subscriber, and the subscription was obtained largely because of Linn compatibility that I’m not really getting right now. Thanks.

The problem occurs on all four devices.

Curious… I have a Majik DS connected to a bog standard Plusnet router by ethernet via powerline. Music is on a Synology NAS, with Roonserver running in Linux on a grotty Win7 era PC, that doubles as a tvheadend video recorder.

Playback is rock solid up to 192/24, as long as I avoid DSP tricks. The Linn occasionally drops the connection (every three or four days) but I have only recently moved to the house and there’s something weird going on with the powerline in general across the whole house.

It all ran flawlessly in the old house with the same setup.

There is a Linn compatibility issue, but it’s really hard to nail it down, although I know that Roon support is looking at it, as I’ve worked with them on getting debugging information for a related but less serious issue, album play stopping 1-2s before the end of the last album track.

1 Like

Sorry, not trying to suggest any doubt about the OP’s issues - just observing that, in my case, not a problem.

Having said that, I’ve been with Roon and Qobuz over a year and only last night had my first experience of the 'stopping 1-2 seconds early issue.

Life was simpler when we only had vinyl :wink:

yes this does seem to be a tough one to nail. Like the op, I have a NUC and absolutely zero issues streaming to my 4 DS‘s.

There is and we have been complaining about it since the two “warring” factions made peace years ago and finally started working together. Neither side seems interested in resolving these issues. If you do a search there are complaints going back for years. ROON keeps on saying they are looking into it (4 years and counting) while Linn, since removing their online forum, say nothing at all.

Hey @Charles_Sipos,

I’m so sorry to hear about the issues you’re experiencing with your Linn audio devices…and I want to apologize for taking this long to get back to you :pleading_face:. I wish this wasn’t the case.

I was wondering if the behavior continued on your end?

Thanks everyone for chiming in with more context :pray:

I’ve had a problem where the Linn system stops 1s or so before the end of a track, typically the last track on an album. However, if I ensure that the Linn system is powered and booted up before the Roon Core boots up, the problem doesn’t seem to happen from then on. So, I just make sure now that if I need to take the Linn systems through a reboot (as with upgrading their firmware) I take the Roon Core down first, wait until the Linn system is back up, and then restart the Roon Core.


Yes, the issue has persisted (it really has never worked properly). I’ve got a sufficient amount invested in Roon at this point – between the Nucleus and my lifetime subscription – that I think the next step ought to be getting me in touch directly with someone in your tech group (including you if you’re able to) so that Roon can help me troubleshoot my specific system and work things towards a solution. Months of trial and error tweaking and implementing suggested standard fixes (reboots, etc) just have not worked for me. Let me know if there’s some way to open up that direct line of contact, sooner rather than later preferably. Thanks.

Hey @Charles_Sipos,

Thanks a whole lot for your reply! While I am sorry to hear that the issue is ongoing, the fact that you reached back out gives us a chance to help.

I have tagged our technical team, so they can reply on this thread with more insight and next steps if applicable.

Please, bear with us a while longer :bear:

I will repeat what I said 2 weeks ago.
Sorry however I have been with Roon and my Linn Klimax DS since the beginning. Always the same problems and neither side seems interested in fixing them. Going on 4 to 5 years already

Ive had them before but it had been several years with no issues until 1.8.


Update here please? I opened this thread three weeks ago and no one from Roon tech has even touched base. There really ought to be a channel of communication with Roon’s tech support that works better than posting on a message board and hoping for the best (and if I’ve missed how to do that, advance apologies, but communications with Roon thus far suggests this method is my only resort). If you / Roon tech can email directly please I’ would appreciate that.


Hi @Charles_Sipos

Have you noticed any patterns here? Is it happening when you’ve reached the end of a track, or does it happen more at random?

There is an issue we are working on with Linn investigating the issue that others have mentioned above, but we don’t have any specific timelines we can provide just yet.

1 Like

It happens consistently / nearly always at the end of a track vs. middle of a track.

Sometimes it happens when a specific album is selected, it will stop playback at the end of the first or second track. The Roon interface / app makes it appear as though a track might still be playing in that Zone, but nothing is. It is particularly persistent with Roon Radio. After an album finishes playing (on the random occasions where Roon gets through a full album), Roon Radio generally stops after 1 or 2 tracks. The “fix” usually means going back a track, and then forward a track, which will then restart playback. But that “fix” only works for one track. Upshot is that I’m often only getting one or two tracks to play before I have to go back to Roon and kickstart it using the process described above.

Oh really?
This has been going on for YEARS
Users ( including me) have posted here on this forum for YEARS about various issues.

I find your reply, and every other reply from Roon, rather amusing.

Sorry - the search function is your friend. Just have a look at the previous posts on the Roon forum regarding consistent problems with Roon/Linn operability

Odd! I used to have an issue where playback stops at the end of a track from time to time, but his issue has gone with 1.8. I do not recall that happens lately.

Nobody claims the credit of the fix? I doubt if Linn fix it because they have not released any firmware update last year.

Because there was no fix. This is a vexing issue that has been ridiculously hard to replicate. I own two Linn system hubs (Klimax and Selekt). Depending on what I don’t know (I thought for a while it was the boot order between the Linn hub and the Roon Core, but that hypothesis is not holding) I may have a stop 1s before the end of an album, which keeps happening on every album; or not, in which case everything works until the next time something is rebooted. What happens then is unpredictable, but whatever happens on the first album played after reboot seems to stick for a while.


I would like a direct line of communication to be opened up between Roon customer service and I to address this please. I’d like to see at least some baseline effort by Roon to help me troubleshoot in my specific configuration. Who / where can I make contact for that to happen? This week, please.


1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.