Linux + Ayre QB9 wavelenght USB 192/24 DAC issue

@Gabor_Dietrich to attract Eric’s attention use @eric which will send him a notification message.

Hey Gabor,

Just to make sure I’m understanding all the history here – both the Pi and the Rendu work fine with the Cambridge Audio DAC, and all of the issues are related to the QB9? Is that correct?

If that’s the case, I’m not sure we’ll be able to spend a lot more time on this. If you have specific questions about the QB9 I would again suggest talking with Ayre – it’s possible they can offer more insight into the behavior of their DAC, how it handles bus power in different situations, and whether there’s a way to mitigate these problems or upgrade your device.

However, unless I’m mistaken, all signs here point to an issue with that specific DAC, and we really do need Ayre to weigh in before we spend any more time on this issue.

If I’m misunderstanding, and you have already spoken with Ayre, let me know and I can make a determination about next steps here. But for now I don’t see any indication that this is a Roon issue or something that Eric or Support can help with further.

Please let me know if I’ve missed something, and sorry there isn’t more we can do here.

Hi Mike!

Thanks your answer!

Your argument is almost irrefutable, but one little thing, my ayre QB9 works fine with my Macbook and Roon.
I never have any problem with them. Should I try with Windows? I am certain it will work fine too.
I will contact with Ayre an Sonore soon.


ps: Belive me, it is not a bus problem, I measured the current and the voltage, and every device delivers the power QB9 nedeed. (they can deliver even match more, and no diference to the Macbook in this aspect) I’m certen it’s a problem related to Linux, and the UltraRendu can handle it better than the Pi.

Was this problem ever solved? I am having the same symptoms with an Ayre QB-9-DSD version and a Bryston Raspberry Pi. Since I can get it to work on a MAC and Windows 10 without problems, I suspect a Pi problem.


Hi Rick!

The problem was never solved!
So I have switched to Ultrarendu. Before I did, I asked both Sonore (Ultrarendu) and Ayre wether is there any problem. Both of them answered it should be work fine.
When I got Ultrarendu I tried it, and it worked, but not “fine”.
I was able to play anything what the dac supported, but!
When I switch on the ultrarendu, Roon did not recognize it! I have to pull out the USB cable and push back. After that everythig is OK! Nobody coud solve even this problem (ROON, Ayre, Sonor) I asked all of them!
Yesterday I upgraded the Operating system of the Ultrarendu from 2.5 to 2.7. Did not solve the problem. (I reported the poblem two years ago!)



Thank you for the quick reply. I have not been able to solve it either. I did learn that the Ayre uses a different USB protocol to control the USB timing. The Ayre uses a proprietary Streamlength code for asynchronous operation, which in theory offers the best jitter suppression. According to Bryston, the Streamlength code expects that there will be no other devices on the USB bus except the DAC and the computer providing the data.

That’s why it works with laptop computers that have multiple USB buses. As long as you isolate the bus to only two devices, it works fine. The Bryston Pi, which I use, only has a single USB bus that is shared with the network connection. As soon as music starts to play, the network connect resets the bus and everything stops.

I understand the problem now, but I can’t fix it. Bryston recommended using one of their other, higher end players as all of them have multiple USB buses.


1 Like

Hi Rick,

In my case the Ulrarendu is connected diretly to the DAC, no other USB devices.
It plas the music fine, but when I switch on the Ultrarendu at firs it did not work!
I have to phisically pull out the USB cable and push back to get it work!