Live Radio Audio Stream Quits After Couple of Seconds

Roon Core Machine

Mac 10.15.7, Quad Core i7, 16GB

Networking Gear & Setup Details


Connected Audio Devices


Number of Tracks in Library


Description of Issue

WCBS 880 (NYC) quits after a couple of seconds.

First reported here. URL works fine in a web browser.

Bump. Does Roon support look at this community category?

I guess not.

Hi @femanburch ,

I’m not seeing any issue with this station’s playback on my end. It looks like the streaming links have been changed, so it might have been an issue with the Audacy stream.

No, @BrianW updated the stream links, but the new links are still not working for me (including the MP3 link), they stop after 1-2 seconds. This is the only station that is doing this. Must be something specific to my setup, because as you say others, including you, are not having the same problem. I am not sure how to further troubleshoot …

I’m not in the US so can’t properly test, but if I try and play the .m3u8 stream (without geo-protection turned on) it stops after 2 seconds.

The .mp3 and .aac streams won’t play at all for me (with geo-protect turned off). I can only play those via VPN. (and thus not through roon)

@femanburch - I enabled diagnostics for your Roon Core and I’m seeing some strange errors when you try to play this station:

01/21 11:22:52 Warn: [zoneplayer] Remote Load Failure While Opening Sound: icy:// IcyAudioSignal: HTTP Request to URL[icy://] failed: Redirect
01/21 11:22:52 Info: [Living Room + Dining Room + Master Bath + Master Bedroom] [zoneplayer]     Open Result (Playing):Result[Status=MediaTooSlow]
01/21 11:22:52 Warn: [zoneplayer] couldn't play URL channel:// other error
01/21 11:22:52 Warn: [zone Living Room + 251 #0024c5003456 Zone + MS200 #0024c500135f Zone + MS200 #0024c5000ec5 Zone] Track Stopped Due to Error

Are you able to play the station to a non-meridian zone?

Hi @noris, thanks for taking a closer look at this. A little frightening but also cool that you can get into our Roon Core to poke around!

I just tried all three of that station’s streams to a zone called “MB Desktop,” which is a pair of KEF LSX speakers hooked up to my desktop, but I think Roon is sending straight to the KEFs (which are hard wired to our switch, in Settings/Audio that zone shows KEF streaming to the IP address of the speakers). Same problem, stream stops after a second or two. Other radio stations (and Tidal and local music files) are fine.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.