Live Radio / Web Radio Icons not shown anymore on CXN V2 [Fixed in Build 880]

for quite a while the live radio / web radio icons get lost on the display of my cxn v2, album covers work well.
Any ideas?

Library ca. 120.000 songs
NUC8i7BEH/M2NVME256GB/16GB RAM/Roon Rock

Networking Gear & Setup Details

Connected Audio Devices

Library Size

Description of Issue

I feel stuck in the middle of nowhere with this issue.

So i bring it to the top again.

Still no live radio icon or picture will showup beneath the station name,
just a generic picture of a note, all the same for every station.

Maybe someone of the staff can tell me if a rock reinstall will solve this issue or
if there is a database error that can be solved.

Thanks in advance.

I seem to have the same issue with my NAD M10. I quite enjoyed the display of radio stations. Now I have a greyed-out display with the ROON logo.

1 Like

I use a nucleus+. Before I updated the Roon-Software to Version 1.8, the Live-Radio-Station-Logo was displayed on my players (NAD M33 and Cambridge CXN)

After the software-update to version 1.8, the Roon-Logo is displayed

What can i do, to see the Live-Radio-Station-Logo again?

Hello @Johann_Ellinger and welcome.

Yes, this appears to be a bug. I’ve moved your post to the support thread about it.

Thank you.
I can select them yes.
The only problem is that I don’t see the radio station icons anymore in my display,
For other stations they aren’t shown anymore neither.

Hmm, I don’t get a jellyfish, but I do just get a boring default disc icon for any radio station. I must admit I rarely use the display function for a radio station. Did this change occur with the latest update - i.e. was it OK before?

If so, we’ll file it as a bug.

I usually see the logo of the radio station.

This is what I get on my display,

every station looks the same.

I would suspect a database syntax error for the transmission to the display.

The icons are displayed correctly on the desktop or the mobile phone / tablet,
so the icons and thumbs should be available in the database,
but are no longer transmitted to the display in the stream.

The cover art/Album art of Groove Salad of SomaFM disappeared recently (last update?) (other station same issue. Before (2 weeks agoa) is was working.
streamer: NDX2 Naim
following done:

  • reset streamer
  • restart ROON and Mac-mini
  • test for art via other source for same radio station: Via Naim app working, Via apple Music working
  • tried other station: no art.

Please advice on what i can do to restore the art

Yes, it’s affecting a number of people. Moving this to the relevant support thread.

1 Like

Seems to affect Roon bridges on Ropieee and Diet-Pi also, see Channel Art not displaying for Live Radio only on RoPieeeXL Display - #5 by Marin_Weigel

A useful observation from

I can repeat this on my android tablet. Database stations do not show but manually added stations do.

Thanks for all the reports, folks! I’ve passed this along to the QA team so they can investigate this. When I have more information I’ll be sure to update everyone here.

1 Like

I recently installed Roon on Docker as a consequence of upgrading to DSM7. I have a Cambridge CXN as primary device.

Since upgrading the live radio station logos/artwork is not being shown on the display of the CXN. The logos are however shown on my Android remote and the Macbook app.

Any ideas?

Hello @Thomas_Jorgensen1, it’s a known issue - moving your post to join the others where you can see when Dylan posts updates.


Btw a supplementary note is that for all the radio stations that I have added manually with direct URLs and uploaded a logo of the radiostation, there is no problem. In that case I do see the logo on the display of the CXN.

It is only for the radiostations that I have added from the list of stations provided by Roon, that the logo is not shown.

Same issue here, since several weeks:
no station art for stations provided by Roon, but for own URL.
Logo is not displayed on RoPieee-Display, but no problem on Roon Control Points (iPad, Mac, iPhone)

For the last 3 weeks when playing radio stations the screen stays blank with only the music symbol as an unidentified track. I don’t know whether this is the right section to post about it, or just do it at the Auralic section. When I play music from the services Qobuz and Tidal it shows the correct artwork on screen, only happens with radio stations.
If there are other Auralic users I’d like to hear if they have the same issue.

Hello @Stere0-catx , yes it’s a known issue. I’m moving this to the relevant thread so you can keep track of developments.