Local album art and pictures not loading or showing on remote

Core Machine:
Windows 10
Asrock b150 pro4/d3, Intel i5-6500, 16GB DDR3
Roon build 1.7 555 64bit

Remote Machine:
Same as core

Description Of Issue
I’m having repeated issues with local album art and pictures in general not showing on a remote.
The remote is installed along side the server software on the same machine. Album art from Tidal loads without issues. Android remote has no issues on both local and Tidal content

Terminating and relaunching both the server software and remote on the core machine sometimes solves the issues for a time, before the images disappear again without any obvious reason. Disabling Tidal also sometimes solves the issue, but then I am unable to stream content from Tidal…

Hi @Espen,

Are you by any chance running firewalls on your Core? Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

Thanks for you reply @noris.

I have verified that both Roon.exe and RAATServer.exe are exempted from the firewall, as well as RoonAppliance.exe. RoonServer.exe was not previously added, but has been now.

I have also verified that the network profile was set to private.

A restart of both the server and remote fixed the issue for now. But as previously stated, this is usually not a permanent fix. I will reply to this thread if the issue returns at a later time.

1 Like

A post was split to a new topic: Album art not showing up until Roon Server restarted

Thanks for giving that a try @Espen, do let me know if the issue returns.

Hi @noris.

The issue has returned after a reboot.

Hi @Espen,

Are you running any antivirus programs? If yes, is there any change in behavior if you try temporarily turning them off?

Are you using the Roon All-in-one version or do you have RoonServer + Roon Client installed on the same PC?

No antivirus programs installed, other than what comes with Windows 10.

RoonServer and Roon Client are installed on the same computer.

Hi @Espen,

Is there any change in behavior if you try to clear the image cache?

What happens if you try to reinstall just the Roon Client part of Roon?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old” (just the Roon folder, not RoonServer)
  • Restart/Reinstall the Roon App to generate a new Roon folder

This issues seems very intermittent.

Images worked today without an apparent reason. Decided to clear the cache to see if there where any changes for the better or worse. After the restart of the remote, the issue reappeared, images where not loading.

I preceded to backup the database and reinstall the Roon remote as described in your post. The reinstall changed nothing at first, but after updating to build 555 which prompted a restart of the remote, the images reappeared again.

I’m uncertain whether this is a permanent fix. Will post again when/if the issue returns.

After changing the theme to dark, which prompted a restart of the remote, images are no longer displaying. I tried closing and reopening the remote, but the issue now persists.

Changing back and forth between light and dark theme did not fix the issue.

Hi @Espen,

Can you please try to load up your database into the Roon “All-in-one” version and verify if you are seeing the same issue there? You can use our Migration Knowledge Base Article for reference, but the steps would be:

  • Create a Backup of the current RoonServer database
  • Go to Roon Settings -> General -> Disconnect
  • On the “Choose your Core” screen, press “Use this PC” instead of RoonServer
  • Restore RoonServer database to Roon
  • Verify if same issue occurs

@Espen are you using any Logitech devices on your machine?

I discovered the issue that was causing this for me, detailed more in the thread of mine that got spun off from this. The Logitech G Hub Updater service was causing port collisions on my local machine.

Yes @SlyBlue.

Sorry for missing the post in this thread. I addressed this in your thread.

@noris The cause of the issue was found in the thread that was split from this topic.

1 Like

Hi @Espen,

Thanks for the update here! Glad to hear you managed to narrow down the issue to the Logitech Hub!

@noris Just for further clarification and to avoid confusion, i don’t believe the Logitech Hub is necessarily the “issue” here. Networked printers are just one of the other common devices that utilize this port, starting another service before Roon using that port also yields the same result.

It seems that upon first startup of RoonServer, is does not properly detect that the port is already in use by another service and gracefully fail to using another port. Upon restarting RoonServer after the issue is seen, it is then able to properly detect the port is already in use and tried to use a higher port in the 9100-9200 range as it is intended to.

Hope this helps, thanks.

1 Like

Hi @SlyBlue,

Yes, I agree that there could be a port conflict here. We have an active development ticket looking into possible solutions since other apps also use this port (Plex/Emby for example).

I can’t guarantee that the dev ticket will address this Logitech Hub case as well, but it is something that we’re investigating.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.