Local folders issue on QNAP NAS TS 673

Roon Core Machine


Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

75000 tracks

Description of Issue

I have been running Roon on a QNAP NAS TS 673 for quite some time now. I noticed today that the tracks have just vanished and it seems that Roon cannot read the local folders I have setup in settings and where all my music is stored. I realized this only today. Only TIDAL tracks appear in my library. Force Scan does not help either, it acts as there are no files in this folder.

I would not like to use a network share because with every addition I need to wait the folder to be scanned and I have 75k tracks in my library in total.

I have seen that other people have the same issue, but have not been able to find a solution to the problem.

A post was split to a new topic: B846 local folders issue on QNAP NAS TS 673

I don’t have a QNAP, but have read about closed security solutions. There it is a care in the rights management obvious. In the forum have been in the last few days to read solutions. Maybe reports the affected or you follow the threads before.

Uwe, can you indicate some of these discussion threads you are referring to? Haven’t found anything that may be of help honestly speaking.

Is this helpful also for you?

Thanks Uwe. Read several posts with the same topic, but no one has posted a solution. With the workaround of using a network share room is brought back to an acceptable state, at least I have my library back. But the access issue to local folders still remains. Using shared folders is suboptimal unfortunately.

I appreciate your taking the time to post this for me though.

1 Like

I am happy, shall we mark it as solved?

The issue is not solved so why should we mark it as solved? It’s under investigation so let’s hope there will be a solution soon.

4 posts were merged into an existing topic: Roon Server = Stopped after update / QNAP [See staff post]

This problem is known and being investigated. Follow this thread:


Just restore your backup and all your ratings, lists and tags are still there, even if you switch to network share.

I restored my backup, I can see my ratings but they are unavailable due to the broken file path.

How do you link the file on NAS local folder to a network share?

I only checked that my favorites and tags are working. I don’t use ratings myself but. I guess I wrongly assumed they would also work, sorry about that.

Oh, don’t say so. Knowing tags are working is a good news.

When do you add network share? before restoring your backup or after that?

I reinstalled the core and only after reinstall could access it. After that I added the network share.

Hello All,

I have moved some posts into the main thread covering this issue. If you are seeing this behavior, please see my post here:


1 Like