Local library tracks not found in search, streaming version is visible

Search had improved but I am still unable to find some songs in my local library. When I search for “Das Lied” it will find the correct song by Krista Posch. Unfortunately this is on an album on Qobuz not on the album (a collection) in my own local library. When I press the icon to filter for local the song is nowhere to be found. In fact, the only way I can play the song is when I browse the albums and manually select the song. Krista Posch is somehow not in the ‘Artists’ list but when I click on her name from the track info all kinds of bio info is displayed.

Having read above how the algorithm works I might have a possible explanations what goes wrong. As far as I understand it there is a ‘deduplication’ process. Somehow the result from Qobuz has a higher priority than the local song (this is my only track of Krista) and when I filter on local this priority is maintained and so in effect the track is invisible for search. If my analysis is correct than this is clearly a bug that needs to be fixed. If I am missing something than I would really like to know how I can search for all of my local tracks!

I do understand that combining search results from different sources can be a real pain but it would be really nice if (only for local content) there would be a standard way of querying. This is not rocket science nor takes that much resources, in fact for the time being I am doing exactly that. With a script reading the metatags from the files and putting it in a SQL database so that I can actually find what I am looking for. This should not be necessary.

One thing worth trying is adding a composer tag to your local copy of “Das Lied”. In principle roon will either auto-merge the compositions or you may have to do it manually. Roon is not awfully consistent so it may not work but this is how I ensure that various versions of track level compositions show up in various searches and displays.

Thanks for the suggestion. I tried it and added a composer and comment to the flac-file, Unfortunately it didn’t change the result (I can see the extra metadata in the song when I manually find the file). My guess is that somehow I have to ‘upgrade’ the priority much more before it will get into the result list.

If you go to the composition browser, you can in principle manually merge them. It doesn’t work every time. This may be one of those cases but it is worth a try and may help you with other compositions.

I can reproduce this problem searching for “Ring of Fire”, the Johnny Cash song. I have 10 local copies. Mostly covers, and “best of” type albums. What I get on search are a lot of Qobuz choices.

I can get to my local tracks indirectly using the tracks browser.

I can also get to my local tracks by accepting a Qobuz choice and hoping that my local tracks have been identified as compositions (with a library symbol counter next to the track). Eventually I worked out that the Chris Isaak cover was a local track.

But with many pop genres, identified compositions are very hit and miss so I have learnt not to rely on that route. I do a lot of manual composition identification and grouping for Classical but this is just too difficult and uphill a task with most pop genres. Mostly I only bother to identify compositions in pop genres if a particular song has my attention and I want to hear some interesting covers. For example, Grace Jones covered “Ring of Fire” but it doesn’t show up in search. I can however find it in the tracks browser. This is the reason for the post.

I was surprised that a local Johnny Cash version of Ring of Fire did not turn up. I have quite a few Johnny Cash albums so I checked and it turns out that the only local versions I have are on compilations like the LateNightTales Belle & Sebastian compilation.

My search gives my local album 1st

It’s difficult to see but that looks like a compilation album that happens to be titled “Ring of Fire”:

johnny cash - ring of fire

As a data point for roon, what tracks/compositions came up?

Good to know that others can reproduce this issue. It would have been a little embarrassing for somebody who makes a living getting data in and out of databases and datalakes if I was doing something stupid and couldn’t figure out how search works in Roon. Hopefully somebody from Roonlabs can confirm that it will be fixed in some future release and that it is not “working as designed”, an excuse that is widely used in IT.