Login issue after reinstallation of Roon Rock

Core Machine (Operating system/System info/Roon build number)

Intel NUC i7 running Roon Core

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Modem to Linksys Velop Router to Ethernet Switch to NUC wired and NUC also setup for WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PS Audio DS DAC connected via bridge and also USB from NUC

Description Of Issue

I have been noticing that my NUC has been running hot even while I am not using Roon. So I decided to reinstall the Roon Rock Software on the NUC using the web interface. The software installed and the NUC came back online. When I opened the Roon app on my iPhone and iPad, it prompted me to Login and I did. But after a minute it prompted that due to network issue it could not login (pink dialogue box). I tried several times, also changed password and tried again but could not get it to work. Also tried restarting the NUC and even reinstalled the Rock again but even then it didn’t login.

Please advise what other things I should try to get it working again.

Thanks!

Hello @Bilal_Anwar,

Can you please share a screenshot of your ROCK’s Web UI?

Ok so I got it working again. Problem resolved.

Just mentioning what I did so it may help someone else if they find themselves in a similar position.

I tried the following:

Restarted modem, restarted router, restarted the externes switch. Nothing worked.

Changed the DNS on the to 8.8.8.8 thru the Roon web interface (RWI)

Tried Static IP thru RWI and fixed the IP thru my Routers App for the Intel Nuc

None of the above worked.

Then used a portable internet device (Mobilink 4g - Pakistan) to connect the NUC thru wifi and disconnected the ethernet cable.

Tried to login and then it prompted that the Roon account can only work with one core device and asked me if I wanted to unauthorise my previous device (which was in fact the same device that I was trying to login with now albeit with the reinstalled ROCK). However, I unauthorised the previous core and selected the new Core and it logged in.

Then I switched back to my ethernet connection and everything is working fine.

Thanks!

1 Like

Hi @Bilal_Anwar,

Thanks for letting us know you were able to login on a different network, this indicates that ROCK has trouble with your current network setup.

While the login via the hotspot may have temporarily resolved the issue, this may not be a permanent solution

Roon needs to periodically verify the subscription status and if your ROCK can’t communicate with our account servers, you’ll need to use the hotspot to login each time, which may not be very convenient.

If you try to logout and back into your ROCK on the regular network, are you able to do so successfully?

Hello @noris

Yes you are absolutely right. I logged out of Roon and tried to login again with my with my home network and faced the same problem as I did initially. So this means that my home network is not able to connect to Roon servers.

What should I do? Any suggestions?

I am attaching the screenshots for your review

One of them shows the network details when wired and the other picture shows that for the Wifi Hotspot.

Thanks,
Bilal

!

Add images

1 Like

Hi @Bilal_Anwar,

Thanks for running that test. I would next like to see your ROCK logs to check for any specific errors, can you please use these instructions to send me a set of the RoonServer/logs folder?

Hello Noris,

Please find attached link for the ROCK Logs file

Hi @Bilal_Anwar,

Thank you again for sending the logs over and for your patience while we had a chance to review.

Looking over your log, it appears that you are indeed unable to login due to a network issue:
Error in web request https://accounts5.roonlabs.com/accounts/3/login: NetworkError (Name or service not known Name or service not known)

If you try to disable the WiFi aspect, leaving just Ethernet on ROCK and logout / back in, does that work?

Are you aware of any restrictions on websites you can access using your current ISP?

If you try to open https://accounts5.roonlabs.com/accounts/3/login in a web browser when using the ISP connection, does that page load at all?

I actually reinstalled ROCK and now I’m not having the connection issues any more.

Thanks for your help.

Ok so my above post is incorrect. I just logged out and cannot login back in to Roon with my network.

I had called my ISP and they confirmed that they have not restricted anything. However, this problem goes away when I login using another network. So it might have to down with my router.

I also tried clicking on the link you provided and it opens a page stating ‘invalid request’

Also, wireless is disabled and still not able to login.

1 Like

Hi @Bilal_Anwar,

Thanks for sharing that screenshot, that is what I expected to see. Let me reach out to our QA team to see if they can review your logs for further clues, once I have their report, I’ll reach out again.

Hi @Bilal_Anwar,

I spoke to QA regarding your logs and there isn’t much additional details in them but we do have a few ideas of where to look next:

  1. You mentioned having a few switches in the setup, can you confirm if the behavior is the same if you try to temporarily connect ROCK to your router instead?

  2. What happens if you try WiFi on your ISP connection, do you still have the same issue logging in?

  3. In the accounts5 website you opened, was this an HTTP or HTTPS link? Your ISP might be filtering out HTTPS headers?

  4. Are you able to login to Roon on a different PC Core on the same ISP network? To switch Cores:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC