Losing connection randomly with Synology DS220+ after updating

My Setup

· Core machine DS220+, memory 6 gig, 2 harddrives 2g, Roon build 884 on an USBshare – SSD-card)
· Remote(s), iMac late 2015, OS Monterey, Roon build 884, iPad, iPhone SE)
· Networking details (router Fritz!box 7583, Ethernet connections between iMac-router. The router is connected to a netgear-switch. The switch is connected to the DS220+ and the ARCAM-Streamer. All ethernet-connections. The iOS devices connect on wifi ofcourse.
· Audio devices in use: Arcam ST60 streamer.

· Library details. Music is stored on a dedicated Samsung 1TB SSD-card, about 18000 tracks.
I use Apple music as streaming service, but that’s a separate circuit (On the iMac – in direct connection to ARCAM-streamer on Airplay2.)

My problem

I updated my Synology DS220+ last week to DSM 7 and installed the new build 884. I have the Roon-server on an SSD-card – as an USBshare connected to the USBport of the DS220+. After installing the updates Roon has connection-issues.

· Randomly the Roon-remotes on my iMac and iOS-devices loose connection with the USBshare.
· As long as Roon is playing the connection is solid. But connection gets lost after Roon has been in-active for a while and I want to start playing music again.

In the settings for Storage I get the message “The directory is not available… etc”

Sometimes loggin out on the Synologyserver en loggin back in, restores the connection with the Roonserver. And sometimes it does not.
Sometimes I have to stop the Rooncore and restart it to restore the connection. But sometimes that does not help either.

I know after updating servers it’s wise to restart routers, servers and computers to rule out issues caused by old setting. So I did, but the problem remained.

The setup with the USBshare worked flawlessly in DSM6 and former builds of Roon.
I’m kind of a newby on Roon. It’s the first time I encountered such a problem and I really don’t know where to start solving this.
Any idea’s would be welcome.

Hi Peter,

How do you run Roon on your NAS? Within a guest OS on Virtual Machine Manager, Docker or perhaps the RoonOnNAS solution?

I am running Roon on DSM 7 within a Linux Guest OS (via Virtual Machine Manager) without any issues. I am having the exact same hardware setup as yourself: (DS220+, 6GB RAM, DSM7, external SSD drive for Roon database).

DSM7 changed the USB support, it is now only supporting USB storage devices. However that should not impact your external storage drive support.

Hi Maarten, I use the RoonOnNas. In what way could that effect the connection with the SSD-card in a negative way? What’s the benefit of such a guest OS you are using (apart from safety)?

DSM 7 restricts 3rd party access to file shares, which might be an issue here, or it could be that the USB-SSD is going to sleep.

The file share permission is an easy fix - go to Control Panel > Shared Folder > (choose the USB shared drive folder) click permissions, change the drop down from Local users to System Internal uUser, scroll down to RoonServer and ensure that it has access to the folder.

If the USB drive is going to sleep, I’m not sure how to help - it’s been a while since I used USB attached storage with Roon.

I am not shure but it sounds if the USB SSD drive is going into sleep after a while. My advice is to look into the Configuration settings and set the USB hibernation time (“USB slaapstand” in Dutch) to “none”. See the attached picture.

If you are living in the Netherlands we can communicate in Dutch via a private messages if you like. I own a DS920+ with Roon Core running on it. Probably I can help you further.

1 Like

Thank you, for your help. I’ve changed those permissionsettings.

1 Like

Hi Alfred, thanks for your advice. I’ve changed the hibernation-settings. Now I have to wait and see if connections stay solid today. So far, so good. (and yes I live in the Netherlands, so i’ll keep your offer in mind :+1:)

1 Like

Please share with us the result so we can also learn from this.

1 Like

@Graeme_Finlayson @Alfred_van_Hoorn : Roon has been working fine today. Problem seems to be solved. Thanks for the help!

1 Like

:+1::+1::+1: Thanks for your report.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.