Losing connection to core during backup

Since upgrading to build 970 I’ve noticed that I’m losing the connection to the core during the initial part of a backup. It starts as normal, with the snapshotting database message, then switches to the following …

Then there’s a few minutes of this …

Then everything goes back to normal and the backup page indicates that the backup is being prepared. Everything else is normal from then on and the backup completes successfully.

I haven’t posted in support, as this doesn’t seem to be an issue per se, but it is different behaviour from releases prior to build 970. Has anyone noticed the same?

Dave, definitely interesting but also troubling. What platform do you use for your Core, is this screenshot from the Core platform or a Remote, and and is the backup target another device or are you backing up directly to the Core?

Robert, everything is taking place on a Mac mini M1 (16GB) running Roon Server and the Roon app as client. The backup was also to the same machine.

EDIT: I just forced another backup, and the same thing happened. This time though, when the “Uh oh, something’s not right” message appeared, I click the text at the bottom of the dialog, i.e. “Select a different Core”. This took me straight back into Roon where everything seemed to be progressing as normal …

As I mentioned in my original post, this doesn’t seem to be a huge issue, as everything else seems to be working as expected.

1 Like

***Update: Just realized I added this to a thread that alludes to losing core during backup. That is not my issue. I can move this if recommended.

I’ve also started having daily issues with errors with my core and clients not connecting. I’m honestly at a loss as to where to being my toubleshooting.

First off, I’m running core on a MacMini i7 running MacOS 10.15.7. Core is Version 1.8 (build 970). Each time I launch Roon on my MacBook, MacPro or iPad Pro 12.8 there is no core to connect to. I select the option to select a different core. Then I see the Core running on the Mini. I select it and then receive the Uh oh, Something’s not right message.

I’ve rebuild the core from a backup from 2 weeks ago. I have restarted the Core mini (multiple times). I’ve validated all networking is working (nothing has changed on the network at all in the last month or so).

Where do I start with my troubleshooting.

Are you running a VPN? For years, I’ve used NordVPN, but whenever I run it now I can’t connect to my core. Maybe something changed in the latest Roon build, or maybe NordVPN changed something with the latest update, I don’t know, but check that first. If that’s not the issue I’d suggest raising a support ticket.

I’m only running VPN from my Synology NAS specifically targeted to the Synology downloader. No VPN running broadly in my router. No devices (other than the symbology) running VPN internally to the network.

Hope that answer your question accurately. Obvious test would be to turn off that above stated VPN (which I’ll try) but I’m relatively certain that’s not the issue - but test I will.

Note: Just turned off VPN completely on the Synology. Same result. I should add - and I realize this may be very relevant, I am also seeing the attached image. The “initializing” Roon core (on the same Mini) keeps appearing and disappearing. So I really puzzled on what’s happening and why these are showing.

Yep, if the VPN is only running on the NAS, and your core is on the mini, I can’t see that it will make any difference either, but it might be worth trying.

Other things to check, that are known to interfere with Roon:

Make sure Private Relay is turned off (System Preferences → Apple ID).
Make sure IPv6 is disabled on your network.
Try turning off any firewalls.

And, if you haven’t already done so, start by rebooting all your networking gear too. I know you mentioned you’ve rebooted the core, but rebooting the router and any switches can also help (sometimes).

If none of that helps, it would probably be a good idea to either ask support to move this into the support area, or to start a new thread.

Me too, but try the various steps I mentioned. If they don’t help, I think it will be time to ask for further help from support.

Thanks for the quick feedback DaveN. I will validate all your suggestions and report back.

Much appreciated!

I wonder….while maybe an extreme approach…might it make sense to delete any of the Roon items in my Library folder (see image)? Would that be a “nuclear” way of deleting all the cruft and starting anew? I realize I might need to at least restore from a backup. And maybe there would be other downstream implications - but just wonder if there is value in doing that?

Yes, but it might not help. Try the other suggestions first and we’ll see if it makes any difference.

I’ve verified your suggestions. Private Relay is turned off. IPv6 is disabled on the network. There is no firewall running (never has been). I’ve rebooted - again - both the router and the MacMini serving as the core.

Candidly I’m getting super frustrated that I can’t seem to work this out. My temptation is to start from scratch with a new server installation on the Mini and then do a backup recovery, but I suspect it’s also possible that the backup recovery could possible bring back the same issues (though on the surface that doesn’t seem too logical).

I need to make sure I’m clear on how to properly get support from the Roon team to see if they can assist.

It looks like this thread is relevant for your issue too:

1 Like

Start a new thread in the #support category, and be sure to include as much information as possible when you fill in the template. If @BlackJack is right about the link between your issue and the one he mentioned, support may merge your new thread with the existing one.

Thanks BlackJack - I’ll review that thread to see if it points me in the right direction.

Thanks again DaveN for your guidance on this issue.

1 Like