Losing connection to Roon Core

I just started my Roon Lifetime in December. This behavior occurs often from my mobile phone remote app for no apparent reason. I do know all my indicator lights on my NETGEAR xs708t 10gbe network switch that connects my 2 blade servers and my Raid10 array and backup Raid5 array to the network, blink in unison when this happens, but it’s not the switch as I’ve already had it swapped for a new one. Typically this behavior would indicate a loop or broadcast storm in the switch, but I know there’s no loop. Maybe a broadcast storm caused by Roon?

PS: As an aside, Roon not supporting jumbo frames is very odd and frustrating for the average end user to troubleshoot. I only isolated that issue through an educated guess after eliminating all other network related possibilities. This should at the very least be documented somewhere. Hopefully someone with this issue will Google and find this and it will help them.

Hi @Wh01sjongalt ----- Thank you for the report and my apologies for the troubles here. To help me better evaluate this issue may I kindly ask you to please provide the following information:

  1. A brief but accurate description of r your current setup as seen here. The more detailed you can be, the better.

  2. Have you always encountered this issue with your Roon remote or is this a recent observation that has been made? If this is indeed a recent occurrence, can you think of any changes that may have been made to your setup recently that would have impact on this behavior being noticed?

Lastly, I notice from your report that you are making use of a managed switch in your network configuration (NETGEAR xs708t). I will advise that we have seen issues in the past a rise from working with managed switches as there could be multicast package filtering going on (More examples: #1 and #2).

-Eric

I have the latest version of Roon Core Server x64 for Windows installed on a Dell PowerEdge R620 server. That server is connecting to ~27TB Raid10 via a HBA to a SAS Expander housing 15x4tb drives. I also have a separate Dell PowerEdge R420 server being used as a Synology NAS, but it’s just for backup, mirroring, redundancy of my media files stored on the R620 server. It has 4x10tb HDDs in a raid 5 for storage, but again has nothing to do with Roon, unless the R620 server goes down. I also have my main gaming rig. All three are connected via cat 7 to the netgear xs708t NETGEAR switch which is managed. This switch was the most basic 10GBE switch I could find with sfp+ and Ethernet Jack’s to support all three nodes at the fastest speed to expedite multi-tb media file moves. IGMP & MULTICAST is disabled on it, unless I’m missing something. The behavior with Roon has occurred since day one. My router is just a descent ASUS router that provides dhcp and WiFi to my network located in another closet. The router is linking the NETGEAR switch and my other nodes through a Cisco unmanaged switch and from there it goes directly into the NETGEAR switch.

To clarify: Internet Gateway>ASUS WIFI Router>Cisco Dumb Switch>NETGEAR xs708t managed switch>Dell R620 server/Dell R420/COSMOS Gaming Rig. My remotes are my LG V20 Android phone running Nougat, and I have roonbridge and the Roon GUI app running on a Win10 Lenovo Tablet in my main listening room connected via a generic and separate dumb switch via Ethernet back to the aforementioned Cisco dumb switch in my wiring cabinet. I have one HIFIBERRY in another zone connected to another Cisco dumb switch via Ethernet that connects back to the aforementioned original Cisco dumb switch. My COSMOS Gaming rig is a 3rd zone Running both Roonbridge and the GUI APP via WIN10 connected via 10GBE CA to back to the XS708T NETGEAR switch.

Hi @Wh01sjongalt ---- Thank you for the follow up and taking the time to answer my questions, both are appreciated. I touched base with my developers today to get some feedback on this behavior you are noticing and they have asked me to gather some more information from you to help clarify some things. Please see below.

  1. Please verify the exact behavior you are experiencing with your mobile device.

  2. Can you please provide the exact model of ASUS router being used.

  3. The behavior you have noticed with your phone acting as a Roon remote, is this being displayed on any other devices acting as remotes?

-Eric

You’re most welcome and thanks for the support!

  1. While using the Roon App or returning to the Roon App on my smart phone, the application loses comm. with Roon and tries to search for it while indicating it’s take longer than it’s supposed to. If I observe my Netgear XS708T 10GBE Switch when this happens, all the ports lights blink in unison for a period of time. Once the phone regains connection to Roon (Times Vary from 15 Seconds to several minutes) the switch seems to calm down and go back to blinking normally, but invariably this will come back and only sometimes cause the Roon remote to disconnect intermittently) Sometimes I can go long periods of time (hours, sometimes many hours) and everything is copacetic with both Roon Remote and the switch. Don’t get it twisted thinking it’s correlative because sometimes the remote app disconnects and the switch is oblivious or already finished having a conniption fit, but more time than not when I lose connection and look at my switch the two seem to be having a battle of contention.

2)ASUS RT-AC87U

3)The other windows 10 machines (COSMOS and X201T Tablet) acting as remotes using the Windows Roon App - nearly always are oblivious to the phones remote connectivity issue, but I have seen the X201T machine disconnect, but usually never when the Phone is going full retard, at least not in any noticeable way.

  1. Bonus: Please …don’t blame my wifi, it’s done nothing wrong. It serves me up hot packets nearly always without any weird connectivity problems or signal strength issues. Yo, I get mad bars of signal strength everywhere in my home. (sorry for the colloquialism)

Hi @Wh01sjongalt ----- Thank you for the follow up and taking the time to answer my questions.

I dropped a line to one my developers today to get some feedback on this issue you are experiencing and he has asked for a bit more information to try and pinpoint if the core is crashing or if this is isolated to just your remote(s).

With this in mind, may I ask you to please reproduce this behavior you are noticing with the phone and while monitoring the phones behavior I would like you to please leave another remote active and see if it goes down as well.

-Eric

Way ahead of you, Eric. I’ve got a Samsung Galaxy Note 7 that I refuse to give back to Samsung that I loaded Roon Remote on. So with both Android phones running Roon Remote and strangely enough when the problem occurs on my LG V20 running the latest Android OS (Nougat) my Samsung Note 7 (running lollipop) is unphased and unaffected.

As an aside, I also notice a visually noticeable graphical corruption line horizontally along the top edge of the app, it looks like a line of TV static. Just mentioning it because I’ve noticed it a lot, I’m not saying it’s related, just passing on the info.

1 Like

1 Like

Hello Eric

I am having the exact same issue of my iPad air last generation loosing connection to Core.

My setup:

iMac running latest OS Sierra houses Roon Core
Music housed on Bluesound Vault
Tidal Subscription Added
IPAD running Remote
Router Netgear N600 Wireless Router - Dual Band Gigabit (WNDR3700)
Service Provider Comcast

Can you please help?

Every time I try to use remote on the iPad, it says waiting for Remote Core. If I restart the machine it works. It then looses again after a little time.

Cheers

Raj

Kudos Jon (@Wh01sjongalt) :muscle: Thanks for sharing this observations with me!

Let me ask you, since you have noticed this issue, have you tried reinstalling the application on any of your remote devices?

-Eric

Hi @Rajesh_Ramachandran ----- Thank you for chiming in and sharing your feedback with us. My apologies for the troubles here. As I have asked Jon, could you please provide the following information:

  1. Can you please provide a description of your network configuration/topology, as well as providing insight into any networking hardware you may be implementing. I would like to get a sense of how your devices are communicating and what tools are being used to make those connections.

  2. Can you confirm if there are any active firewalls or anti-virus applications currently in your setup?

  3. Can you verify that your core machine is not going into a sleep state at any point and also that no one else is logging into their user account on your core machine?

  4. Have you always encountered this issue with your Roon remote or is this a recent observation that has been made? If this is indeed a recent occurrence, can you think of any changes that may have been made to your setup recently that would have impact on this behavior being noticed?

  5. The behavior you have noticed with your phone acting as a Roon remote, is this being displayed on any other devices acting as remotes?

  6. Have you tried to reinstall the application on your iPad?

-Eric

Hello Eric

@support 1. Network set up. My Bluesound vault that has all music files is hard wired to my router. My router is mentioned in my previous post. My iMAC and iPad are connecting to same wireless network.
2. I don’t have anti virus or firewall on this Mac.
3. My wife has a log in but she has not logged in for now.
4. I only added this from Monday evening. So i have not used it longer. This problem started right away. I can now access the remote with out any issue on iPad and not working with my iPhone 7S.
5. I have not done that.

I will uninstall and reinstall the app and report back. My guts telling me that there’s something in the newest Android nougat OS that is causing this. Maybe it’s an under reported issue because very few Android phones support the Nougat version OS? The LG V20 was the first smartphone aside from the new Google Pixel phone to come with Nougat installed.

1 Like

@support

I tried delete and add App in iPhone. I still have same issue. Its not connecting to Core.

1 Like

Hi @Rajesh_Ramachandran and @Wh01sjongalt seems we have not exact the same but a very similar problem. The remote interrupts the connection from the core to the audio zones in some way. I reported it here a month ago and I’m also in contact with @Eric.
Sebastian

@sebi

I did dump my phone logs to Roon. I will wait and watch what happens now.

Reinstalling didn’t correct the issue for me.

2 posts were split to a new topic: Losing Connection to Core with Nexus 6P

A post was split to a new topic: Roon 1.3 - Connectivity issues with Samsung Galaxy Tablet