Loss of the remote connection to the Roon server


I use the latest version of Roon (Win 32 bit control/core/output) 1.5 on a Windows 10 pro computer. and I have like devices BlueSound et Trinnov (all with last firmware)

From the computer, I can control without any worries roon
But on my Roon remote ,(Nexus 9, Pixel 2, Iphone 6, …) 90% of the time, impossible to have access to the roon server.
Only solution, have access by RDP to the roon server with my smartphone/tablet
And sometimes, after I connect to the server via RDP, Roon remote on my smartphone finds the connection as well.
Finally, when I completely turn off, then restart the computer on which Ronn is installed, usually access with Roon remote works for sometime, then lose the connection.

Version of Roon : 1.5 (323) 32bit (with 64bit version, again more problem)
The operating system where Roon is installed: windows 10 pro
Basic informations : CPU i3-2120, 8 RAM, 128GbSSD + LSI MegaRAIS SAS9240-8i with 6 HDD in RAID 5 MB :ASRock H67M-ITX
antivirus: Kaspersky internet security 19.0
All the Music is on local RAID drive

router: Ubiquiti UniFi Security Gateway
Switch: 5 x Unifi Switch 8
Wi-Fi : 3 x Unifi AP-AC Lite
Server with fix IP, and on the same VLAN than the other audio equipment

Many thanks for your help, because it’s really frustrating.

@David_Ghidoni Your CPU does not meet minimum specs see https://kb.roonlabs.com/FAQ:_What_are_the_minimum_requirements%3F

That is possibly the main issue - I have a similar Ubiquiti setup with 6 switches and 5 wifi AP’s and a USG3P and I can be pretty certain you dont have a networking issue.

That said you have to have ALL your roon devices on the same network segment…I use VLAN 1 (no VLAN if you like) so if your control devices are on another VLAN then this might be an issue.

Hi @wizardofoz,

Thanks for the feedback, definitely,I have all my Roon devices on the same network VLAN.
All was working perfectly with my CPU for years, and when connection work between core and remote, no sign of slowing. but thanks for the proposition, another idea…
I was hoping more of a problem with my firewall, although roon,'is normally not blocked

Turn off any and all firewalls and try that … I’ve seen odd things even tho it appears Roon might have entries in the rules.

Hello @David_Ghidoni,

Thanks for contacting support, and providing the details of your setup, I’d be happy to take a look at the issue you are facing here. There are a few possibilities of what could be going wrong here but my initial suggestion would be to set up some firewall exceptions in your Router. You’ll want to forward:

  • UDP port 9003
  • TCP ports 9100-9200

You can read of a user with an issue similar to yours that was resolved by forwarding those ports:

Some users have also mentioned that enabling ‘Flow Control’ on their managed switches improve performance. I see that your Unifi Switch 8 is a managed switch and if it has the ability for ‘flow control’ I would suggest you enable it. You can read more about flow control and how it has solved people’s issue in these threads:

Please let me know if any of my suggestions help here but if they don’t, we can take a deeper look into what’s happening here.


@noris Just for the record none of my Unifi switches have flow control enabled.

Maybe ill try it and see if it gives any better or worse performance but I have been running like this for more than a year with no lost connections.

I just turned on flow control on my 7 switches … no differences noticed for anything. FYI

Really sorry for the late feedback @noris, @wizardofoz

I turned on “Flow Control” on my 6 switches and forwarded ports :

  • UDP port 9003
  • TCP ports 9100-9200

But the problem still persists :frowning:

Hello @David_Ghidoni,

Sorry to hear that enabling flow control and opening those ports have not solved the issue at hand. This might seem like an unnecessary question to ask but I want to do so just to make sure, your Roon Remote devices are connected to your WiFi when attempting to access Roon and don’t have WiFi disabled when trying to connect? Also another thing, are you on the same SSID (WiFi name) as the Roon Core? (As in not using a guest network that could prevent some connections). I would also double check that your Firewall has been configured properly to allow Roon, Ubiquiti has this guide for confirming firewall rules and they should be applied in both on the LAN IN and LAN OUT page. Also, can you please further describe your setup here? I would assume that it is something along the following lines but please do correct me if I am mistaken:

Path for Core: ISP Modem (wired) -> UniFi Security Gateway (wired) -> UniFi Switch (wired) -> Roon Core
Path for Remotes: ISP Modem (wired) -> UniFi Security Gateway (wired) -> UniFi Switch (wired) -> UniFi AP-AC (wireless) -> iPhone Remote

If you can please confirm the above it would be much appreciated!


Hello @noris,

No worries, you’re right to ask!

Yes remote phone/tablet connected to WiFi

Yes, I have only one SSID and no guest network at the moment

Regarding firewall all is open in local LAN (IN/OUT)

Finally, yes it’s exactly like that :

But as I tried to explain in my first message, sometimes the remotes work correctly again after I connect via RDP to the server.


Hello @David_Ghidoni,

Thank you for your detailed reply, I appreciate it. I have gone ahead and started a case for you with our QA team to see if we can pinpoint what could be going wrong here. While they have a chance to review the details of this case, can I please ask you to perform the following:

I want to rule out if this is a Network issue or a Roon Core issue. I propose a test where you install a Roon Bridge on another computer and connect it directly via Ethernet to the same UniFi Switch that the Core is connected on. If they are connected to the same switch, are you still experiencing issues with the connection dropping? Please let me know your observations from this test when possible, I will also let you know if QA has some further questions as to what could be going wrong here.


Hello @David_Ghidoni,

One of our senior developers took a look over your case today, they said that it seems like something is preventing your Core or Remote from properly communicating with one another through Multicast and Broadcast traffic. Do you by any chance have any “AP Isolation” features turned on in your network setup that would prevent communication between the devices?

Furthermore, if you navigate into each of your UnFi APs, can you please verify that you have the “Block LAN to WAN Multicast and Broadcast Data” turned off? If this setting is enabled it would definitely cause some issues here with the connection.

Please let me know your reply to these questions and the previous ones when possible.


Hi @noris,

I spent little bucks and bought a NUC7I7BNH to connect it directly via Ethernet to the same UniFi Switch that the Core was connected on.

And apparently, all is working now.
I’m facing just some problems with backup in Dropbox and sometimes songs that are no longer present in TIDAL, but at least I can use the system.
But I think I can handle this on my own.

So, we know the issue was not with the network. so your QA team can close the case.

Thanks for all

Hello @David_Ghidoni,

Glad to hear that the NUC is working great now. This makes me believe that this issue was due to the firewall settings on the Windows 10 and Kaspersky AV was somehow blocking the connection to your remote. You should be aware that TIDAL only updates once or twice a day so if you recently added songs, the update of the day may not have been performed yet. You can trigger a “Force Refresh” in Settings -> Services -> Edit (Next to TIDAL) -> Sync Library Now:

Please do let us know if you run into any additional issues but I will mark your case as closed for now!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.