Lost all zones (power cut)

Core Machine (Operating system/System info/Roon build number)

NUC8I7BEH2 with recommended spec, running ROCK/ROON current build.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Hardwired network, Fritzbox router and mesh bits, Netgear (I think) unmanaged switches.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

dCS Rossini hardwired
Meridian ID41 hardwired
Meridian MS200 hardwired into mesh extender

Description Of Issue

All was well, then there was a power cut, and since then I haven’t been able to play to any zone apart from MacBook and iPhone. The Rossini shows up and claims to play but the timeline never moves past 0:00. The two Meridian zones never ever ever show up any more.

Important: not only do all devices show up reliably on the network itself (i.e. iNet app or Fritzbox webinterface), but they all play reliably using another machine on the network with a different unrelated Roon build.

My suspicion is that the untidy shutdown due to power cut has got the ROCK into a bad state. A full restore (including ROCK OS, Roon and database from backup) did not help.

I’m hoping there’s a file in there which I can delete to wipe the audio settings, or some such…

Help!

Hi @Ludwig,

I would try to completely set the old database aside and then restore from a backup at least a week before the issue occurred. You can set the ROCK database aside by using these instructions:

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Restore your database from a backup

I was away 3 weeks.

I did what you recommended, but even with a fresh ROCK database that Roon doesn’t see the Meridian zones. And just to recap, iNet (network scanner) and another Roon (alpha) on the network, do see the Meridian zones.

On the other hand, the Rossini has played continuously for more than 24 hours, so seems to have sorted itself out.

Some strange hardware problem in the network? Or simpler possibilities?

1 Like

Your Roon library has ‘latent corruption’?

Hi @Ludwig,

Thanks for running the fresh database test. Since the Meridian zones are still not showing up, I don’t suspect this is a database issue.

Is there any change in behavior if you connect both ROCK and the Meridian to the same unmanaged switch?

Yes, Roon finds the Meridian zones.

I have 3 switches connected to 3 of the 4 Ethernet sockets on the cable router. Let’s call A the switch in the basement where the ROCK doesn’t play ball; let’s call B the switch with the Meridian 818 on it, which when it also holds the ROCK works fine; I tried C, the third switch, and like on A, Roon can’t see the Meridian zones. So I disconnected the switch and tried the C cable directly into the ROCK - still nothing. So it seems the problem is the cable router rather than the switch. Corruption from a spike when the original power outage ended?

I’m thinking there isn’t much more to try but resetting the cable router to factory settings.

Unless you have a further suggestion.

Resetting the router back to factory settings helped a bit, but only unreliably.

I read here that some routers benefit from an independent switch immediately after them, so I did that - not expecting anything much.

Lo and behold, all zones are back. WTAF.

I’ll watch carefully.

1 Like

Yes, I have recommended that many times. Not sure if it was one of my recommendations you read! But, if it is working… :+1:

Hi @Ludwig,

Happy to hear that adding the independent switch helped with this issue!
Do let us know if the system remains stable with that change in place.