Lost Channel Layout setting

Hi

I am using Roon Rock on a NUC as the core server in a system with a Linn DSM and a NAS for two channel music.

Today, I added a second NUC Roon ROCK as an end point to take an HDMI multi channel output to a Marantz surround reciever in another room. At first everything work fine and I got full surround 5.1 from flac files on my NAS. However, I have subsequently lost the option to set the output to 5.1 because the Channel Layout option has disappeared from all Audio Settings for all output devices. At first it appeared greyed out on the control on my iphone for the HDMI output of the Roon ROCK endpoint and I could access on it a Windows PC, but now it’s gone completely.

Is it possible I could have inadvertently changed some global setting somewhere to cause this? I’ll be very grateful for assistance. Many thanks.

Hello @Newton_John,

That is certainly strange, can you post a screenshot of your Device Setup -> Advanced tab? Does rebooting the ROCK or Marantz receiver help?

Thanks,
Noris

Hi Noris

Thanks for the response.

I managed to get the Channel Layout to return for a while by disabling that HDMI output and enabling another one. However, as you can see it has gone again.

Regards, John

As you can see here it is on one of the other HDMI output. This is HDMI1 - the previous one was HDMI0 which is the one that actually outputs to Marantz.

I tried rebooting everything I could think of and reinstalling ROCK operating system. The only thing that worked was the disabling and enabling routine. Didn’t try rebooting the Marantz, though, as presumed this wouldn’t afffect things. Will give it a try, now.

PS I also found that with the big multi channel files, I got some dropouts which may be due to the long convoluted ethernet route from the Core and NAS to the endpoint. I got round this problem easily by limiting the sample rate to 96KHz, but as you can see this option also disappeared.

Yes. Rebooting the Marantz restored all the options including Channel Layout.

That’s great, thanks. I know what to do if it happens again.

By the way, Roon and ROCK are great.Only been using Roon since Sunday, but they have already transformed my listening habits.

Hello @Newton_John,

Thanks for letting me know that rebooting the Marantz has helped! believe that this issue may have something to do with how the Marantz HDMI “handshake” happens. Do let me know if you are unable to restore the communication with a reboot of the Marantz in the future though.

– Noris

Hi Noris

Just to let you know the problem disappeared when I replaced the HDMI cable - changed Amazon Basics to Audioquest Pearl. That appears to have cured the handshake issue you identified. Also improved sound, too.

Regards, John

I have similar problems with a Denon AVR. When switching between sources/zones it starts reporting wrong capabilities to the pc hdmi adapter. Rebooting AVR or PC fixes it.

Happens with other software, not just roon.

Went round and round with Denon support, never figured it out. They wrote it off as some sort of handshaking problem.

Resolved by using toslink optical. Works 100% reliably.

1 Like

It also solved problem of dropouts with 176.4kHz 5.1 files.

Edit: might have spoken too soon there, but at least they’re less feequent

Hi

Since the recent software upgrades, I’ve lost the ability to set the output to 5.1 whenever the ROCK device is connected to the Marantz AVR by HDMI. No amount of rebooting both devices makes any difference.

If I unplug the HDMI cable, I am permitted to select 5.1. However as soon as I reconnect the HDMI cable, the ROCK device reverts to 2.0 and I can no longer correct this.

Is there anything you can suggest to resolve this. Many thanks.

Regards, John

Hi @Newton_John,

What is the exact model of the Marantz receiver? You mentioned that last time this happened you were able to select one of the other HDMI ROCK zones and that worked ok, is that not working this time around?

– Noris

Thanks for the quick response, Noris

It’s a SR6008

I am using HDMI 0 - this produces sound OK but some of the options are missing as above and it defaults to stereo.

I have tried HDMI 1 and the other zones and see all the settings such as Channel Layout but no sound is produced. There is only one physical HDMI socket on NUC.

Do you use zone 2 feature of your AVR?

2 Likes

Hi @Newton_John,

Thanks for letting me know the model number. I am going to be reaching out to our hardware team to see if they can take a look at this case. It may be a bit of time before my request reaches their queue but I will let you know as soon as I hear back.

– Noris

1 Like

Yes, I do use zone 2.

I’ll try disconnecting it to see if it makes a difference. Thanks.

You were right about Zone 2, R_Neal

Switching Zone 2 to another source cleared the problem.

Many thanks for the suggestion.

Regards, John

2 Likes

Hi @Newton_John,

Glad to hear that @R_Neal’s suggestion worked out for you!
Thanks for making that suggestion @R_Neal! :sunglasses:

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.