Lost my LS60 from the ROON READY device list

Roon Core Machine

Nucleus +

Networking Gear & Setup Details

Nucleus + hardwired to router, all audio devices connected via Wifi

Connected Audio Devices


Number of Tracks in Library

15,500 tracks in library

Description of Issue

My LS60 has vanished from the Roon Ready list - they only appear as Air Play devices.
It seems this happened after they were paired with the LSX-II for the weekend. Could I have deleted them when unpairing? How can I reinstall them as separate devices?
They are on the network and I can control them perfectly fine with the KEF Connect App. But for Roon they no longer exist.

Thanks for helping!

@Arthur_Kipferler, welcome to the Community. A fellow user here, but have your tried first rebooting them and seeing if that helps? I have the original LSX and LS50W (version I, not II), so not sure what you mean by pairing the LSX-II and LS60. Do you mean grouping them together as a common Roon endpoint? If so, were these grouped as AirPlay devices or native Roon devices?

I will never be lazy again… Yes, un- and replugging the LS60 solved the problem. Thought that wasn’t worth trying since they did work fine than for any other purpose than Roon Direct…

Problem solved.

1 Like

Great to hear you have them available again!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.