Lost my Ropieee Endpoint in Roon [Solved: reflash Ropieee]

Roon Core Machine

Dell XPS 8000 Core i7 16mb with Umbuntu 20.04 TLS

Networking Gear & Setup Details

I’ve been using my Roon on my network just fine. I have all 1G Ethernet connections and a Netgear router static IPs for all devices. I can access Roon on my phone, Roon can cast to my Shield without problem. So no firewall problems that I can see.

Connected Audio Devices

Shield TV via Chromecast is working
Stack Audio Link II Ropiee Endpoint NOT WORKING. Was found before but when I moved Roon from Windows PC (working for 6 months withought problems) to Ubuntu Roon server, it is not found by Roon. Endpoint web admin page is still accessible, so it should be discovered by Roon. When I switch back to the Roon Core on my Windows PC, it also is not found in Other Network Devices.

Library Size

28,000 track

Description of Issue

So I wanted to move my Roon core from my Windows 10 PC to an Ubuntu machine. I did the minimal install and I am running it headless and accessing it with Remote Desktop in Windows. That process went well and Roon server is installed, and I can access it by Remote Desktop, and I can also access Roon with my Android phone. I logged out of the Core on my desktop and logged back in with the Ubuntu as the instance/license. Roon server seems to work fine.

I can see my Shield TV in Other Network Devices and I can play music through it. So I don’t think I have any firewall problems.

But I cannot see my Stack Audio Link II Ropieee endpoint in Other Network Devices. I can still see endpoint in my network, and can access the Web admin page. On my Windows PC, I tried logging out of the Ubuntu instance and logging into the remaining Roon Core on Windows. It also does not show the Roon endpoint. This is odd as this was working no problem before I installed the Ubuntu. I don’t believe this problem comes from Ubuntu.

Is it possible that the Ropiee endpoint is somehow reserved with the original Roon core and cannot be found because of this? Is there some kind of flushing I have to do to make the endpoint open to connect to other devices? I unplugged and restarted the endpoint, but that didn’t work. I rebooted my router as well.

Thanks for the help.

1 Like

I have two Ropieee endpoints (DIY Pi with Pi2AES HATs) working with an Ubuntu Server 20.04 core, no issues recently. However, I had a couple of instances where I had to reinstall Ropieee on their microSD cards because Roon would not find them. I had a quick look at the Link II manual, not obvious how to reinstall Ropieee. I’d start by checking with Stack Audio…

I would not expect it to show up under Other network devices, because it is a normal RAAT endpoint. I assume that it simply does not show up in Settings —> Audio for you to enable?

Yeah, it doesn’t show up in the Audio panel at all.

When you connect to the Link II via its admin page, can you reboot it successfully on the Advanced tab?

Yes, I can reboot it.

Update: I downloaded a new version of Ropiee on a Rasberry Pi 4 (which I previously used as my first endpoint) and set it up. It also does not show up under Settings>Audio.

Have you posted this on the Ropieee thread? The developer @spockfish is very responsive and he has ways of debugging issues like this.

Do you have a DAC attached and powered on?

Without a DAC the endpoint will not show up in Roon.

I was able to reflash the device and its working.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.