Lost USB DAC after update

Core Machine (Operating system/System info/Roon build number)
Windows 10 Pro.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Netgear CM1000 / Erro WiFi bridge / Surface Pro /

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
USB NextDrive Spectra (Asio & Wasapi).

Description Of Issue
After the version update I lost my USB NextDrive Spectra (Asio). When trying to ‘enable’ the screen goes to endless loop of “enabling” and blank (no audio devices displayed) in about 3 second cycles.

All was working until update. I did everything including de-installing (settings & dB) reinstalling, rebooting back to the wall, Disabled all audio devices and closed Roon. Re-opened and tried different order of enabling. Nothing works,

Selecting Spectra (Wasapi) does work! Just not with the Asio driver.

Looking forward to resolution.

Thanks Craig

Windows update or roon update? Maybe there are also updates available to you dac or dac drivers?

Sorry…forgot to say…
Problem came with update from Roon 1.4 to 1.6. I also had some pending windows updates which I just completed and re-did everything all over again.
UPdated firmware on NextDrive Spectra. Trying to look at their support sites to see why the Wasapi driver is working but not the Asio?
However, at after Nextdrive update now the Audio window is stable and I can “enable” the Nextrive (Asio). Big progress
However, no sound!


Hi @Craig_Davidson,

Welcome to the forum. Looking over this device, I see that there is a driver needed for ASIO playback. Can you please check to see if you have the latest driver installed from the Spectra Site (FAQ -> Driver Manual)? Here you can find a direct link to the driver.

You should be at Roon V1.7 B521 now and windows 10 1909 IIRC

Well, 2 things:
First, I am at Roon V1.7 B521 and a slightly earlier version of Windows Pro 10 which is controlled by my employer.

But Second!! Previously I had just ‘re-installed’ the Asio driver. This morning I de-installed/reinstalled and now all is back to normal and working correctly.

I think it all had to do with updating or reinstalling the drivers in some order yet unknown to me.

This has been more time consuming for a simple Roon update but at least I’m listening to nice music while writing this now.



Hi @Craig_Davidson,

Glad to hear you’re up and running on the newest build of Roon with the driver reinstalled!

Ahhh… hate to report this. I was listening to music while working this afternoon. Shut down, went home, powered up and opened Roon. Everything is screwed up. The Nextdrive (Wasapi) and NextDrive (Asio) show up but only the Wasapi will enable. But when output to that audio device - no sound.

Now also no sound with System Output. I get output through laptop speakers with Std out.

I literally did nothing other than shut down and power up.

Tried again to deinstall and reinstall the Asio driver but still not working.

Hi @Craig_Davidson,

No worries, we can take another look at this issue. These symptoms sound a bit strange too me, can I request a copy of your Roon logs? You can access them by using these instructions and the best way to get them over to me would be via Google Drive / Dropbox, but if you don’t have either service just let me know and I can provide alternate upload instructions, thanks!

Wow… here’s the news.
First here is link to Roon logs: https://www.dropbox.com/s/10qwkoutz2yic4o/Craig%20Davidson%20Roon%20Logs.zip?dl=0

Now… I get back to work and everything is working fine again! When at work I plug my NextDrive DAC into a IXCC 4 Port 3.0 Hub. Everything works!!

When I plug the NextDrive directly into the laptop USB port (like at home last night)… it doesn’t work. Before the Roon update it didn’t matter where the DAC was plugged.

Can this have anything to do with the configuration at the time I installed drivers? I honestly don’t remember how/what I did.

Hi @Craig_Davidson,

Thanks for sending those logs over. I requested them to take a look for any database issues, but they seem to be in order and I can’t find problematic database traces, which is a good sign.

That’s strange. Is the behavior the same if you use another USB port from the laptop? Perhaps that specific USB port has a hardware issue?

The Surface Pro has only one USB port so sometimes I use the USB Hub with other devices.

Confirmed and repeatable. If I plug the NextDrive into the Surface Pro USB port the NextDrive(Wasapi) shows in the list of Audio Devices that can be enabled. When Enabled and subsequently made the active audio device I don’t get sound anywhere. The NextDrive(Asio) shows as “not available” and cannot be enable.

When I plug the NextDrive into throught the USB Hub, the NextDrive(Asio) audio device shows normal, can be enabled, and stable and normal.

This only started with the Roon update and through my attempts to fix by futzing with reboots/driver installs/Roon de-install/install…etc.

If I can fix this through some other sequence of installs/driver refresh or whatever I will try. But at least it is working for now through the USB Hub.


Hi @Craig_Davidson,

Glad to hear that the NextDrive is working properly though the hub! As for troubleshooting this further, you could try performing a RAATServer refresh:

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings -> Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location: https://kb.roonlabs.com/Database_Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Also, if you by any chance have any other PC around the house, you could try installing Roon and connecting the DAC to the other PC and verify if it works there. That should help clarify if it’s just the Surface Pro’s USB that’s affected by this behavior.

No joy with new RAATServer instance.
The USB port works in every other way for everything I use as normal. Just this NEXTDrive thing after the ROON upgrade.


HI @Craig_Davidson,

Thanks for trying the RAATServer refresh. If you are happy with using the USB hub to facilitate the connection, you can keep using that method, or if you want to debug this further, performing this test would be helpful:

Hi… just an update. I was close to changing computers and restructuring so I did not follow through any further. I did move Roon over to a new installation on a new computer and seems all is working fine. In fact, I have added audio equipment including an additional DAC/Headphone preamp and BT to Home Theater receiver along with the previous USB Dac …… I have to say that Roon somehow helps me manage all these alternate outputs easier than with any other software I have used. It is quite nice. Cheers.


Hi @Craig_Davidson,

Glad to hear that the issue is resolved since switching Cores!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.