"Lost" Wireless Devices on Roon and Sudden Inability to Access Roon From Them

I have used the same server and devices for a long time. All wireless devices were previously identified by Roon Audio Settings.

Wireless devices include an iPhone 7 and two iPads. All have worked well with Roon and all are able to access the internet – wifi is turned on.

There has been no change in operating system (Windows Home Server 2011) and no updates to it. Roon software is up to date (Version 1.7, Build 511).

I did recently upgrade my NADAC+Player firmware. As a result, NADAC+Player is now identified as a Core that requires an update. My actual Roon core resides on my server and currently operates as it should (except for when it comes to my wireless devices).

I am able to control and play music through the Roon server interface with both DACS (NADAC and Chord DAVE).

I have not changed my networking gear for nearly one year. I use a Netgear CM1150B modem, an Apple Time Machine router, and Ubiquity switches. All seem to perform well.

There are two issues. First, Roon (at the server) doesn’t recognize my wireless devices. Second, I am unable to connect with Roon through these devices.

When I attempt to connect with Roon with my wireless devices, one of several events occur:

First, my server’s Roon Core is identified but the connection is unsuccessful (the light flashes between yellow and red before seeming to “give up”). The “connect” light is light blue. Often, there is also the same behavior described in the next paragraph.

Second, the server’s Roon Core is not identified, but the NADAC+PLAYER is found, a green light is lit and a message by the light indicates that an update is required. I suspect that this happens because the manufacturer offered a package that included Roon when I ordered it but was unable to actually provide it at the time it was shipped to me. Roon was not actually included but the NADAC+PLAYER apparently was set up for it to be added.

Third, I am directed to the “Choose Your Roon Core” screen which eventually changes to the NADAC+PLAYER option (as described in the previous paragraph) only.

Some additional information:

I have performed a factory reset on the NADAC, reinstalled the previous firmware previous release (that had been working), and reinstallied the maintenance mode (both previous and new versions). I tested the remote Roon on my iPhone after each step (and with every combination of firmware and maintenance mode software) and it made no difference.

Lastly, when the NADAC is turned on, Roon is able to find the NADAC core but not the server core. When the NADAC is turned off, Roon is unable to find any cores. Occasionally (but inconsistently), I am able to reboot the iPhone and the server core is located but not able to connect (as indicated in prior report).

Hello @John_Roberts,

Thanks for reaching out to us here. I am looking over your post and I notice a few aspects we should investigate further:

In the past, we have seen “teredo tunneling pseudo interface” interfere with Roon working as expected in a Windows Server setup. If you have this interface enabled, it would be worth a try to disable it if you are not using it.

We often suggest user to stay away from Apple Networking gear, as we have seen poor performance in the past, as mentioned on our Networking Best Practices Guide. It is too early to say if this is the fault here but one aspect to consider.

When this behavior occurs, do you still see your Windows Server on the network as having a valid IP address?

What happens if you bypass the switch and connect directly to the router, does the system remain stable them? Sometimes switches (even enterprise-grade one’s) have hardware failures, so I wouldn’t discount this as a possibility.

Noris –

Thank you for your response.

I have not been able to locate a “teredo tunneling pseudo interface” on my server. The server is almost entirely used for music (and some photography storage), so I would be willing to disable it if I can find it.

I will consider replacing the Apple Networking gear at some point or sooner, if it appears to be the culprit in any of my mishaps with Roon. For me it has been quite useful and the Time Machine function has been really good to have, on several occasions.

I am not sure if this answers your question about the Windows Server being visible on the network as having a valid IP address: In several instances, while waiting for Roon to be found on my server, I have been able to log onto my music folders from my ethernet wired laptop.

On occasion, the server’s Roon Core appears on the wireless device’s screen (while searching for a core) – the light fluctuates between orange (mostly) and red only to turn solid red eventually.

I usually have the server directly connected to the router and the problem persists. I tried the opposite experiment – plugging the ethernet cable from the server into a switch – again, with the same results.

Thank you for your help with this.


Hi @John,

Thanks for the additional info.

Do you notice any text being displayed when you are in this state?

Just to clarify here - have you used any Time Machine backups with Roon before? We have seen database issues occur if users have restored backups from Time Machine.

Let’s also take a look at logs to see if there are any obvious errors, can you please use these instructions to send me a log set from your Windows Server Core? The best way to get them over would be via Dropbox / Google Drive / Send.firefox.com.


Noris –

Here is the Roon Log zip file from my PC Roon Server. https://send.firefox.com/download/19bf5e7e8ef273ba/#K5pyb2YB8HL66EIzFtPjzA

I am also including a screen shot from my PC Roon Server.

On The Choose Your Roon Core screen (on my iPhone remote) it says, “The Core is the brain of your Roon system. It manages your audio devices, music library, and any Roon Remotes on your network.”

Below that, it says:

 Firmware 1.0 (build 448). Stable /:fff:, Version 1.3 (Build 276)
 (Green) update required
 The Connect Button is blue.

  Windows 7/:fff: version 1.7 (build 511) stable
  Connecting (Orange) and Connection Failed (Red).  The Connect button is faded blue. 

At the bottom of the screen is a “Configure Roon OS devices on your network” message in light blue.

I can only get the information about my server (PHT-NAS-04039) if I shut down and reboot my iPhone. After a couple of attempts, it doesn’t show up on my phone screen.

Here are some screen shots from my PC server screen :

I have never used the Time Machine for my Windows/Roon server. It is used for my laptop (which is not linked to Roon in any way).

Please let me know if you have any more questions.

Thanks for your help.


Hi @John_Roberts,

Thanks for the additional information.

I took a look through these logs and this log package appears to be from the NADAC, not from the Windows PC Roon Server. Can you please upload a log package from the PC and not the NADAC?

Noris –

Let’s try this instead:


Hi @John_Roberts,

Thanks for sending those logs over. I am looking through them and I’m noticing that your Core is constantly trying to connect to a NAS drive, filing the logs with this attempt over and over again. Do you have a NAS drive on your network? Can you please try temporarily disconnecting the power from the NAS and rebooting your Core and Remotes?

The NAS is where I have Roon installed.

I know it is kind of confusing. I have an NADAC+PLAYER but I use the NAS for the Roon Core. It started because when I bought the NADAC, a lifetime membership to Roon was supposed to be included. When the NADAC arrived, there was no lifetime membership to Roon. I obtained a refund (for the Lifetime membership) from the distributor, via the dealer, and decided to have the Roon reside in the NAS where the music was.

This turned out to be a pretty good decision because I later added a Chord DAVE to my system.

In short, I am not interested in having Roon reside in the NADAC. I would prefer to have it continue to reside in the NAS (where it has been all this time).

Do you still want me to try to bypass the NAS to see if it will get Roon to work in the NADAC?

Hi @John_Roberts,

Thanks for clarifying that the NAS is actually the Core, that disproves my theory in that case.

Since you are unable to connect to the Core in the present state, our next step here would be to try a fresh Roon install on the NAS Core. Can you confirm if you have any backups of your database?

I would use these instructions to set the current database aside:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon database folder
  • Restore from backup

Can you give that a try and let me know if it changes anything?

Hi Noris –

Since my last message, I managed to update the NADAC Roon software (thanks to a lot of help) and get the music uploaded. The NADAC Roon is pretty much operating as one would expect – including the ability to operate it via remote (iPhone and iPad). In addition, there seems to be some performance improvements, especially in the area of volume control with the remotes (iPhone and iPad).

The popping is much better now – more like the sound of a needle being placed on a vinyl record. Although it is not one of my favorite sounds, it is several magnitudes better than what I had before. I will continue to test it for the next several days.

After the NADAC Roon became operational, I did follow your instructions and reloaded Roon for the NAS Roon Core (I didn’t do anything with the NADAC Roon Core). Although this resulted in some improvements (several devices reappeared in Roon, such as Apple AirPorts and one of the two Apple TVs), I continue to be unable to use the iPhone and iPad to operate it.

Now that the NADAC Roon Core is operational, when the NADAC Roon Core is selected, the iPhone and iPad devices are able to control Roon – easily and with far fewer “glitches” such as difficulty in smoothly and consistently increasing or decreasing volume. It operates as a remote should.

Interestingly, the NAS Core looks to be operating when I look at the NAS display. When I play something from the display, it interrupts the music that is playing on the NADAC. When I pause the music (on the NAS display), the music on the NADAC (which was paused) resumes playing when I press the play button on the iPhone.

I do have two lifetime licenses and, as part of my experiment, one may have been applied toward operating the NADAC and the other toward playing the NAS. If I can get this to work properly, I will want to keep it this way (and buy another license for my system at my office). I mention this because it is likely part of the reason why this is happening (at least from a licensing perspective).

Do you have any other suggestions? Does this new information give you any ideas of where to look for a solution?

Thanks for your interest and help. If I don’t hear from you before next week, I hope you have a wonderful week-end.


Hi @John_Roberts,

I hope you had a wonderful weekend as well!

Thanks for the update, glad to hear you got the NADAC Core up and running. As for troubleshooting the NAS Core:

Can you check to see if you have re-added Roon and RAATServer as exceptions to any firewalls you have on the NAS?

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path. I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have on the NAS Core.

What is the message you’re being presented with when trying to connect to the NAS Core via your iPhone/iPad? Is it the same Connecting (Orange) and Connection Failed (Red) message or did anything change since re-installing the Roon database?

Noris –

I re-added Roon to the exceptions list on the NAS firewall.

I could not locate RAATServer on my system. Is this something I should do something about?

At this point, both Cores are working and it is easy to switch back and forth (which is pretty cool!). In addition, all Roon active devices are showing up in Settings in both Cores.

I do have an additional issue. I tried to play a DSD 256 (and also the DSD 128 version I have) recording that I downloaded from NativeDSD (Arne Domnérus’ “Jazz at the Pawn Shop”) and have not been able to get it to play through the NADAC Roon Core. I get two errors: “Playback was interrupted because a track failed to load” and “Too many failures. Stopping playback.” These are new errors to me.

In fact, sometimes I cannot easily locate in in the NADAC Roon Core Library. It easily appears in the PC Server Roon Core library.

This raises a question for me. It seems as though the two Cores are operating off of two libraries. Is this the way it should be set up (for two Core set-ups)?

Shifting over to the PC Server Roon Core, it is able to play both versions of this album with no apparent difficulty. It is a beautiful recording.

Any suggestions on what can be done about this. I have noticed that the NADAC Roon Core produces better sound quality and it is ironic that I cannot get it to play this recording. In addition, I have noticed that it does play other DSD256 recordings quite well.

Thanks for your help to this point. You have been a great help!


Hi @John_Roberts,

Glad to hear that both Cores are operational at the present time!

RAATServer should be in the similar Database Location as RoonServer, it has it’s own unique folder in the %localappdata% directory.

It is possible that the NADAC Core does not have sufficient processing power to play the DSD files, what does the Signal Path look like when you try to output DSD content? Can you share a screenshot of it?

I would take a look to see that the Processing Speed does not drop down under 1.2x or so, if it does this would indicate the processing speed is not sufficient for DSD playback.

It is also important on where the DSD files are being stored. On your NAS Core, this DSD file would be local on it’s own HDD and when using the NADAC Core, it would be reaching out to the NAS and involving the network for the playback (to fetch the file from the NAS), which also adds a processing overhead.

You can choose to have the different Core setup or you could restore one of the databases to the other using the Backup feature. The database being the same is only required if you want to have any metadata edits/Roon-created playlists available on both Cores.

Do note that restoring a backup will overwrite any custom settings you have made on the previous install and you might need to re-configure your Roon Settings -> Storage locations if you go down this route.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.