Loud Pop on my speaker when switching songs

I’ve set my resync delay to 2000ms and this seems to have helped with the pops.


It seems your issue is related to sampling changes…

I experience similar low level pop noises using DSP volume and the play/pause function.
It seems others do to.

Although this is not “sample” change, I wonder if its related some how.
It would be great if Roon support would comment?

1 Like

Thanks for this tip. I wasn’t aware of this sampling rate change “playback delay” feature.
My Motu Mk5 Uralite takes about 4 secs between sampling rate changes to play music, I would always miss the start of songs. Perfect fix! without upsampling everything to a fixed sample rate. Cheers.


Upsampling was my next suggestion if this doesn’t work. This might be useful if setting 16/44 doesn’t do a perfect job, or even improve it as well.

OP has gone off to test this, but thanks to you @grizaudio and @RBO for offering him additional help as well.


You’re welcome. Give us a shout if it works for you :slight_smile:


Yep, the delay works perfectly for synchronising Roon playback start times/with Motu DAC sync/clocking times.

I like to keep my sampling rates native. My active setup uses a liberal dose of DSP for crossovers and room correction so this “delay” method is the ticket to minimise CPU demand!..

Appreciated… I really should poke around in settings more often.

I just notice an issue though. With this setting engaged, Roon radio doesn’t automatically transition into playback. The thumbs up and down messages appears, I need to test a few thigs.

1 Like

I’ve just tested this and radio kicks in just fine.

Yeah, working now.
Once I clicked the radio Thumbs up pop it was fine.

I set sample rate to 48K and max bits per sample to 16. Also set the resync delay to 2000ms…have not heard the pop as yet…but will keep you guys posted…I’ve not got a chance to do extended listening. Thanks to all of you who responded…

1 Like

Was hoping I found the solution…nope the above did not work…just got a pop on starting a song…

Are playing MQA?

I have not had a pop since setting resync delay but will test some more just in case pops are not as often now and somehow I missed them.

Can you screen shot of the signal path for the song that caused the pop?

As @RBO mentioned that if you are playing MQA it gets treated differently. Some people disable MQA on their DACs for this reason.

Fiddled with different sample rate songs from Qobuz and Tidal (FLAC and MQA) and surprise, I get the pops again even with resync delay.

I get the pops even when playing different sample rate FLAC so it’s not MQA related as far as I can tell.

Michael, how do I take a screenshot of the signal path… sorry is this a silly question… as I said I’m a newbie to Roon…

Depends on the platform, but Android and iOS you just use the screen capture app, on Android its power button and volume down and on iOS it’s power button and volume up.

You will see the signal path like below.

Here is what I see is in the signal path

And I can’t figure out what is optimizing for speaker settings… DSP is completely turned off in Roon

That is strange, distance is normally set in DSP (see screen shots) if it’s not visible it shouldn’t be active. But you can add the filter then disable it to make sure.

Thanks for that, when you get a pop do you know if you are playing a track at a different resolution so you can use the signal path to see. I would expect if you played a 24/48 or 24/192 track that it would engage DSP to make the track 44/16 and thereby keeping al the music on the same digital output path and saving the DAC from having to switch.

This is only an assumption on my part that it is this causing it.

Some people use DSP for setting their Roon outputs to upsample everything x2, but first it’s good to find out if this is actually your issue.

Change in resolution was the problem in my case, resync delay of 500mS resolved it.

1 Like