Loud popping noise when starting new track - native DSD only

Hi Jussi,

I am hearing a loud popping noise at the beginning of new tracks, when playing in native DSD mode. It sounds more like lifting a needle off a spinning record with an unsteady hand, rather than a “pop.”

My DAC is an LH Labs Pulse X Infinity and I recently updated the firmware to support native DSD. I am using HQP in SDM output mode and of course the µRendu as the NAA. When I have DoP selected, everything plays fine, but when I switch it to native DSD, I hear the noise.

Can you help me troubleshoot this?

Here are my HQP settings:


1 Like

I’d suggest increasing the buffer to 250ms then trying increased and decreased values until you find a minimum value where the noise artifacts don’t appear.

Thanks Andrew, I will give that a try to see if that helps.

What’s strange about this is that the noise only happens when I have native DSD selected, not DoP. Same tracks and all the rest of the settings are the same.

Unfortunately, that did not work. I changed the buffer to 100ms and no change, so I changed it to 250ms and I still get the noise. On one of the times I made the change to HQP, quit and restarted it, then restarted Roon to play the same track, I got white noise. Bummer!!

Too bad HQP+Roon in native DSD is so flaky because it sounds absolutely incredible. To my ears, native DSD sounds better than in DoP… which is surprising because from what I’ve read, there should be no difference sonically.

I don’t what else to try. Hopefully Jussi will chime in here and offer some suggestions.

Well, pure speculation here, but… I might have identified the source of the problem. First of all, the noise does not happen at the beginning of all tracks, it seems to happen when I’m going from PCM to a DSD track.

I am using the sonicTransporter to attach my music storage drive (USB drive) to my LAN. As I was just listening, I heard the HD spin-up at the beginning of a new track and… the noise happened! So perhaps, the drive is going into a sleep mode and when the track changes, it’s having to spin-up perhaps causing a delay and causing HQP to hiccup, thus making the noise? I’m speculating here, but it could have something to do with it.

Now, if I can just figure out how to prevent the HD in my USB drive from going to sleep.

Is it viable to put your library on an SSD ? You could experiment with a selection of tracks on a new watched folder on an existing SSD to see if it makes the difference.

Let’s drop a flag for @jussi_laako in case he can add something.

I asked Jussi this question a few weeks ago and got the following answer:


That is common problem with DoP and DACs that don’t follow DSD
specification closely enough. The specification requires DAC to mute
output for 50 ms when DSD stream is starting and when it is ending to
avoid such noises.

HQPlayer does play silence at beginning and end of playback. But not
between tracks. Make sure you have either PCM or SDM output mode
selected (instead of Auto) in main window so that DAC stays at either
mode and doesn’t keep switching between the modes…

Best regards,

    - Jussi

Thanks for the information Stephan.

In my case, I am getting the noise with native DSD and I have SDM output mode selected in the main window.

have a message into Jussi but haven’t heard back yet.

Hi Gary

I’ve had this problem with DSD 256 for about 4 weeks now - but I wanted to check if you are getting the same behaviour -
the ugly pop only occurs of I change the track - if it’s fed a Play All command, a Playlist, Album - track after track it is fine. But if I change the next track - that’s when I get the pop. (I am streaming from TIDAL to an OPPO-HA2)…



Does it happen also when playing locally with HQPlayer without Roon?

Are you using latest HQPlayer version?

Hi Jon, sorry for the long delay in responding. I will check that out tomorrow and report back.


Hi Jussi, I will check this too and report back tomorrow.

  • Gary

Here’s a summary of when this noise occurs. Note, all of these tests were done when HQPlayer is used with Roon and microRendu as NAA. All of these tracks were placed in playlists with mixed file types, sample rates and bit rates.

The noise occurs at the beginning of playing certain tracks. Here are the tests I conducted (each row indicating the starting track and next track in the playlist):

Redbook to Redbook
Redbook to hi-rez (24/96)
Redbook to hi-rez (24/192)
Redbook to DSD
Hi-rez to Redbook
Hi-rez to hi-rez
Hi-rez to DSD
DSD to Redbook
DSD to hi-rez

Here are my findings:

No noise:

DSD to Redbook
DSD to Hi-rez (24/96)
DSD to Hi-rez (24/192)
Redbook to Redbook
Hi-rez to hi-rez (same bit/sample rate)

Nasty noise:

Hi-rez to hi-rez (different bit/sample rate) - (Noise both directions)
Redbook to hi-rez (24/96)
Redbook to hi-rez (24/192)
Redbook to DSD
Hi-rez (24/96) to Redbook
Hi-rez (24/192) to Redbook
Hi-rez (24/192) to DSD
Hi-rez (24/96) to DSD

I will be repeating the above tests in HQPlayer without using Roon and I will report back.


I just repeated the above tests in HQPlayer alone without Roon and low and behold… there is NO NOISE at the beginning of tracks. I do hear the noise the first time I click play to start playing a playlist, but none of the noises between tracks that I hear when combined with Roon. I can play any combination of track types - DSD, Redbook, hi-rez, different sample rates and bit rates and there is no noise at all at the start of tracks. It’s dead silent!

So the issue is present when using Roon + HQPlayer in native DSD mode, again using microRendu as an NAA.

Does anyone have any ideas as to what could be causing this within Roon? Perhaps a setting I can adjust?

Andrew @andybob - do you have any suggestions?


Hi Gary,

I’m afraid I’m stumped. I’ll drop a flag for @brian to see if he can suggest anything or reproduce the issue.

Do you have a DAC available other than the LH Labs Pulse X Infinity ? That could confirm whether the issue is particular to the DAC.

I do hear the noise the first time I click play to start playing a playlist, but none of the noises between tracks that I hear when combined with Roon.


Reading through this thread, it sounds like it might be making an unpleasant sound when HQPlayer wakes up your DAC. Some DACs are noisy when making transitions, or require a period of silence after starting/switching streams. When you configure Roon to speak to a DAC directly, we have settings for this sort of thing (e.g. “resync delay”). Unfortunately, we don’t have any control over the particulars of how HQPlayer or NAA talk to your DAC.

When you play back using Roon and HQPlayer together, assuming you haven’t enabled Roon’s DSP features (e.g. volume normalization, crossfade), Roon is passing the audio stream to HQPlayer exactly as it appears in your files, without any extra junk or artifacts–i.e. we are confident that the pops you’re hearing are not embedded in the actual data stream(s) passed from Roon to HQPlayer.

I’m aware that HQPlayer uses some different code for receiving streams from Roon than when playing straight out of a files. When we switch HQPlayer streams (e.g. on a format transition), we ask it to stop the first one, and then begin the next one. Perhaps something about how HQPlayer processes these commands during those transitions is causing extra artifacts. It’s certainly possible that HQPlayer’s file-based mechanism is designed to manage the transitions differently.

Since HQPlayer owns the relationship with the DAC, I’m not sure there is much that we can do from our end–our role is in generating the source data and passing it along to HQPlayer unmolested, not in managing smooth transitions on the player/DAC side.

If there is something that we’re doing wrong, we’d certainly be interested to know the technical details from @jussi_laako once he’s investigated in more detail, but I think the debugging of this issue is going to start there.

Thanks Andrew, I will see if I can get my hands on another DAC that’s native DSD capable to run some other tests.

Hi @brian,

I will make sure there are no other DSP features enabled in Roon. RoonServer is running on a SonicTransporter, I assume all of the same settings are accessible via the control device (my laptop).

This could very well be the issue. But I would think that many more customers report this same issue if that were the case.

I will try to get another native DSD capable DAC to test and report back.

Thanks again for your response.


The most interesting thing in your report is this: I do hear the noise the first time I click play to start playing a playlist.

My understanding of HQPlayer is that it performs an operation equivalent to starting a playlist when Roon stops a stream and starts a new one. I think this is what makes Roon+HQPlayer different from HQPlayer alone–HQPlayer does something smoother when playing within its own playlist mechanism than when switching between Roon’s streams.

If I were you, I would attempt to get the noise at start of playlist playback fixed purely within the world of HQPlayer/NAA. Once you can start a playlist without artifacts, put Roon back into the equation. I think your problem will be resolved.

It’s too bad HQPlayer doesn’t have a “resync delay” facility (at least, I just took a look at their settings screen and couldn’t find one). If you were having this symptom with RAAT, a short resync delay would be my first suggestion.

On this point, I come to a different conclusion.

If Roon were sending junk to HQPlayer during transitions then every user would have this problem when transitioning between sample rates, regardless of the DAC or the other setup details. The fact that this is not generating widespread reports suggests to me that the variable that’s causing your problem is further down the chain, where most of the variation lives.

I’m going to continue to monitor this thread in case there are new developments. Good luck.

Interesting Brian, thanks for your insights.

That sounds like as good a place as any to continue trying to resolve this.

@jussi_laako Do you have any comments or suggestions on this?