Loud popping noise when starting new track - native DSD only

Brian and Jussi,

A quick update: I changed several settings in HQPlayer and nothing seemed to eliminate the pop at the beginning of playing for the first time.

But here is what’s interesting:

  1. The pop does not happen 100% of the time at the beginning of playing a new list of tracks.
  2. The pop does not happen when I have DoP selected under SDM Pack.

But the fact that it does not happen every time is what has me stumped. When I make changes to the settings, I make sure to completely quit HQPlayer and restart it, then replay the same starting track, but sometimes the noise happens and sometimes it doesn’t. But when I combine HQPlayer with Roon, there is 100% consistency when the noise occurs. Very strange!

At this point, I still have no idea whether it is something in HQPlayer or the DAC. I still haven’t been able to get my hands on a native DSD capable DAC to test with.

Hi Both and All

I’ve been reporting exactly the same fault with DSD in ROON/HQ in similar threads for months.

If I set to play an album, playlist and left running it won’t pop - any time I initiate a change of track or album - then that ripping noise will kick in at the beginning of the track selected.

That’s at DSD256 or 128 on an OPPO-HA2. I was advised to try it without ROON but that wouldn’t be any use to me if it were a solution as I can see it’s happening to other users.

Any updates welcome.



Jon, do you have HQPlayer set to DoP or native DSD?


Hi Gary

I believe I have tried toggling both.




I’ve been having similar issues with Roon --> HQP --> µRendu --> DAC

I posted on the CA forums and got a response from Miska, but haven’t had time to do more testing and follow-up. Based on what I’m seeing in this thread, the issue isn’t DAC-specific, but possibly specific to a particular implementation of DSD utilized by certain DACs. Hopefully there is a way to mitigate or solve the issue entirely in software.

For the time being, I’ve just been up-converting to 384 Kbps rather than DSD and don’t have any issues playing PCM files in this configuration. That being said, I would like to get things working such that I’m up-converting PCM to DSD128 and playing Native DSD without any unpleasant noise when changing tracks. I’ll see if I can do more testing this week and provide some data to help the troubleshooting process along.

1 Like

Hi @mrvco, just curious if you found a resolution or have any more info from Miska on your popping issue playing new tracks? I’m having the same issue, identical setup as you: Roon --> HQP --> µRendu --> DAC. Tried switching to HQPlayer 3.14b5 beta but the problem still persists with native DSD. The issue does not occur with PCM or DSD via DoP.

I also have the same issue of a popping noise when changing songs whenever upsampling flac or tidal to DSD64. I have a Devialet 200 that is connected to my PC via a USB cable. I don´t have this issue at all when upsampling to a higher PCM rate - only DSD.

I’ve been now trying to reproduce this without much success. Although I may have different Roon build…

I have Roon running on my Mac Mini under latest OS X. I first checked local playback to HQPlayer running on the same machine with output to TEAC NT-503. Now I’m listening Tidal stream upsampled to DSD512 by HQPlayer running on my Linux desktop and output going to iFi iDSD Micro (native non-DoP DSD).

Settings I have:
Auto rate family: enabled
Bit rate limit: 24576000
Oversampling: poly-sinc-short-mp-2s
Modulator: ASDM7
Output rate: Auto
Output mode: SDM

1 Like

Hi Jon

I run Roon server and HQP on same NUC with Win10, Chord DAVE DAC, ‘Chord Async USB 44.1kHz - 768kHz’. WASAPI driver is used, SDM pack set to DoP all the way.

With Roon + HQP for resampling everything to PCM 384, playback, skip / next / pause then play all operation without pop sound.

But if set to resample to DSD, skip next / pause then play will produce pop sound same as others.

Meanwhile I workaround by setting to PCM resampling only, as the DSD playback through DAC drivers (especially ASIO) has less consistent result among different DAC with different behavior.

@jussi_laako My DAC just upgraded their firmware to now play native DSD (Unison Research CDDUE). Same results here if I use native DSD256 it produces a loud pop before playback. DSD128 no pop.

DAC must keep it’s output mute relays muted for first 50 ms of DSD playback and also for the last 50 ms of playback. So unmute is allowed to happen only after 50 ms of DSD has been played and must be muted 50 ms before DSD playback ends.

Some DACs fail to do this and that’s why you get popping at start/end.

This problem appears to be due to a bug in ALSA regarding how it sends “silence” to a USB connection upon playback. Hint: It’s not silence …

A fix has been developed as per the thread below and a patch has been implemented in DietPi (Dan works fast !):

I expect that the mR will implement the fix when it rolls out in an ALSA update.

In the meantime I have found that Add Next or Add to Queue doesn’t trigger the pop.

Edit: The ALSA fix has been incorporated into the 4.10 Linux kernel. It may not be the only cause of pops or artefacts, but it is good to have this one fixed.


@Jesus_Rodriguez Any news on Sonore fixing this on the SonicOrbiter SE as I still have this issue.

@Jesus_Rodriguez @agillis any response here would be great. Silence is not the best… would love a simple, “working on it” or “we don’t know how to fix it”

We are working on it, but it’s going to take some time.

Hi - The details make it hard for me to follow but do you think the problems reported here are related to those I’m still experiencing? Loud Disturbing Pops When Starting a New Album or Selection

The patch implemented in the 4.10 Linux kernel that I’ve referred to related to native DSD only and corrected an error in the ALSA code. It wouldn’t affect PCM or DoP.

@Jesus_Rodriguez @agillis any update on how things are proceeding to address this issue? Hopefully this can be fixed sooner rather than later as this popping noise is driving me nuts.

It seems you will be paying for a new card and the fix in the new OS.

1 Like

I fixed the link, CA site provided link button apparently is broken.