LS50WII only connect via Airplay to Roon Core on PC (Roon Remote does not see Core either)

Hi.

I’ve just started a 14 day trial of Roon. The core is on my desktop PC and KEF LS60WII’s are endpoints. Music source is Qobuz. Reason for trying Roon is to combine the best SQ with the best UI.

Previously I have been streaming Qobuz over Chromecast (built in the speakers) as I prefer that over Airplay that doesn’t do hi-res music. Problem is though that Chromecast audio is not gapless. So figured the KEF’s as Roon endpoints may solve the issue.

But I’m having some start-up problems. Under audio settings when enabling devices the KEF’s only show up as Airplay devices in Roon? Can this be right? I see no Chromecast or other option. Airplay caps out at CD quality so Qobuz hi-res will be downsampled which is not ideal.

And even if I go with Airplay and choose the KEF’s as output devices I get no sound from them when starting a track in Roon. The timer at the bottom is not running no matter what. If I try to configure the RoonOS Core under setting it’s searching for it but nothing happens - it just keeps on searching.

And the iOS Roon app can’t connect to my Roon Core either - it also just keeps on searching not finding anything.

I’m surprised by these roadblocks as I thought the Roon setup would be a cinch. :slight_smile: Any suggestions or tips? Thanks.

Good morning!
Firstly " configure Roon core" is not applicable to your setup so nothing for you to worry about.
This is for Roon " appliances" which would be a Nucleus or a NUC running R.O.C.K.
Not for running Roon as you are on a desktop.
That is why it is endlessly searching for an appliance it cannot find.
Now when you go into settings:audio what do you see for endpoints?
Can you provide screen shot?

Ah, OK that makes sense. Here’s a screenshot.

have you checked to make sure the firmware is updated on the KEF? How are they connected to your network? wired or wireless?

They are connected wirelessly which is my only option. Firmware is latest (1.8).

It’s very strange that you’re not seeing Chromecast or KEF Streaming. Double that with your iOS device not finding the Core, nor actually playing anything (does it play anything through your speakers/headphones/whatever you have set pin your Mac as the audio output if you enable System Output?) makes me think there’s something with either your Roon setup or the network. I think you need to have a chat with Roon’s @support

Are the KEFs on the same network as Roon? I had a similar problem because I forgot KEFs were on an eero mesh network I set up and Roon on my underlying Verizon network.

Yes,I only have 1 router that all devices are connected to. Only thing I can think of is trying a re-install. Thanks for the support link I will likely have to send a request.

Hello @Kim_Christensen and welcome to the Roon community :wave:

It’s great to see you engage in conversation and to see your interest in finding a solution. So sorry about the trouble you’ve ran into from the very beginning.

This is definitely an initial troubleshooting step, but, do you have any antivirus or firewall on your desktop PC? Could you temporarily disable it and see if you can connect your devices?

Hi again. I only use the anti-virus and firewall that is part of Windows 10.

Is it correctly understood that LS50 Wireless II’s ONLY connect either via Chromecast OR Airplay? Also is it correct that Chromecast run through Roon can ensure gapless playback that Chromecast alone cannot? That is my main reason for wanting to try Roon but if it doesn’t solve the non-gapless problem then I will seek an alternative solution (or live with the gaps).

I really like the Connect solutions that Tidal and Spotify have but to my ears Qobuz sounds better than Tidal and Spotify lossless has yet to arrive. Used to have Roon and a Bluesound Node (Mk1) streamer years ago but I’m hoping to solve this without adding further boxes as I like the simple setup of LS50WII + KC62 sub. Wireless and all necessary cables tucked away in the matching stands.

And I really should test thoroughly IF I can actually hear the difference between Chromecast and Airplay streaming even though the latter tops at 48kHz.

LS50 Wireless II was certified as Roon Ready back in April, so assuming they’re on the latest firmware, which you’ve said yours are, Roon should be showing another option aside from AirPlay and Chromecast.

I’ve attached a screenshot of what I see on my network at the office. if you ignore the LSX ones, the remaining three are all the exact same unit of LS50WII (the IP addresses are all the same). The top one is the Roon Ready option, and the other two are Chromecast and AirPlay.

The IP address in my picture further up looks atypical does it not? Is it normal that the Qobuz desktop app only shows the KEF’s as Chromecast devices? Could I have gotten something wrong during the initial KEF setup?

OK, so I looked into my PC network settings and the profile was set to public so I set it to private and got a prompt from the Win10 firewall where I allowed. So now I have the KEF’s as a Chromecast option too along with Airplay but through Roon I’m still gettings gaps between the songs using the Chromecast option. I see no KEF wireless streaming option that isn’t either Airplay or Chromecast.

So in Qobuz from the PC desktop app to my LS50WII’s is the only external hi-res streaming option Chromecast? Why not just wireless streaming over the shared network and without the gaps that Chromecast introduces?

screenshot_26