Lumin D1 and Roon 1.5

After the Roon 1.5 upgrade, all of a sudden there is some processing going on and the signal path is “Enhanced”. How come? Lumin is set to “Decoder and renderer” with "MQA core processing set to “Off” in Roon.

The Lumin has been identified as an MQA capable device and Roon has configured itself accordingly. It will revert to its previous settings when you play a non MQA file.

Your signal path correctly indicates that Roon is doing passthrough of MQA music to Lumin. The Lumin is performing full MQA decoding - which is classified by Roon as Enhanced.

And you can actually leave the “MQA core processing” set to ON. As Roon will do what is appropriate, including just a straight pass through based on your setting of Decoder and Renderer.

1 Like

I just found it a bit strange that Roon did some processing when just passing the MQA stream through, but thanks for clarifying!

The Authentication step is not a processing step per se, as far as I understand it. That is just letting you know, Roon has confirmed it is indeed a real MQA file and will then begin to do the appropriate actions as defined by that device’s setup.

Hmm, still a bit confused about this. If no processing is done - why the “processing speed” indication (44.5x). It looks like the core’s doing some processing, this wasn’t the case with 1.4.
Also, my other setup with a Pro-ject S2 (decoder and renderer) doesn’t show “enhanced” signal path when playing MQA content. I guess it’s got something to do with it not being a networked device but connected to a roon bridge via USB.

Hello @sohe68,

Because the “authentication” stage is still a part of the signal path, even if it’s not modifying the bitstream in any way, this will trigger Roon’s “processing speed” indicator.

As to why you’re not seeing “enhanced” in the signal path, this is because the Pro-Ject Pre Box S2 Digital does not support the MQA HID signaling in it’s current state. MQA HID signaling allows for the device to report back to the program what it is doing with the MQA stream. Since we cannot be certain with devices that do not support these commands, we can only guarantee that the playback is “Lossless” instead of the full MQA “Enhanced” state.


On the Lumin D1, set the MQA Core Decoder to on/ yes, and try again.

I assure you the signal path for the Lumin playback is correct. It looks different from 1.4 because 1.5 expects a more detailed reporting from RAAT endpoint if it is a MQA decoder or renderer. Lumin has already implemented it 3 months ago. As for the other non-Lumin setups, they may have other technical limitations or need further enhancements to show the same thing.

Please do not worry about the processing speed indicator. Your signal path shows that Roon Core is doing passthrough and not performing any processing.

That being said, it’d be worthwhile to try shifting the MQA Core decoding from Lumin to Roon Core by setting MQA Capability to Renderer Only. See if you hear any difference in SQ. Reference: Roon Decoding MQA Listening Impressions

Excellent, that’ll give me peace of mind :slightly_smiling_face:

@wklie One more question, when Lumin’s in “Renderer only” mode and letting Roon doing the first unfold, the display is showing 96/24 although original MQA is 192/24? Signal path looks OK.

The MQA 192kHz music is delivered in a 48kHz file, which Roon decodes to MQA Core in 96kHz, and Lumin performs MQA rendering for the MQA 192kHz music. Your signal path also proves that Lumin is one of the MQA playback device that can accept MQA Core as decoded from Roon. (There are some other devices that need a firmware update to fix that.)

Do you mean the front panel is showing 96kHz?

Yes, the display on the D1 corresponding to the screenshot of the signalpath in my post.

I’ve tried a few other tracks from Tidal with Lumin set to “Renderer only”. Lumin display always shows the sampling- and bitrate after Roon’s first unfold - not the fully rendered if the track goes beyond that. Must be either a bug or some setting of mine that’s wrong, but I’ve double-checked.

I hope to get this front panel bug fixed within the next 18 hours.

I tried to test this case back in February using some sort of emulation of Roon behavior (months before Roon 1.5 was available). Apparently my emulation had timing differences with the real thing.

1 Like

Please use Lumin app to upgrade to Firmware 10.3.

Lumin accepts MQA Core decoded signal from Roon.

Lumin users can try setting MQA Capabilities to “Decoder and Renderer” (default) or “Renderer only” for playback of MQA music. See if anyone think there is any sound quality difference or not - even if the digital bits are the same. In the “Decoder and Renderer” case, the MQA Core decoder runs on Lumin and uses more processing power, in the “Renderer only” case the MQA Core decoder runs on Roon Core.

Although MQA official recommendation is to have the MQA Core decoder and the Renderer in the same device, I believe in the Roon model, i.e. heavy processing should be done in the Roon Core. Otherwise why spend the money on an i7. :grinning:

1 Like

Fantastic, I can confirm the sampling and bitrate info is shown correct now. One minor thing, the signal path in Roon shows “ORFS” for the output while the Lumin panel shows “OFS”. Is that intentionally?

Yes, but both mean the same thing - Original Sampling Frequency.

When I choose the setting “Renderer only” and play an 192 KHz MQA file from Tidal (e.g. Thelonious Monk with John Coltrane, Ruby, My Dear) I hear this hissing sound in the back of the music. It disappears when I let me Lumin D1 do both decoding and rendering. My Roon core is running on an older iMac (2.66 GHz Intel Core 2 Duo), maybe that has something to do with it?