Lumin d2 Not found on windows 10 roon core

Core Machine (Operating system/System info/Roon build number)

Windows 10

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Private network Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Lumin D2 (release date 2020-8-13)

Description Of Issue
Hi, Im trying to play music from roon on my new lumin D2 But I can see my lumin device in roon app.
Roon app, roon server, and roon bridge are installed but i can see lumin D2 in available device.

I can figure out wy wherase I can see my android phone on roon, and can connect to my pc librarie from Lumin native app.
I also tried to disable my firwall with no success

Thank for your help!

Cyril

The D2 should be connected to the network. You should see a circle on the front panel. Its USB port should be left unconnected. You should not need Roon Bridge - please uninstall it.

In Lumin app, select Lumin D2. In settings, turn on Roon Ready.

In Roon settings -> Audio, scroll down to Roon Ready section, find Lumin D2, enable it and give it a zone name.

Play something, then use the zone selector to switch to Lumin D2.

If you want to use Lumin app instead of Roon to play music, you need to install the free MinimServer on the PC.

Please keep the firewall disabled until you get this working. After disabling the firewall, please reboot your Windows.

For now I think this is likely a settings issue in the Lumin so I’m moving it to the #audio-products:lumin area.

You need to go into roon settings once the lumin settings have roon enabled and there under audio you should see the D2 listed as Roon Ready.

Hello,

I try do do what you said but nothing seems to work.

  • I desinstall all roon programme
    -disable my firewall.
  • install only roon server on my computer
  • check that roon ready is on

when i launch roon on may android mobile, I can see That roon core is working. I can play music on my phone or on my computer by selecting the zone with the roon remote app.

But i can not see lumin in audio device menu. I feel a little frustrated…

In Lumin app, please factory reset the D2 in the About function of D2.

After that, please post a screen capture of Roon Settings -> Audio, and scroll down to Roon Ready section.

Don’t forget to activate roon ready in the lumin app options.

Hello,
All firewal are desinstall and my lumin is connect to network with ethernet. (i can play music directly from spotify) but can see it in roon setting

Here the screens of my lumin app :slight_smile:


Add images

Please factory reset the Lumin D2 using the Lumin app.

Please state the brand and model of your router.

Please describe your network topology in detail, if you have any network switches, WiFi access points, etc.

Is your Roon Core directly connected to the router using Ethernet cable?

Is your Lumin D2 directly connected to the router using Ethernet cable?

If “Private” means any special configuration such as VLAN or “AP Isolation”, it does not work. The Roon Core, smartphones, and the Lumin have to be in the same subnet. The network also need to pass multicast traffic - this is often related to IGMP settings.

If you have an unmanaged network switch, please connect the Roon Core and the Lumin D2 to the network switch, not directly to the router.

Hello,

Hello, roon and my lumin is working great ! But only if coonnect directly my lumin directly on on the rooter/box and not on the main switch of my house.

I’m using 2 switchs.

  • The first one is a NETGEAR GS305E in my listening room.

  • The second is a Cudy FS1018PS1 Switch PoE where room of my house are connected.

Do you have some idea on wy I cannot use my Lumin D2 in roon ready mon with those switchs ?

Thank you for your help

You’re using a managed switch, which is usually especially difficult for Roon. This would explain all the troubles you had.

You need to configure it to pass multicast.

For the Netgear ProSAFE Managed switch, please try these settings for IGMP Snooping:

And do not use VLAN.