Lumin T2 mid/high distortion "spitting" "splatty" DAC gone bad?

I’ve noticed many songs a mid/high distortion that sounds like a cable might be loose or a bad connection somewhere. Finally after hours of switching out cables I decided to bypass the DAC and use my Anthem STR DAC (via usb) instead. Spitting sound gone!

It’s not an MQA thing because it happens on Qobuz as well.

At first I thought I’d blown a tweeter or mid driver.

Also of note, I’ve turn off all processing in the Lumin T2 and letting Roon do the heavy lifting.

Is this a common thing? I found out that Lumin’s customer service is in China and they don’t have an 800 number so I had to email. This ought to be very interesting.

Note: that most of the time the dac sounds fantastic! It’s only on those transients that I hear a “splatter” if you will at ALL volumes.

Thoughts?

Never had anything like that with my T2. I don’t use any DSP either in Roon or the T2, which is connected to my amp by XLR.

Does it also happen if you are playing files from storage rather than streaming Tidal/Qobuz?

One of the senior folks from Lumin is a regular on here so I’m sure you’ll hear something soon.

This is probably a case of too much gain. Stop any playback. In Lumin app please set Analog Output Level to Low, or/and use RCA instead of XLR output.

If you’ve just got the T2 brand new, please burn it in 7x24 by repeat play for no less than 2 weeks.

Thanks Peter, I was hoping you’d weigh in. I’m surprised I’m the only one experiencing this as it’s very audible and many people have similar equipment…

I’ll post pics of all my settings too…

Preamp - Anthem STR
Amps - PS Audio m700
Connections - XLR from Lumin to Anthem STR and from Anthem to PS Audio amps
Speakers - Tekton Double Impact SE (tried on brand new other speakers as well so it’s not the speakers or wires).

  • Please set Analog Output Level to Low
  • Please set Custom Re-sampling to Off
  • You may also try RCA instead of XLR

Here’s my Roon set up:

I did try RCA, same deal… Even so, I would NOT be very happy if my very expensive streamer’s XLR’s didn’t work.

Changes made… Might not get to listen tonight (wife and baby get weird about that :slight_smile:

How does this change the gain?

It does not.

@Chris_Spruiell Do you also have any dsp or eq going on in roon? If so I would turn all that off and just let everything run native bitrates

1 Like

Nope… I should be bypassing all this…

I turned off the Analog Audio Output Level and that seems to have fixed it. However, I’m a little perturbed that I have to turn that off given it lends more volume/headroom.

It depends on your amplifier’s analog inputs, which is why there is an option to have low or high output level from the T2. Well done Lumin.

I see, I’m not familiar with that part of my preamps tech… I’m guessing my Anthem pre is has more “sensitive” for lack of better term inputs… idk

I experienced this too. Only one time, last week when switching in roon between dsd512 and native. Took about 5 minutes and disappeared after playing other album.
Never since.

Great. There’s one more thing you can try, if you do not absolutely require the built-in Room Correction in the preamp:

  1. Stop playback and power off the M700
  2. Connect the T2 XLR output to M700, i.e. bypass the STR preamp
  3. In Lumin app, enable Volume Control and Leedh Processing Volume, and set Analog Output Level back to Normal.
  4. Set volume to a really low value, e.g. 10, then power on the M700.
  5. In Roon, recheck the volume value then start playback and gradually increase the volume to a level you normally listen to.

To compare loudness you may use a free sound level meter app on smartphone, before and after this setup change.

See if it sounds better this way.

I have a D2 connected directly to my M700 thru xlr. Dynamics is better compared to when connected with my preamp took away the coloration too.

1 Like

Thank you to all the info on this. Peter’s suggestions fixed the issue… Also, one other thing that also contributed was in the Anthem STR preamp. If you go into the Input settings there a setting called “Convert Analoge”. Set it to “No”.

By default this setting is set to “32/192” which i suppose upsamples analoge sources?

I played around with the Leedh volume and it was nice but not a noticable difference in the short time I spent with it. Hard to tell really… But I found it cumbersome to change the volume from my phone all the time. Also, I’d be bypassing my ARC room correction whenever I get around to setting it up :slight_smile: