Lumin T2 Sound Quality

Good Evening. I recently purchased a new Lumin T2. I connected it to a Mcintosh MX 122 with XLR to a Mcintosh 302 Amp. I have also tried RCA and direct connect to the MCintosh 302 AMP via RCA and then a Rotel Amp via RC. I have used it for around 100 hours. Unfortunately, the sound quality is not good. Suggestions? I have already tried turning off digital processing. Thanks

Please burn it in 7x24 by repeat playback for several weeks.

You may also try using Roon DSP engine to convert to DSD and see if it sounds better to you this way.

How do I do that? Thanks

You may access the Roon DSP Engine settings.

Please turn on Parallelize Sigma Delta Modulator.

See:

Perhaps define “not good”. Is it distorted? Not long enough? What’s the issue?

I’ve had a T2 until very recently and I’d say the sound from it is anything but “not good”.

Also please try setting Lumin app Analog Output Level to Low and see if it helps.

@ Jack: out of curiosity why did you buy the T2 and did you read on the ROON forum about it?

Distorted.

This did not help at all.

So its sounds very distorted at times. It is loud enough. Generally, vocals and piano music sound ok (Same tracks played on Oppo 105 or Sonore Optical Rendu sound 100% better). Music sounds blurred, garbled and electronic.

Those descriptions of the sound your hearing is odd. I would never use those descriptors to explain the sound from my T2.

Hope you get straightened out.

Good luck with it.

I tried all of this. I think this may be a defective unit as I can’t believe a burn in period will fix this poor sound quality.

Roon influenced my decision.

This almost always points to the (pre)amp does not like the high output voltage of the Lumin. Typically setting Analog Output Level to Low should solve it. After setting it, Roon playback needs to be stopped and restarted.

I tried this to no effect. The same distorted sound just had less volume. I also by-passed the preamp and did a direct connect to my Mc 302 Amp via XLR. This resulted in no change. I then tried a Rotel amp via RCA. There was no improvement.

I also used two sets of XLR connections to make sure it was not a cable. I also has my BW 803 D speakers tested. They are fine.

Please factory reset the T2 using Lumin app - About of Lumin T2. After it boots up again, set the Analog Output Level to Low, disable “Lumin Streaming” (AirPlay), and disable Spotify Connect.

I did all of this and there is no improvement.

Please make sure Roon DSP Engine and especially volume leveling are disabled.

If you still find it sounds distorted, please take it to your dealer and have it checked.

In the absence of improper configuration (such as mismatched output level), a distortion might be a hardware defect, however exceptionally rare it may be.