Lumin U2 Mini no longer working

I just saw today that y U2 Mini was no longer detected by Roon as a Roon Ready device, only as an Airplay device but it didn’t play anything.
I started the Lumin App but it was no longer detected there as well.
I could see it in my router and the network lights on the switch it was connected to worked.

Rebooted the whole network, no change.
Hardware reset the U2 Mini, no change.

Connected it straight through the router instead of a hub, was detected for a few minutes by the Lumin app, not by Roon, then it disappeared again.
While I could see it in the Lumin app there wasn’t much I could do with it, no button for firmware update etc …

Tried a hardware reset again while connected to the router but it asked for a USB stick, then showed “Leedh Processing” on the screen and rebooted but still not visible in the Lumin app or Roon.

Tried a third hardware reset and now it’s stuck on “Leedh Processing”. Network LEDs are flashing all the time though.

Weird thing is that is keeps being detected as an Airplay device in Roon ad MacOS, even while it’s doing nothing now.

So, what do I do now, can I get a file to flash it with a USB stick?

Please power down the whole network of devices, especially the router, WiFi access points, switches, Roon Core, Lumin, all mobile devices.

Wait for a few minutes, power up the router. Wait for 5 minutes, then power up the access points and switches. Finally, the other devices.

If this does not work, describe the whole network of devices (state the brand and model of everything) and how everything are connected together. And try bypassing the switch - connect the Roon Core and the Lumin to the router. If this works, your switch is dead.

In Asus router setting for LAN → IPTV, enable Multicast Routing.

Then reboot all devices again.

On Lumin front panel, you should see a progress circle displayed if it boots up normally.

Nope, and I just tried with my old Netgear Nighthawk X8 as well.

Nighthawk X8 straight to Lumin U2 Mini, only other device connected was iPad.
U2 mini not detected in Lumin app although it is connected as I can see in the Nighthawk app.
Front panel still shows “Leedh Processing” and stays like that, even after a fourth reset.
When I reset it it ask for a update file on removable media.

So it’s not the router (tried 2), not the switch (didn’t use one) and not the cables (tried a few).
Would it help if I had the newest firmware on a USB stick?
I haven’t updated the firmware in a long time, unless it autoupdates?

Does the “Leedh Processing” that remains on the screen mean it doesn’t boot succesfully?

That is not normal.

Please check e-mail for further instructions.

Got the mail, thank you very much!
Early morning here now so I will try it when I get back from work.

Meanwhile, may I ask if my settings for IPTV are correct?

I think so (but I’m unable to check against my home Asus router at work right now). The multicast routing setting may be related to Roon discovery on some models of Asus routers.

Succeeded to update the firmware with the file you sent me.
After that it asked to attach the network.
Turned it off, connected network and DAC with DAC turned on on the USB input.

Problem remains, front panel keeps showing “Leedh Processing” logo, network lights on the back flicker.
The device does not show up in the Lumin app or Roon (not even as an Airplay device anymore).

Please check e-mail.

Did so, thanks.

Was there a resolution to make this work?

I am having the same issue with my U2 Mini.


Is there a workaround to make this work?


I got a firmware file to flash it with a USB stick from Peter but no result.
The U2 Mini is sent to the distributor now.

Did it also start by the U2 Mini not being recognized by the Lumin App?

Yes it started for me with saying Qobuz media was loading slowly. Then it got worse from there.

Mine acted normally for a few months, then all the sudden it wasn’t even found by the Lumin App anymore, nor Roon.

A reset gave me the screen you have now and even update firmware from a USB drive didn’t fix it.
So now I’m waiting to get it back from the distributor, hoping it will again be detected then.

1 Like

Since we have been corresponding in e-mail, please check e-mail.

I reached out to my distributor to hopefully get things sorted out. The USB update didn’t work for me either.

Shipping from dealer to distributor, then to us, takes time. I’m sorry about the time it takes. I’ll ask our service staff to see if they are aware or have processed an order from Belgium.

1 Like

Thanks Peter!