M3U Playlist Support

I am having a similar issue, but I’m using relative paths and all of my m3u playlist files are within the folders where the music files are.

Some of my m3u files in some of my folders get imported, while others don’t. When I open the m3u playlist files of one that works and one that doesn’t, everything appears to be the same (both just list the file names of the tracks and nothing else/extra.

Any ideas on what else to try?

I used kid3 tag editor to create ALL of the m3u playlist files with the same exact options. I forced a rescan to no avail. I also tried turning off “import playlists” in storage, saving, then going back and turning it on and saving. Nothing changes (same ones come in, same ones don’t).

I’m at a loss on what else to try.

Is it possible that something is using a character that isn’t handled well by Windows?

My library is on a QNAP NAS running Linux based QOS. My Roon Server is running Windows 10. I used kid3 running on a Mac to create all of the m3u playlist files. I know that Windows can choke at times on characters that *NIX based OSes are fine with, so throwing it out there. I don’t see any characters that fit that description, other than emoji characters… but the m3u files that are coming in have the same emoji characters as the ones that don’t come in, so that can’t be it.

@Timothy_Federwitz, based on the age of the previous thread, I created a new support topic for you so the community can offer their suggestions.

1 Like

There are some good thoughts in this. Please keep in mind that you have access to that installation, we here not. So while you can compare working versus non working playlist, we don’t. Please consider sharing complete examples of working and non-working examples including screenshots of where the files are located and complete listings of the playlist file contents, either here on the forum or wait until official support shows-up and possibly provides you with another option.

Fair point. Here is an example of two folders configured nearly identically. I essentially created a compilation of songs by putting them in a folder and adding id3 tags to create the track order I want. Kid3 can then save the files named with the track number, artist and song title. Kid3 can also create the m3u playlist file using any number of variables, but I went with the same setting for each folder.

m3u playlist settings in Kid3:

The folders I am using. The 1950s one works, the 1960s doesn’t.

The 50s playlist in Roon

What the folders look like with the m3u file inside them, alongside the files they reference

(not working)

And, finally, each of the m3u files in TextEdit

(not working)


I’ve tried making multiple changes on each. I removed the emoji in the folder name, deleted and recreated each m3u file with the same result each time. Since Roon is real-time monitoring the storage, the working m3u file appears almost immediately upon creation. Nothing seems to work on the 60s version.

1 Like

I will add that I tried a different method as a “workaround”… but I’d rather get the m3u playlist working.

The method I used was to change the “album” on ALL of the tracks in the folder to the name of the compilation (e.g., “VA - Hi-Res Masters - 1960s”) and even replaced the “picture” with a common picture.

The result is a single “album” in Roon in the correct order that I can play like the playlist. The upside is that I don’t need the playlist with this method. The downside is that I lose the individual song’s album art. :pensive: I like being able to see the original art per song.

Now I’m even more befuddled. In looking for anything out of place, I noticed the playlist in Roon says 58 songs, yet I had the files named and numbered to 59. I then found I skipped 56, so I went back and changed 57-59 to 56-58. I corrected the file names and recreated the m3u playlist, just like I had several times before in this folder and, now the playlist won’t show up in Roon!! What did I do now?? :joy:

I don’t know why you expect this to work in Roon. The documentation clearly states that this isn’t the way to go.

From Importing playlists:

You are intentionally creating what is documented in point 3. as not working.

Note: To better understand the documentation you have to know that Roon expects that the tracks of an album are all stored in the same folder (optionally named by the album title) and therefore the author of the referenced document has used the terms synonymous.

“Why is this?” you may ask. Because the developers, like the author of the knowledge base article, think “Folder = Album” and in that case a playlist is just not needed, you can simply play the album. You figured out that part already.

“So why does one example work then?” you may ask. For Roon to know if a playlist is simply a listing of all the tracks in the folder, the playlist has to be read in and analyzed (eventually also compared to the files in the folder) to some extent. It seems that the method Roon uses here is simple and not very accurate – so you could trick it with your wrongly numbered tracks.

Really, what else did you expect? :rofl:

Sure you can now use the glitch/bug you found to trick Roon into displaying all your playlists that are of the same, documented as non-working type. Just be aware that this is glitch/bug-using and Roon may improve its software at any time, making your playlists ignored.


Doh! Now I get it… I had actually read that post too, but apparently wasn’t seeing what I was doing as number 3! Because, in my head, all these songs were from different albums I didn’t look at putting them in the same folder as “creating my own album”. :man_facepalming:t3:

Thanks for spelling this out for me though. You see, I was also trying to make portions of my library “portable” to more easily copy music AND playlists onto microSD cards for the two different DAPs I use. I guess I will either continue creating my own custom albums like mix tapes (tagging all albums as a new album) or find another way that will work in both Roon and my DAPs for playlists.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.