M3U Playlists gone [Ticket In]


I had over 15 playlists that were available with roon 1.6 but have since disappeared when I upgraded to 1.7. Nothing has changed with the playlists (location) but roon 1.7 will not show playlists. Nothing has changed with Ron settings either so it should import.



Weird. Mine are still there.

Check MP3 list import for your storage. Maybe it was disabled during upgrade.

Thanks Daniel. I checked and verified that it was checked. I removed my monitored music folder then added it again. Just waiting for it to complete the scan to see if that worked.

Strange that they were not there before. Nothing changed except for the 1.7 roon upgrade

Well removing and adding the library again didn’t work. Really not sure why it’s not importing

Anyone from Roon able to help how I can diagnose what’s happening and why it’s not importing playlists anymore?


You don’t have more than one roon profile set up by any chance?

Hi @Edward_LeBlanc,

Can you give some details on your Core machine and where your files are stored?

Can you share one of the m3u files that doesn’t work with us so we can take a look? You can share this via a shared Dropbox link or any other file sharing service.


I do not have more than one profile

Hi @dylan

The core machine (ROCK) is on an intel NUC. MY music is stored on a synology NAS. I access Roon on my phone (Huawei), iPad and PC (Windows). I create playlists using MusicBee (just to make playlists and export music to my iPod). The playlists are M3U format using relative file paths and stored in the root of the music folder. I use the Powernode 2i for playing music with Roon

The only thing that is different in the way I listen and manage my music is the upgrade to Roon 1.7. Prior to this upgrade all the imported playlists showed up in Roon.

Here is a link to a playlist

On a side note, the imported playlist show up and work properly in BluOS



Same issue to me. My configuration is quite the same like Edward‘s. Music stored on a Synology NAS and Roon is working on a Intel Nuc. Playlist (created with mp3Tag) showed up in 1.6 but not so in 1.7.

My playlists was also missing after upgrading to 1.7… I solve it by changing from backslash to forward slash in my M3U files:

.\Fleetwood Mac\Fleetwood Mac\01 - Fleetwood Mac - Monday Morning.m4a

./Fleetwood Mac/Fleetwood Mac/01 - Fleetwood Mac - Monday Morning.m4a

Thanks @VidarDK. I’ll give that a try later. Strange though that we need to do a work around for a problem that didn’t exist before the upgrade

Hi @dylan

Any idea what the issue might be?



@VidarDK. I did a test on one of the playlists and changed all the \ to / and it did work. Thanks for your help. Still not clear why this needs to be done just for ROON, when my other music apps recognize the original playlists

You are more than welcome, I’m glad I could help.
ROON must have made some changes to way paths are read between version 1.6 and 1.7

Hi Dylan…

Just following up to see if you were able to investigate



Hi @Edward_LeBlanc,

Apologies for the delay on this. After I saw your message I requested an update from the team. They did some testing with the M3U file that you shared with us and they weren’t able to reproduce this issue in our QA labs. They’re continuing to investigate this, but they’re hoping you might be able to provide some additional information about this file that you shared with us that isn’t working for you:

  1. How did you create this file?
  2. What OS was this file created on?


Thanks for getting back to me @dylan .

I use MusicBee on Windows 10 to create and export playlists. I’ve attached a screenshot of the settings. Nothing has chnaged with the settings prior to upgrading to ROON 1.7. The playlists use to appear in ROON and they also work in BluOS.

Thanks again


Thanks, @Edward_LeBlanc.

The team is working to reproduce this issue in our QA labs and I’ve passed this along to them. I’ll be sure to update you once I’ve received further feedback.