M4a file not seen in Roon[Solved]

Hi, I noticed that I have a m4a file that will not show up in Roon. The file was originally download from the itunes store and plays fine in iTunes. I have other m4a files that play fine in Roon but can’t seem to get Roon to see this one. Any ideas how to fix this issue?

I import all my music via itunes which saves the music files onto a external HD via a permanent thunderbolt connection. Roon then watches the external HD.

How old is this file? Could be that it’s protected (DRM).

Cheers, Greg

Not sure how to check if it has DRM but the purchase date looks like 2010. Have some older itunes downloads that work ok.

Sometimes converting to another file type (lossless) and then back with an up to date converter can solve format issues. Definitions of file types can change subtly.

Also try changing the name of the file. To maintain interoperability Roon will avoid files with deprecated characters in any supported operating system, so it can get stuck on files that are “legal” in Windows, for example, if they have an “illegal” name in Linux.

Hello @Paul,

Would it be possible to upload this file that’s not importing somewhere like Dropbox, and PM me a link? If you don’t have a way to upload them, let me know - I can give you some instructions for sending these files over.


Renaming the file worked to a degree. The song is now seen in roon. However its now showing as a completely different artist!

I’m happy to send the file to you. Both the original and renamed version.

Many thanks for everyones help.

For me Roon imported both tracks: the renamed one and the original version. Though imported track was misidentified. I think that has happened because of the file tags. Try this:

Album title - Hôtel Costes, Vol. 12 and not Hôtel Costes 12 By Stéphane Pompougnac (Digital Exclusive Version)
Album Artists - Stéphane Pompougnac and not Unforscene

It is also a good idea to collect all tracks of this album in one folder.

Renaming the file as you suggested worked. Thank you.

The problem has been solved but for what it’s worth… I’m not sure what the newer iTunes DRM files show up as but I believe the older iTunes DRM files were labeled m4p rather than the normal m4a.

FWIW I had lots of “old” iTunes DRM files, I ended up burning all albums on CDs and ripping those back to digital - then they became m4a files & perfectly identified by Roon (and any other music software). A bit painful but definitely a cure.

I’m having the same issue but the tips above aren’t helping. I’ve tried importing a .MOV and .m4a tracks. They show up in the import folder in Roon Imports, but I cannot find them when searching in Roon