Mac Mini issues with Marantz AV 8801

I am using a Mac Mini to run Roon Core. I output the Mini to a Marantz AV 8801 processor, then to a power amp, etc. I use an iPad Air to control Roon. I am currently just using Tidal for music although I hope to rip my CDs to Roon in the future.

My Mac has a 2.6GHz Dual Core Intel i5 processor, 16G of ram, 256G flash hard drive.

I connect the Mac to the AV8801 via HDMI. The D to A occurs, as I understand things, on the Marantz.

When it works, it works great. The sound is good and the interface is great. But it doesn’t work all the time.

Sometimes, I just can’t get the Marantz to play what is coming out of the Mac. To get it to work, I play with the the selector dials on the AV8801 and much of the time, it begins to work. Not always, though. Other times, I will be enjoying music via Roon and everything will go dead. Then, I bang on the Mac keyboard, play with the Marantz selector dials, etc. and sometimes, I get everything working again. Sometimes, I just have to give up.

It’s frustrating. I must say that these problems are much less frequent since version 1.5. But they still happen. Interestingly, these issues do not occur with other signal sources. The cable box, the Oppo DVD player and the Roku streamer are immediately recognized by the Marantz and perform, well, flawlessly.

Any ideas?

Thanks for reaching out to us, @Timothy_Good, and apologies for the frustration here.

So we can gain some additional insight into what you’re experiencing, may I ask that you please verify the following:

  • Have you noticed any patterns in when this behavior occurs? It sounds like it doesn’t always happen, so knowing any similar patterns would definitely help us narrow down why this behavior may occur. Are there other applications in use at the time? Are you playing any specific type of content? Are there any error messages that disaply?
  • Do you have any other endpoints that you play to? Can you confirm whether this behavior only happens with this one endpoint or if others are affected as well?
  • Could you try enabling the “Send stereo/mono content as 5.1/7.1” toggle and seeing if you notice a change in behavior? You can find this toggle in the Device Setup screen for the Marantz zone under the “Show Advanced” fold.
  • Has the Mac gone to sleep in these cases, and you’re using the keyboard to wake the machine?
  • What dials are you using on the device that sometimes gets it to work? Have you noticed any specific settings that seem to help?
  • Have you tried using a different HDMI cable for the connection?
  • I assume the answer is yes, but since noticing this behavior have you power cycled your Core machine and the endpoint?


Hi Dylan,

Thanks for your willingness to help.

First, the Roon core signal goes over a wire, an HDMI cable to the Marantz, which I think is what you mean by “endpoint”. I haven’t yet started using any other endpoints. I guess I’m worried about additional frustration.

I don’t really see any pattern to the behavior. Sometimes I select the Mac input on the processor, fire up Roon and the iPad controller and everything works. Other times, it just doesn’t. I updated the firmware on the processor but haven’t detected any improvement in performance, i.e., reliability. Nothing other than Roon is running on the Mac. No error messages. Just playing jazz via Tidal. You don’t think it’s a jazz issue, do you?

The Mac going to sleep is a suspect to me, too. I’m a PC guy but I have a Mac consultant working with me on this project. I will ask him to review power management. Power management is not the issue when I begin using Roon, however.

The dial on the Marantz that I bang on the most is the input selector. It’s funny, as I rotate the dial to the Mac input and away again, sometimes the signal from Roon starts coming out of the Mac internal speaker and sometimes out of the internal speaker on the monitor. When that happens, I know I’ve almost got Roon running. On good days, a couple of more fiddles on the Marantz input selector gets Roon to play through my audio system and I’m a happy guy.

I haven’t changed out the HDMI cable but I have done cold boots on both the Mac and the processor. Many times.

I will point out that when things are successful, the Marantz goes through a handshake process. The display on the front panel shows that the source is HDMI, etc.

Thanks again for your help


Thanks for the updated info, @Timothy_Good.

Could you try enabling the “Send stereo/mono content as 5.1/7.1” toggle and seeing if you notice a change in behavior? You can find this toggle in the Device Setup screen for the Marantz zone under the “Show Advanced” fold.

Can you also share a screenshot of the signal path when playing to this device?


Hi Dylan. I don’t see the toggle for send stereo/mono. The only item under advanced is “multichannel mixing” and the options there are channel mapping only and down mix as needed. Also I’m not sure how to send you the screen grab you requested. Thanks for the help.

Thanks for the update, @Timothy_Good!

Are you connecting to the Marantz via airplay? Can you share a screenshot of the signal path you’re using? You can copy the screenshot directly into your response and it will be included with your message.



I am connecting to the Marantz via HDMI, not Airplay. Not being terribly familiar with Macs, I am not sure how to show a picture of the my signal path. But in words, I have a cable from the HDMI port on my Mac that goes to the HDMI in port on the Marantz.

Thanks for your diligence in helping me find the solution to this issue.


Hey @Timothy_Good,

Apple has a great article here about how to take a screenshot on Mac.

You can find your signal path in Roon by clicking the colored dot next to the song name that’s playing toward the bottom of the screen:


When you click it, you will see the signal path.

Take a screenshot using the method listed in the article above (Press Shift-Command (⌘)-3) and then you can find the screenshot on your desktop and drag it into the textbox for your response.

Please also include a screenshot of device setup for the Marantz.



Above are two screen shots, one for the Roon signal path and the other for what I think is the signal path for the Marantz. Hope this works.

Thanks, as always. Tim

Thanks for the screenshots, @Timothy_Good!

If you go to Settings > Audio, rather than using System Output, do you see the Marantz as an option you can enable? If so, try enabling that, and then in Device Setup select the option for Send stereo/mono content as 5.1/7.1. Then choose the Marantz as the zone you’re playing to instead of System Output.



Here is a screen shot of when I go settings>audio. I don’t see the Marantz as an option for output but I do see the Marantz apparently accessed via Airplay. I have found Airplay rather unstable in other contexts so have avoided it. Could this unstable connection be my problem?

Try using the HDMI zones that are attached to the Core. Give them both different names and see if one of them works with the Marantz.

Cheers, Greg

1 Like

Hey @Timothy_Good,

As Greg mentioned above, try both of the HDMI outputs on the Mac. When you find the correct output you should then see this option Send stereo/mono content as 5.1/7.1.



Because of the issues I have raised on this forum, I decided to bail on using the Mac Mini as a Roon core. I just took delivery of a Nucleus and so far, so good.

I am connecting the Nucleus with my Marantz AV 8801 via HDMI. It works and sounds pretty good.

I would next like to connect the Nucleus with a NAD CI 940 to drive the outdoor speakers. To do this, I connected an Audioquest Dragonfly Red to one of the USB ports on the Nucleus and then used an analog cable to the NAD. It only works OK. Is the Dragonfly Red a Roon supported device? If it’s not, can you recommend a similar product that is?