Mac mini (M1) won't see NAS folder (Synology)

Hi there fellas,

I usually research like mad before I post anything in order to avoid pollution on the forums but it seems I’m really stuck with this one. And since I’m a life time member, I need to fix this.

I’ve changed my core recently, set up my Mac mini M1 as the main machine and I’m having hard time adding the music folder in my NAS.

I’ve tried bunch of things, but so far no luck… Allow me to attached the screenshots here for your reference. It would be great if you could shed some light on this matter.

All the inputs are greatly appreciated.


Looks like you have connected your NAS via afp (the use of afp is no longer recommended, even from apple itself) to your mini.

Try to connect via smb, maybe your Synology NAS didn’t have smb enabled. I would also connect via IP-adress, like smb://


Hello @Osman_Aydogan,

In the screenshot you provided you are using the “SMB” prefix with a locally mounted directory. This would be equivalent to typing “SMB://MacintoshHD/Documents”.

To connect to your Synology share you should try the following:

A) Determine the IP address of your Synology.

B) Once you have the IP address of the Synology, enter the following Network share location in Roon:

smb://ip-of-synology/NAS Storage/Music

C) Enter your credentials and click “Add network share”.

If this doesn’t work, you should check that SMB is enabled in the Synology NAS settings.


Thank you very much for all the help John. I’ve disabled AFP and only SMB is enabled.

Problem fixed now.

All the best,

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.