Mac mini to dac Roon stopping

Core Machine (Operating system/System info/Roon build number)

Mac Mini

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Virgin Hub3 Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  1. Mac Mini/Toshiba HDD/BluSound Node 2i/Optical to Benchmark DAC2

  2. Mac Mini/Toshiba HDD USB from Mini to Benchmark DAC2
    Description Of Issue

  3. Works perfectly

  4. Works perfectly for 30 seconds then sound stops then stream stops. Hit pause and play works perfectly then stops

Can you detail more specifically the models of the macs cpu RAM disk types etc.

My gut feel is that you are probably suffering some lack of performance with your core at least not able to cope at all.

Maybe some details about your network will be useful too, and your internet connection if you are streaming from online services. What’s using WiFi and what’s lan wired.

Check this post out Suggested hardware

1 Like

Mac Mini mid 2010 2.66 ghz Intel core 2 duo memory 4gb 1067 MHz DDR3
BluNode and mac mini are wired, Network functions well - what details do you need.

Ok a 2010 macmini is not going to cut it for roon imho. Do you have a more recen machine to run the core on to test at least?

Hi @Alastair_Romanes,

As wizardofoz mentioned, your Core definitely falls below our recommendations, which can impact performance and cause issues like what you’re seeing.

Does the Mac Mini use an SSD? How many tracks total are in your Roon library?

My library is about 1000 cds. I have a MacBook Air as well which I could use to test. The mini copes perfectly via the Node 2i and previously with a microRendu and a Topping amp so I suspect I may be missing something elementary here. The mini doesn’t use an SSD as far as I’m aware.

So is you described issue 1&3 are one setup that’s ok and 2&4 are are the issue? If so your details are a bit hard to determine

Are you doing any dsp like up sampling?

Thanks for replies. I’m sorry - I just noticed the automatic numbering took over - it should read

  1. First Setup - works flawlessly
    2.Second setup - problematic

I’m not doing any upsampling. Is there any reason why Roon shouldn’t play flawlessly via usb direct from mini to Benchmark? Does it require another device in between mini and mac?

how long is the USB cable?

Have you tried a different cable?

What bitrate files are you playing.

can you post a screen shot of the audio path of the offending setup

Hi @Alastair_Romanes,

As wizardofoz suggested, definitely give another USB cable a go and please share a screenshot of both your Signal Path when playing to this device and Device Setup for this device.


USB cable is 0.5m length - no change when replaced. Here’s the screen shots

Hi @Alastair_Romanes,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

I can’t reproduce the issue because both the mini and the Benchmark have disappeared from view even after a Roon Server reinstall. See the attached screenshot

Hi @Alastair_Romanes,

Can you try temporarily disabling the firewall on your Core machine and see if the devices appear with the firewall disabled?

The firewall isn’t enabled.

Hi @Alastair_Romanes,

Since reinstalling have you tried rebooting your Core machine that these devices are attached to?

Something, perhaps the reboot, has solved the problem. Whatever, thanks for your help and patience which reassures me if I needed it that my lifetime Roon purchase was great value for money. Incidentally Wizardofoz thought my 2010 mini not up to running Roon. Although it seems to be working ok now, do you advise an upgrade?

Hi @Alastair_Romanes,

Glad to hear that things are working for you now!

As mentioned before, your Core machine doesn’t quite meet our recommendations. With an underpowered CPU and no SSD, things may run for now, but there is definitely the possibility that you will experience performance issues. This is especially true for larger libraries and when using DSP Engine.

If Roon is running currently on your machine you can continue to use it, but if you’re experiencing dropouts, slowness, or other performance issues, an upgrade would likely be the solution.

Hope that helps!

Thanks again

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.