Mac network interface binding

Roon Core Machine

iMac 2017, i5, 32 GB of RAM

Networking Gear & Setup Details

Ethernet mostly, wifi sometimes (see below)

Connected Audio Devices

Several, but not the problem (I assume)

Number of Tracks in Library


Description of Issue

  1. My roon server is on my iMac that is connected by wire to my network through a thunderbolt dock.
  2. Whenever I disconnect the thunderbolt dock (because I need to connect my laptop) the roon bridge goes into ‘unavailable’ mode. I understand the network interface becomes unavailable.

expected behavior

  • Roon bridge is not only bound to the wired interface, but also the wireless interface.
  • If that is not true, how can I prioritise the wifi interface over ethernet? Do you use the priority set in the network interface of MacOS?


If you select ‘Set Service Order’ you’ll be able to drag Wi-Fi to the top of the list. This will (hopefully) solve your immediate problem but may cause other issues (Roon works best when hard wired).

1 Like

yeah I figured that much - I might just use the iMacs’ hard wired connection instead of my TB docks’, thanks for the suggestion!

1 Like

Hey @Casey_Romkes,

Thanks for choosing to reach out and share what you’re trying to find a solution to. We’d love to help as well.

Did @DaveN’s suggestion make a change? Thanks @DaveN :pray:

1 Like

Hi @beka! Yes I’ve solved it by setting the primary network connection to be a different one, that worked!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.