Mac OS app crashes intermittently after running a short while [Roon Investigating]

Roon Core Machine

MacOS 12.6.1 (Monterey), MacMini (2018) 3 GHz 6-Core Intel Core i5 with 32GB RAM

Networking Gear & Setup Details

FiOS drop to Firewalla Purple to tp-link TL-SG1024DE switch to Mac. All ethernet connection without VPN

Connected Audio Devices

System Output

Number of Tracks in Library

100,182 tracks

Description of Issue

Roon app intermittently crashes. Multiple crash reports sent to Apple. Start of one:
Translated Report (Full Report Below)

Process: Roon [16736]
Path: /Applications/
Identifier: com.roon.Roon
Version: 1.0 (1.0)
Code Type: X86-64 (Native)
Parent Process: launchd [1]
User ID: 501

Date/Time: 2022-11-25 21:56:15.9753 -0500
OS Version: macOS 12.6.1 (21G217)
Report Version: 12
Bridge OS Version: 7.0 (20P411)
Anonymous UUID: B433F9A7-C2A8-8929-0F90-5F6DAC38B35C

Time Awake Since Boot: 1400000 seconds

System Integrity Protection: enabled

Crashed Thread: 59 .NET ThreadPool Worker

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
abort() called

Thread 0:: Dispatch queue:
0 libsystem_kernel.dylib 0x7ff804b2a97a mach_msg_trap + 10
1 libsystem_kernel.dylib 0x7ff804b2ace8 mach_msg + 56
2 CoreFoundation 0x7ff804c2e36d __CFRunLoopServiceMachPort + 319
3 CoreFoundation 0x7ff804c2c9f8 __CFRunLoopRun + 1276
4 CoreFoundation 0x7ff804c2be3c CFRunLoopRunSpecific + 562
5 ??? 0x11ea26f95 ???
6 ??? 0x11f0e5e9d ???
7 ??? 0x11e587408 ???
8 ??? 0x11a69e177 ???
9 ??? 0x11a5f07fa ???
10 libcoreclr.dylib 0x10a6a08b9 CallDescrWorkerInternal + 124
11 libcoreclr.dylib 0x10a4eccba MethodDescCallSite::CallTargetWorker(unsigned long const*, unsigned long*, int) + 1530
12 libcoreclr.dylib 0x10a4eccba MethodDescCallSite::CallTargetWorker(unsigned long const*, unsigned long*, int) + 1530
13 libcoreclr.dylib 0x10a4eccba MethodDescCallSite::CallTargetWorker(unsigned long const*, unsigned long*, int) + 1530

Bump. If anyone can tell me how to get support in another manner, happy to do so. I’m trialling Roon and this isn’t a good start …

Based on the “Crashed Thread: 59 .NET ThreadPool Worker” in your crash message, I suspect it is this issue:


Hi @Steve_Epstein,

There is unfortunately a known issue with Mac OS that the team is investigating with a high-priority ticket. @Suedkiez has helpfully linked the main thread above. As mentioned, the thread crash listed in Apple crash report suggests this is a related symptom.

A few questions to help the tech support team investigate and resolve your situation:

  1. Are you able to upload the entire Apple crash log at this link so our team can investigate?
  2. Does this crash occur when you have Roon minimized and then attempt to open or adjust the window?
  3. In the meantime, it can refresh conditions to create a new Roon database and restore a Backup:
  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup
  1. I uploaded the entire crash log
  2. The crash does NOT occur when Roon is minimized. Usually, I have Roon in the background when it crashes, but not minimized.
  3. Bear in mind that I’m running Roon on NAS (DS920+ on DSM7). I had created a core on my Mac at first, but because Roon keeps crashing, I would never have access to my music reliably (since the Core would be offline). By contrast, Roon on NAS has been rock-solid, and I can access that Core through the MacOS app. So …
    a. I created a backup
    b. Exited Roon
    c. Found my RoonServer folder on my NAS and renamed it as “RoonServer_old”
    d. Reinstalled the Roon App from the downloads page.

When opening the Roon app, I see the following message: “There was an issue loading your library. To avoid data loss, restore a backup now or head over to our Help Center for more information.” There is a single button “Restore a backup” and no option to create a fresh database.

Please advise.

BTW - happy to merge this to the main thread listed above if that’s more appropriate. I’m just not sure how to do that short of simply copying some of this.

I am having this problem as well. I’ve uploaded crash logs.

I’ve tried using the Early Access build (the current one is 1180 – which is a smaller number than the release version build 1182 – this seems weird?!) to no avail.

I’ve also tried backing up / restoring my database, restoring a few-days-old version from before I was having the intermittent crash problem. That didn’t help either.

Core runs on a Mac Mini (2018, 3.2 GHz 6-core i7, 32 GB RAM, MacOS 12.6.2); music files stored on a Synology DiskStation DS1019+ (DSM 7.1.1-42962 Update 2); connections all wired through a Ubiquiti UDM Pro / Ubiquiti switches / Gig Ethernet). The setup was absolutely stable using multiple playback devices / zones until a couple days ago (when I updated to build 1182) – and now I can’t keep the Core running for more than 15 minutes even if I don’t try to play anything.

Praying for a quick resolution so I don’t have to use Spotify through the holidays!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.

I have same issue,toooooooo!