Mac OS Sierra is out [Roon B161 supports it]

Is there any update on when this will be fixed?

USB is working with a Chord Hugo but not a PS Audio DIrectstrean

In my experience that’s no indication of it being stable, or all the relevant programs one has installed having been updated and stable also. But I’m cautious because I don’t like it when things stop working… :wink:

The SMB issue has a fix in the next bugfix release, which is in the last stage of testing.

The USB Directstream issue is still undergoing investigation.

1 Like

I’m rolling back to El Capitan

When can we expect this to be fixed? I hoped it would be a matter of a few days but it’s been a week now.

Our fix went into testing at the end of last week but some issues were found over the weekend, so now the process is starting again.

It will be out when it’s stable, not before :wink:

2 Likes

While most will want the latest yesterday sometimes even tomorrow is too soon. We should all be happy to wait for a good release and not get impatient.

day after tomorrow should be good right :grin:

Respect for keeping us informed and not releasing prematurely :grinning:

It seems roon was cought by surpise! Sierra was out in beta for months. Was no testing done before release?
Hopefully roon wont make this same mistake again and will make sure it’s fully compatible with the latest major operating systems.

I asked some time back here Mac OS Sierra and iOS 10 - Has any testing been done yet?

I think that in order to avoid all these, Roon Labs should adopt finally AFP instead of SMB mounts in the future. How possible is this?

roon dropped support of AFP. I used to be able to connect using AFP last year

As of Mavericks, AFP has been deprecated by Apple, promoting SMB2 as the standard protocol.

AFP is old and advised only for Time Machine backups and compatibility with older systems. See: https://www.apple.com/media/us/osx/2013/docs/OSX_Mavericks_Core_Technology_Overview.pdf (page 21, Network File Systems).

Apple made major changes to the mounting of SMB shares at the default location /Volumes (these used to made at user level, but now require root permission). A fix for Roon is currently in testing and will available soon.

As a general rule of thumb, it is wise not to upgrade production systems (basically anything you rely on to perform a task reliably) to a new OS release until the .1 update is out and the software you rely on has reached full compatibility.

As for betas being available for some time: while this is true, Apple is known to make far-reaching changes during its beta cycles. IMO, chasing compatibility with a OS that is still in flux would be a waste of resources.

2 Likes

Both my external drive on the airport extreme and my nas automatically mount using afp in finder. This was the case with every OS so far…also Sierra.

I need to set it manually to make these drives mount using smb by using “connect to server” and changing the server address .

I guess Apple need to get onboard with all their devices an align them with their policy of AFP deprecation.

But I think we are drifting quite a bit of topic now.

It looks as I gave you missleding information. Sorry for your trouble. Hope it will be solved soon.

Build 161 just went live with a fix for this, guys.

Let us know if you have any additional issues, and thanks for everyone’s patience.

In light of getting my hand spanked for starting a new topic and “fragmenting” the discussion I did not find the answer to my question that was locked. Is there any consensus of how this is working with Sierra now? Good to go?

Thanks,

It’s been tried, tested and working perfectly fine as of Build 161.

If you are using a USB DAC requiring special drivers, you may want to check for compatibility issues first though.

Thanks!! Appreciate the info!