Macbook Pro Core - Can't locate audio devices

Core Machine (Operating system/System info/Roon build number)

Macbook Pro - Catalina - Roon version 1.7 (build 511)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WI-FI Linksys E3200

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  1. Macbook USB to IFI Zen Dac
  2. Macbook USB to Peachtree Nova DAC
    3 WIFI to Logitech Duet

Description Of Issue

Since the update to Catalina OS I’ve been having constant fails with audio devices recognition. It happens while playing but also after rebooting the core (macbook). The audio setup shows that it can’t get past searching for Squeezebox devices (picture attached). Need to constantly reboot the router and after a couple of reboots it comes back to normal.

Hi @Rodrigo_Castellanos,

Welcome to the forum. Can you please check to see if you have any active firewalls which could be blocking Roon from operating properly? In the past, we have seen McAFee/Bullguard/Kaspersky/Little Snitch impact Roon in a similar way, I would also check to make sure that Roon is added as an exception to your OSX firewall, you can use these instructions to check the OSX Firewall aspect.

Hi @noris

It’s the Mcafee Total Protection firewall. As soon as i deactivate it, roon runs normally. The problem now is that I can’t just include roon as an exception as it can be done with Catalina’s firewall (deactivated btw), since Mcafee requires TCP/UDP configuration to include an exception. Any thought will be greatly appreciated.


Add images

Hi @Rodrigo_Castellanos,

Roon uses dynamic ports, so there is no specific port range that I can suggest you add.

Instead, what you should do is add an “application level” exception, where McAFee does not interfere with Roon communication.

These instructions from McAFee might help, but if you still need further assistance afterwards, I would reach out to McAFee technical support:
McAFee Firewall Instructions

Thanks for your assistance. Actually that doesn’t help much since there is no “Internet connection for programs” option or window or tab… however, just changed the basic settings of the firewall (previously was selected the “public network” option and changed it to domestic/private) and its been working correctly for the last couple of hours.

I might need to give it some time to evaluate if that finally resolved the issue. I’ll come back to you in the next few days.

Again, thanks for your support.


Hi @Rodrigo_Castellanos,

Sounds like a plan, do let me know if the system is still stable after a few days!

Wells, it’s been a while now and haven’t had any problem whatsoever. So it’s safe to say that even that particular version of McAfee Total Protection doesn’t allow to exclude specific programs, there shouldn’t be a problem as long a you make sure to identify your network as “home”.

Thanks Noris for your support.


1 Like

Hi @Rodrigo_Castellanos,

Thank you for the update, glad to hear that the system is stable since making the McAFee change!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.